Announcement

Collapse
No announcement yet.

Wierd Lighting Problem.

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Wierd Lighting Problem.

    Ive tried everything I can think of to get this to stop.

    I have made a simple wall mesh + Collision and added a brick texture to it and i set up a small . VERY small room to test shadows. Its 2 small walls in the centre of a larger floor so I can walk arouynd the edges.

    Anyways I placed a light in the middle near the walls and on the inside where its lit everything is fine but when you go look around the edges and back the surfaces are lit. Almost like they are emitting light yet these sides should be in 100% darkness because no light is hitting their surface. I know its no the texture as its just a standard texture with normal map and the model is just a box. Any Ideas?

    Also when I remove the standard Inventory when i look down there are 2 floating ball things that must be the mesh of the hands or something and I dont have a clue how to remove them. They are annoying. Hehe

    #2

    Comment


      #3
      Go to your World Properties and then Lightmass and uncheck Use Global Illumination.

      Generally you would want GI but to get pure black there you need to disable it. GI calculates light bounces.

      Comment


        #4
        There's a quick fix you can do in Kismet to get rid of those floating balls, hide the player.

        The setup looks like this, just UNCHECK all those options you don't want. I'd suggest hiding the player and hud if you want a clear screen.
        [shot]http://chrisholden.net/udk-kismet-cinemode1.jpg[/shot]

        Comment

        Working...
        X