Announcement

Collapse
No announcement yet.

Road tiling problem

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • replied
    It looks like they do not have normal maps, is that correct?

    If they don't, then it is a geometry error. A wireframe would probably help.

    Leave a comment:


  • replied
    Here's one take on a solution:
    http://www.chrisalbeluhn.com/UT3_Nor...pec_Issue.html

    As a last resort, you could always try using the custom lighting option in the material. You may be able to get rid of that with a custom light solution that forces computing the light angle vs the reflection vector with some smoothing so that it won't reflect at odd angles around the edges. May not work either, but it'd be an option to try if nothing else works. Maybe make a cube map and apply that as a filter so that full light can hit from every angle since its a plane anyway, you shouldn't mind the sides and angles being lit.

    Leave a comment:


  • replied
    Do those road meshes intersect with each other? From pictures it is for sure lighting artifact. May be because of smoothing groups, shape of edge (overlapping parts with next mesh that put some vertexes in dark).

    For road meshes turn off all shadows, leave only accept lights, dynamic lights etc.

    Leave a comment:


  • replied
    If you turned off the SSAO and shadow casting note that smoothing groups are ignored for open edges - in case you used ASE ff; and make sure that lightmap UVs are snapped to the full pixels.

    Leave a comment:


  • replied
    Well ive been playing with ideas all day with no luck.
    But i have come to a semi fix. its still there but not as noticable. I have just lowered the lightmap res and its not as bad. Just means other shadows on the mesh aren't as good, but it will do :-P i haven't really got enough time to fiddle around with this problem for much longer lol.
    Cheers for everyones help. Didn't think i would get this much responce :-) Gives me faith in the community :-)

    Leave a comment:


  • replied
    I think it is because it is not 1 mesh, the road is a lot of meshes one near other and lightmass or/and ambient oclusion go crazy. Solutions:
    1- BSP.
    2- Scale 1 mesh in X, remove others and tile the texture with TextCoord in material editor.
    3- Merge all road meshes in maya.
    4- I don't know.

    UVs are ok? no overlapping?

    Leave a comment:


  • replied
    Yea i tried upping lightmap res no change. I am doing a production render now. will take awhile so will get back to you on that one.

    I don't think it would be a texture problem as the lighting only has the error. But will try it out after i render.

    I have also set them so they don't cast shadows at all. although i could have used the wrong button :-P

    And yea i would rather not use bsp.

    Here are some shots with the different viewing modes.



    By mageslain at 2010-10-07


    By mageslain at 2010-10-07


    By mageslain at 2010-10-07

    Leave a comment:


  • replied
    Originally posted by Mageslain View Post
    This is the result of that. :-S no change really.

    Any other ideas? :-(
    Are you sure it is not a texture problem? Use a material with a plain texture on it (material with a constant at 0.7 or 0.6, in diffuse channel) and make a screenshot.

    A wireframe screenshot too.

    Leave a comment:


  • replied
    Originally posted by ikifenix View Post
    Why don't use BSP to kill the shadow problem between mesh and material with Lerp to kill tile?
    Maybe because he eventually gets same problem with walls, trims or something else. It is better to know solution to it than workaround.

    Leave a comment:


  • replied
    Why don't use BSP to kill the shadow problem between mesh and material with Lerp to kill tile?

    edit: Fast road with bsp + lerp (still have tile, i did it fast).

    [shot]http://img833.imageshack.us/img833/2918/roadb.jpg[/shot]

    Leave a comment:


  • replied
    Try setting them to cast shadows only on themselves. Or maybe even disable shadow casting completely.

    Leave a comment:


  • replied
    How road looks in lit without textures mode, and how road mesh is done? Those errors may be from lighting on edges, or material normal. Such errors are quite common topic here, if you use search it may be faster than waiting for responses.

    Leave a comment:


  • replied
    Have you tried increasing the lightmap res? have you also tried this with production quality lightmass?

    Whenever I get seams like this they usually go away if I use production quality lightmass or up the res of the lightmap and or both.

    Leave a comment:


  • replied
    This is the result of that. :-S no change really.



    Uploaded with ImageShack.us

    Any other ideas? :-(

    Leave a comment:


  • replied
    i think it is same problem:
    http://forums.epicgames.com/showthread.php?t=745816

    Leave a comment:

Working...
X