Announcement

Collapse
No announcement yet.

Serious problem with shadows

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Serious problem with shadows

    I use pointlight with default settings and I get bad Kactor (bricks) shadow and no static mesh shadow (pipe) http://img715.imageshack.us/content_...ng&via=mupload. If I retreat I get no Kactor shadows and no static mesh shadow http://img408.imageshack.us/content_...ng&via=mupload. I want that my shadows by relistic and visable all the time. How can I do what?

    Sorry Im speaking english bad

    #2
    First of all make sure you are using the latest UDK version

    Second thing, not all light sources allow static shadows [make sure your light source has it turned on and the static mesh set to receive and drop them].

    An other thing i've discovered is when you want to have self shadows on static meshes when using non dynamic/scattering shadows [possible only with dominating sun or direct light], you should go to your mesh options window [the one you get by pressing right mouse button in the assets browser on the mesh thumbnail] in the window that opens with the mesh appears on the left and the properties on the right. There in the top first menu, you have option "generate custom UV's" i am not sure exactly how it's spelled, but it opens some options on the right of this window, and after you generate them custom UV's, you will start having self shadow maps on the mesh. In the same right list of model settings, there is an option that allows you to set up the resolution for those shadow maps. No need to make it very high but by default i think it is set to very low resolution.

    Sorry i couldn't be very specific but i hope it helps...

    Comment

    Working...
    X