Announcement

Collapse
No announcement yet.

Kismet Material Param not working on Particles?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Kismet Material Param not working on Particles?

    hello,
    I have a particle emitter that I'm using to create some clouds. anyway I'm trying to animate the colors via Kismet and Material Params (R, G and B are constant Params appended into a vector color) to match my day and night cycle, the problem is the color changing don't seem to work on particles. I have the same material (the instance) applied to a plane and it does appear to work though, my colors change as my Kismet animation changes the values.

    so is there anything special I need to do so that particles can react to Kismet Material Param changes?
    thanks

    #2
    Is it a time varying material instance? If not you may want to try that route.

    Comment


      #3
      thanks for the idea but nope, that didn't work either
      the material seems fine, as I said the same material works if I apply it to a regular mesh. it's just on particles that it doesn't work :/

      if it can give any clue as to what's wrong I'll provide some more info:
      I'm setting my particles as lit, my material is translucent/phong and the params I'm changing in the material are the diffuse (which I use as lit color) and emissive (which I use as unlit/shadowed color)

      Comment


        #4
        Try changing it to unlit, and then modifying the values. I am guessing it will work.....

        I set up a kismet chain with an unlit material that modified the color value, and this worked just fine. You could probably easily fake your lighting by just multiplying in a "lightColor" particle color parameter that you modify in kismet. This would allow you to simulate not only color but brightness to fake day/night cycle.

        A lot of games do it this way. Hope that helps

        Comment


          #5
          thanks again for your help

          something I forgot in the main post: I'm chaning the values via Matinee, not plain Kismet.

          anyway,
          setting the material to unlit and the particle system to bLit=false didn't do it either
          thing is, when I apply a material instance to some geometry and change its properties through matinee, it seems to duplicate that instance and use it internally (ie. my non-particle cloud layer uses a material called CloudMat through an instance called CloudMatInstance, but if I activate matinee and I select the object in the editor, right click, go to 'materials' to see the name of the material, it says MaterialInstanceConstant_278).
          but in the case of my particle system, this duplicate / name change isn't happening,the material name is still CloudParticleInstance.
          however if I set some geometry with the same material, once I change its properties in kismet, and go rightclick-materials, the material name does change to something like MaterialInstanceConstant_X as well.

          incidentally, I tried setting the particle system's material to MaterialInstanceConstant_278 and it worked! however if I close matinee and open it again the material name changes again (from 278 to 275, etc). so it's not really a solution!

          However if I just take my CloudParticleInstance material, go to its properties and modify the variables that control the colors, they do affect my particles. It's just in matinee where it's not working.
          I'm thinking this duplicate thing isn't supported for particles in matinee but I hope I'm wrong

          Comment


            #6
            hmmm perhaps this is too particular/deep to be here. should I post it on the Support Tips and Advice section of the forum?

            Comment

            Working...
            X