Announcement

Collapse
No announcement yet.

water waves? / flickering water

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    water waves? / flickering water

    hi,
    I'm working on a large water volume, overall spanning some 5 kms, and I'm using a fluidsurfaceactor
    first I want to have some waves on the geometry. I've tried using a fluidsurface influence actor but my water volume is so big that the waves take at least a minute to come to my shores. plus you can clearly see the waves come from a point where the waves are a lot bigger (fluid_wave) or multiple spots (fluid_)
    so I tried making the waves on the vertex shader via worldpositionoffset, like this tutorial, but instead of having a waving surface, my whole surface just offsets up and down instead. perhaps it's related to using a fluidsurfaceactor? any other ideas?

    I'd also like to know if a fluidsurface can be trimmed, similar to how you can make holes on a terrain
    imagine you have a big island; having a huge water volume to surround it all makes you have useless water geometry below the island, but if you place separate chunks of water to surround it you'd end up with normalmap/specular/distortion/positionoffset/fluidinfluence seams.
    so how to do this?

    the second thing is about a flickering bug. I have the water shader set up with a reflection actor. the problem is that at close angles (ie. with the player near the water) the water flickers whenever I set the capture view mode to scenecapview_lit (as opposed to litnoshadows or unlit). the flicker seems to change from lit to unlit in a rapid succession.
    there's also another flicker whenever I use fog in the scene (with enable fog in the capture actor), and the flicker seems to change from seeing the fog, to not seeing it, in a rapid succession.
    the same thing happens if I use a post process, the flickering seems as the post process gets on/off in a rapid succession.

    for the flickering I've tried moving the scenecapture actor up and down, and the info found in this thread and this one, but nothing has worked.

    I hope someone can help me with this
    thanks!
Working...
X