Announcement

Collapse
No announcement yet.

Phase out huge package > 300mb

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Phase out huge package > 300mb

    I made the mistake of storing the majority of my assets in a central package- after I hit the 300mb mark, UDK let me know about it. So I've been moving items to smaller packages for characters, props, environmental, buildings, etc. But the issue is that the initial package still remains, and it has all of the original assets.

    How can I phase out the original bloated package without destroying the references in the map?

    #2
    I'm not sure if this is the best way to do this or not but it worked or me (I had a similar problem).

    What I did is I loaded up my level that is using the custom assets.
    Then from my main package I transferred all of my content into specified packages (as you had stated).
    I saved all of my smaller packages.
    At this point I had nothing left in my main package and so I saved that package as well.
    Then I saved my UDK map.
    I closed UDK and went into the package content folder and deleted my now obsolete central package (leaving the new smaller packages there of course).
    When I opened up UDK and loaded my level, my central package is now gone and my level is referencing the new smaller packages.

    before trying this I would create a backup of your central package and UDK level just for safe keeping.

    Hope that helps.

    Comment


      #3
      By renaming your assets inside that package. Rather than re-importanting all your models, simply right click the old ones and hit "Move or Rename" and change their package name to a new package. This will remove it from the old package (as long as you save the change) as well as put the meshes in the new one, without destroying any referencing. Anything you move, or rename will be perfectly fine in the map (as long as you once again, save the package after).

      Comment


        #4
        Yes, Move and Rename is KEY! Also, check the "Save Packages" checkbox. If you crash and lose data, it's gone, baby! You may want to fully load all your packages and load a level that uses the assets as IrishKiller suggested, but I haven't had any problems... well I did lose all my sound queues :/, but I don't know if that was me or the editor.

        Rest assured that if you use Move and Rename, it will re-link all your assets and references. Just don't blame me if it doesn't. Or be sure you have a backup :P

        Comment


          #5
          It won't rename in your scripts. Just a reminder.

          Comment


            #6
            When I reorganized my packages I had opened up a my level that was referencing them like what IrishKiller said, but when I saved them all out I forgot to save my level so the next time I opened up the level it was still trying to reference the old packages. Just to let you know to save your level after you set up your new packages so you don't have to redo them like I did

            Comment


              #7
              Or, don't open a level. I don't think it's needed, but I could be wrong :P It happened once before.

              Comment


                #8
                If you face problems of old package references coming up again, then run UDK with the 'fixupredirects' flag ("UDK.exe fixupredirects"). This will search through all packages and maps, and fix up all references permanently.

                Comment


                  #9
                  Thanks for the input. It all seems to be working fine. Although I'm finding that even breaking packages into smaller chunks leaves some categories still too large- I'm finding that textures take up most of my space. I ran a test, and I can separate textures from mesh packages, and work with them independently (or between other people), and the textures don't have an issue re-linking, where-as static meshes will be saved as null after saving a map when they could not be located.

                  Comment


                    #10
                    desigpa> that's because the materials that reference the imges are stored in the packages, so the references get updated automatically. Like i said about your scenes losing linking, I think it's because you've got the scene open. That's likely a bad procedure as it's unneeded and can cause some big issues as you mentioned.

                    As for your packages, you can organize them in any way you see fit. Texture sets can be in different packages than materials that can be in different packages than the meshes theya re applied to. How you organize it is completely up to you.

                    For example, i did a very high-res globe that required several layers of 4K textures to acheive the effect. I ended up with 6 or 7 100-200mb packages to acheive the single model and material:
                    http://forums.epicgames.com/showthread.php?t=732696

                    Comment


                      #11
                      Tom, thanks for the reply and the insight. The reason that the map is loosing linkage to its assets is a result of the package not being available when it is loaded. You see, when working with a dozen other individuals who all have different assets coming in at different times- you simply cannot arrange packages how ever you'd like.

                      The situation is that we are all working remotely. Each person does not need access to all assets at once, typically, an individual will only need to place an asset in the game or spend time re-arranging assets. So the process of downloading 12-15 separate packages everyday to integrate one asset is a little troublesome.

                      I'm looking for a way to display proxy meshes when the full asset is unavailable. I don't think that there is an option for this though.

                      Currently, because textures seem to be the biggest use of space, I'm thinking about categorizing all of the static meshes in a single package by their use in the game, and placing all of the textures in several packages.

                      The real issue right now is that when I move an asset from the large package to another one, a version of it remains in the original package.

                      Comment


                        #12

                        Here's the error I get when attempting to delete an asset. There is no map open, and the dependencies are all within the package, and there are some scripts that reference it as well.

                        I ran the "fixupredirects" command, and all seemed to be going well; the command line popped up, identified several packages that needed fixin', but then it crashed- a couple times.

                        I'm thinking I might need to get forceful with it.

                        Comment


                          #13
                          Do you get that message when you are moving the asset or deleting it?

                          If the answer is deleting, you're doing it wrong :P You need to move/rename, otherwise no linkages will be updated, hence the error when you try and delete something. However, I HAVE been in that particular hell before after doing some botched moves early on in my days with UE3.

                          If it's during the move, then there's likely something in script that's binding those assets to the packages. Scripts as was mentioned above won't update when you try and move assets. You'll need to disable the .u files you are using, move the stuff (don't load a map!), update the scripts, recompile and you should be golden.

                          Best of luck!

                          UPDATE: there it is in the linkage error: INCCletusInfo class

                          Comment


                            #14
                            Cool! That all sounds logical. I will give it a shot. Thanks.

                            Comment


                              #15
                              Looks like everything is working fine- now it's a lot of rinse and repeat. I guess the trick was accessing all of the scripts that referenced the assets and changing their references, after relocating the assets.

                              Thanks for all of the help.

                              Comment

                              Working...
                              X