Announcement

Collapse
No announcement yet.

Spatialize broken in March beta?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Spatialize broken in March beta?

    Sorry if I've not noticed this documented somewhere, but I'm trying to get some audio files to spatialize and it's not working at all.

    I have a bunch of dialogue files that I want to play from the co-ordinates of an NPC bot walking around my level. I originally imported them as stereo and set the target inside the Play Sound node, then tried creating an object for the bot and attaching that to the PS node. Neither made any difference. Then I converted them all into mono files, made four copies, and reimported as 4-channel audio files. The log when I run the game then informs me that spatialize doesn't work with multichannel files, but with it on or off it still makes no difference. Also, Attenuation works perfectly, but not Spatialize.

    Every tutorial I've seen just says point the PS node at a target object and that's it done...

    Footsteps work fine and you can hear the bot moving around in 3D, but my speech files just play in the centre. I am using headphones, but I've also tested on a 5.1 speaker setup.

    Anything I'm missing?

    #2
    I could be wrong, but don't you need single channel mono sounds for spatialize? Couldn't hurt to try.

    Also, posting an image of the kismet sequence would help.

    Comment


      #3
      Temorzerella is correct, you should be using mono audio for spatialised audio; using stereo audio is very wrong (think about why you use stereo audio, and then think about why you use spatial (3D) audio. You'll soon see the obvious clash).

      Comment


        #4
        Hah, thank you, guys! Works perfectly now.

        The documentation said stereo (and I agree that struck me as odd), so I never tried just mono - then went from stereo to 4 channel ;-)

        Comment

        Working...
        X