Announcement

Collapse
No announcement yet.

Level Teleport Player Error

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Level Teleport Player Error

    I am getting an error when attempting to teleport the player between levels.

    I have a persistent level with a CSG floor, and playerStart. I have a couple other levels where I want the player to be teleported to when they touch a trigger volume.

    Seems easy, right?

    This is my kismet for teleporting player from my persistent lvl to my first game level.

    http://i42.tinypic.com/154yan9.png

    The level streams correctly and the player is teleported how I want when I play in editor, but when I play from PC, I get this error when I enter the trigger:

    Kismet Warning: Failed to find streaming level object associated with SeqAct_LevelStreaming UEDPC'name of game'.TheWorld.PersistentLevel.Main_Sequence.SeqAc t_LevelStreaming_0'

    IDK why it would work in editor but not when I play from PC, the player is teleported but the level is not streamed or visible.

    Please Help

    #2
    I'm actually having the same problem. I really can't find out what is the problem.
    Mine is set up different from yours. I have a teleporter in front of a door that if you touch it, it will teleport you to the next level, but I have a trigger volume that streams that next level before you reach the teleporter door. So when when you get over there it's all good. My level shows up. Maybe you set things upon the wrong "LevelSequence" kismet. Make sure the name of the level your loading is exact. Even though everything is working in the editor just like you said and even for myself. It won't work when I try to play on PC or even launch with "Unreal FrontEnd"
    It has to be something else. If I can get past this, I will be fine. I've done plenty of troubleshooting and still no progress. I bet it's something simple too. It always is. If I figure it out I will post it.

    Comment


      #3
      Originally posted by Winwarproductions View Post
      I'm actually having the same problem. I really can't find out what is the problem.
      Mine is set up different from yours. I have a teleporter in front of a door that if you touch it, it will teleport you to the next level, but I have a trigger volume that streams that next level before you reach the teleporter door. So when when you get over there it's all good. My level shows up. Maybe you set things upon the wrong "LevelSequence" kismet. Make sure the name of the level your loading is exact. Even though everything is working in the editor just like you said and even for myself. It won't work when I try to play on PC or even launch with "Unreal FrontEnd"
      It has to be something else. If I can get past this, I will be fine. I've done plenty of troubleshooting and still no progress. I bet it's something simple too. It always is. If I figure it out I will post it.

      Yep, that's exactly the problem I have. Hopefully somebody can help us out.

      Comment


        #4
        I can't really pin point the error fix. All I know now is that my levels work the way I want it now when I play in the editor, and now also when I launch with "Unreal Front End"
        The strange thing now is that when I try to launch with PC from the small icon on the top menu of the editor next to the black joystick looking icon. When I do it that way now, it doesn't work. The important thing is that it is working for "Front End" now so I can Cook and Package and stuff. Still hard to find out which is the real game now.lol.
        What I've been doing for the past few hours was playing with simple test levels and it still wasn't working. The most drastic thing I've done was I went back to my original game levels that wasn't working and took everything out of my sub levels kismet and copied it to the Persistent. Then I builded and saved everything. My birds and stuff aren't moving right now because I pretty much took all the script out of the sub levels kismet but that's okay,all I have to do is connect the dots. After all that I launched with Front End and that works. Just not the PC button in editor. My teleporters are working. I have it set up to where when it teleports me to the next level I land in trigger volume that unloads the previous level. All of this in Persistent of course. I don't want to find solutions on accident, button on purpose because I always forget how I did it.

        Comment


          #5
          Bump for somebody that may be able to help us out

          Comment


            #6
            I am having the same problem and I'm really confused because you can't play from PC in the editor but, you can play in editor and from the frontend so I guess I'll just do that but it is rather annoying. :'(

            Comment


              #7
              How big is the level that you're loading? I've had issues where Stream Level throws "finished" before it's actually finished loading. In this scenario, that would obviously cause the player to try and teleport to someplace that doesn't exist yet. Put a large delay after the streaming finished but before the teleport to allow the level to load in and see what happens.

              Comment


                #8
                Hey, guys.
                I have the same problem, and I am waiting for the solution.

                Comment


                  #9
                  Originally posted by lion_fan View Post
                  I am getting an error when attempting to teleport the player between levels.

                  I have a persistent level with a CSG floor, and playerStart. I have a couple other levels where I want the player to be teleported to when they touch a trigger volume.

                  Seems easy, right?

                  This is my kismet for teleporting player from my persistent lvl to my first game level.

                  http://i42.tinypic.com/154yan9.png

                  The level streams correctly and the player is teleported how I want when I play in editor, but when I play from PC, I get this error when I enter the trigger:

                  Kismet Warning: Failed to find streaming level object associated with SeqAct_LevelStreaming UEDPC'name of game'.TheWorld.PersistentLevel.Main_Sequence.SeqAc t_LevelStreaming_0'

                  IDK why it would work in editor but not when I play from PC, the player is teleported but the level is not streamed or visible.

                  Please Help
                  Is the level part of your persistent map? That is, when you go to the levels tab does it show up under your persistent map? If not, that's your problem.

                  You might also try checking "Should Block On Load" although this might not work properly when the player is already spawned.

                  One thing to note about Kismet actions: "Finished" doesn't necessarily mean "Completed". I've run into situations where they fire Finished after failing the action.

                  Comment

                  Working...
                  X