Announcement

Collapse
No announcement yet.

No ingame deafult hud (Done but)....

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    No ingame deafult hud (Done but)....

    Hi guys long time no post.

    Ive mannaged to get the Default hud off and now want to make my own but and this is the problem. Problem below.

    Go the View, WorldProperties. In World Info Tab tick. No Default Inventory for Player. Open kismet. Then right click and go to. New Event, Player, Player Spawned. Then right click again and go to. New Action, Toggle, Toggle Hud.

    From Player Spawned "Out" Plug it into "Toggle HUD" Hide.
    Right click and go to. New Variable, Player, Player. Click on the All Players in Kismet and in the properties unctick All Players.
    From Toggle Hud "Target" Plug into Player 0.

    And that gets rid off the Default Hud and i can play with out hud or gun. Ive also done the tutorial from the UDN site on top down view game of the "Timer Bar" tutorial. Ive compleated that and got the timer bar working with out any other hud on screen and works perfect.

    I then go to make my own texture for just a basic circle for a radar. I import the texture and then make the UIScene textur and other material but when i go into the game the radar what i made shows up where its ment to but the game is paused and i got to press escape key but when i press the escape key the radar what i made goes but the game is fine and runs.

    I dont no whever im making the UI_textures wrong or other things but im doing the exact same thing as the Timer bar tutorial but it doesnt seem to work.

    Thanks for any advice.

    #2
    Click within the blank UIScene area (just somewhere in the grey area to deselect all widgets) and then under properties you need to make sure Pause Game While Active is unchecked (it's under flags) and then you also need to go under the "Interaction" Tab and set Scene Input Mode to "INPUTMODE_None", this will keep it from locking your viewport in place, if you need to click on your radar at any point you might need to set it to "INPUTMODE_Selective

    Hope this helps!

    Comment


      #3
      Oh my god it worked. hehe. thanks been trying ages. I better write this down for future use hehe. thanks again.

      Comment


        #4
        no problem! had the same problem myself, if you figure out how to get the health to display using UILabels please let me know, i'm trying all over and nobody is being clear enough for me being a non-coder

        Comment

        Working...
        X