Announcement

Collapse
No announcement yet.

Weird BSP(CGS) Brush Wireframe Disapearances.

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Weird BSP(CGS) Brush Wireframe Disapearances.

    I've had this happen to me twice so far. First time I got around it simply by going "right it doesn't like me doing *that* to the geometry so I'll just use a CGS subtract to remove that geometry" And for some reason it liked it and never had an issue with that brush again.

    Then later when I decided to build a giant CGS brush for a section of the world that will function as a visible outside background for the side of a tall building if player decides to be suicidal and jump off the ledge into the abyss (with their pawn) they wont see a whole void of nothing on their way down into the fog which I have yet to put in, since I am currently just blocking out out everything in CGS.

    Usually I got around this little issue in the past by either saving saving saving at every step encase problems happen and just hope the next CGS I make using the geometry sub-tool or whatever the correct naming for it is, won't bug on me when it gets saved and returns.

    It's just an annoyance and I just want to know how I can fix this, or avoid this problem.

    What happens is that the geometry for the brush disappears, so I can't select it. The wireframe for the CGS remains, the lightmass remains, also the textures remain. But it's static, can't be removed and can't be deleted. I tried selecting Brush via it's textures, then deleting, that didn't work either.

    It seems to only effect CGS which is built with the geometry tool or that which I first subtract or add then clip sections off. Also on a minor note, I am very diligent at keeping all my brushes locked to the grid and on the grid.

    If anyone is willing to help me with this, I'd really appreciate it thanks.

    #2
    Originally posted by Splademan View Post
    What happens is that the geometry for the brush disappears, so I can't select it. The wireframe for the CGS remains, the lightmass remains, also the textures remain. But it's static, can't be removed and can't be deleted. I tried selecting Brush via it's textures, then deleting, that didn't work either.
    You've removed (or translated) the brush without rebuilding geometry.

    Brush system is not intended for for complex modeling. To avoid problems, use brushes for simple objects only - or to cull other geometry if you really have to. For any other types of geometry use models created in external 3d application.

    Comment


      #3
      Ah ok, thanks for the help.

      Comment


        #4
        thats happend to me
        entire level of simple rooms, and my wire frame brushes disappeard, but i could still see it all in my 3d viewport, nothing i did fixed it - only one map did this happen do
        i do not understand why it happend

        Comment

        Working...
        X