Announcement

Collapse
No announcement yet.

Something broke my Global Gravity Z?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Something broke my Global Gravity Z?

    So I jump in to my game using PIE. I press jump and my pawn goes flying up up up and up. He never comes down.

    I checked that somehow the Global Gravity Z value in my WorldInfo was set to 0. I checked and DM-Deck sports the same value too. Also does my other map which I quickly whipped up yesterday, but jumping was fine then.

    I recently got problems getting PIE to launch (Windows error dialog popped up each time I tried). I thought that maybe it was something I coded. So I reverted to an older code version I had and then PIE started (something about 'Within' used in a class prevented it from working). Could it relate to this?

    I tried setting numerous values into the gravity slot, but it doesn't seem to take effect.

    My pawn extends UDKPawn and has no proper modifications done to affect this.

    #2
    Any physics volumes or their children overlapping your playable area?
    Tried checking the worldinfo at runtime to see what it thinks it's global gravityz is then? (editclass name=worldinfo in console or somesuch like that)

    Comment


      #3
      I'll try. I have only placed a terrain, a static mesh water plane, lights and a heightfog to my level.

      Let's see what the game thinks of an UTPawn...

      EDIT: Hmm, works just fine with UTPawn (in UTDeathmatch). I'll see whether changing some code fixes this.

      EDIT2: I see. The UDKBase classes break this property. Switched back to extending from Engine instead of UDKBase and now my pawn stays on the ground very well.

      Anyone else willing to try? Just extend an empty pawn from UDKPawn. Could be in the UDKPlayerController too.

      Comment


        #4
        Have a look at the last two posts in this thread http://forums.epicgames.com/showthread.php?t=718384

        Hope that helps

        Comment


          #5
          Set CustomGravityScaling to 1.0

          Comment


            #6
            Found the same thing setting the default controller in utengine.ini to an AFF one. Works ok outside of PIE though :s

            Comment


              #7
              Originally posted by reropme View Post
              Have a look at the last two posts in this thread http://forums.epicgames.com/showthread.php?t=718384

              Hope that helps
              ...

              Xaklse: where is that property? :S

              Comment


                #8
                Umph, sorry I meant http://forums.epicgames.com/showthread.php?t=718277.

                That property is in UDKPawn so if you extend it put CustomGravityScaling=1.0 in the defaultproperties of your pawn class.

                Hope that helps this time

                Comment

                Working...
                X