Announcement

Collapse
No announcement yet.

staticmesh set to receive light

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    staticmesh set to receive light

    when I import any object using 3dmax to UDK, all staticmesh can not unlock it to get any kind of light. have this image here so I can help with my questions.


    #2
    Your viewport is set to unlit mode.

    Comment


      #3
      is not the unlit mode, are the properties of staticmesh, pressing the Build lighting, the shadows disappear.

      Comment


        #4
        Right now your perspective viewport is set to "unlit mode" and that's the only way you can see your mesh because you don't have any light actors close by (as i can see). Add at least one light actor close to your mesh in order to see it in "lit mode".
        The settings on the right are not static mesh properties, those are BSP surface properties - and since you dont' have any selected it sais "No surface selected"
        In order to get static mesh properties > select one or multiple static meshes and click F4. Here you can change many mesh properties.
        F4 will also open any actor properties curently selected including light actors ...
        To add a light - left click > Add Actor > Add Light (Point)

        Comment


          #5
          know how to change the properties of the actors and light, I'm sending over a picture to get an idea of my problem.


          wanted after I press continue to build lighting shadow, I'm using a direct light

          this whole scenario was modeled in 3dmax export to. ase

          Comment


            #6
            Have you made the second UV map for the lightmap?

            Comment


              #7
              did not, you can show me how to do

              Comment


                #8
                Second UV map for lightmap you can do in Max - too laborious and boring lol. or you can do it in the editor with few clicks:
                Open the Content Browser, find your mesh, doubleclick on it to get into the Mesh Editor. Here click on "Mesh" drop down menu and click on "generate Unique UV's" here you can try to set up some numbers ... which will give you various results (watch out for "UV channel to save results to" number DON'T choose 0 there because you will screw up your first channel wit all te textures > Apply. Now your static mesh will have second UV chanel which you can use to control how much memory will the mesh use for the light map.

                Inside your map open up the mesh properties go to the bottom under StaticMeshActor>StaticMeshComponent you will see:
                -Override Lightmap Res? (CHECK)
                -Overridden Light Map Res (put some number - the higher your number the better the shadows but the higher the memory cost)

                Comment


                  #9
                  Read Hourences' tutorial, it's very good. http://hourences.com/book/tutorialsue3lightmap.htm

                  You basically have to do the same stuff to your teapot/building model as what Hourences does to that concrete block.

                  Originally posted by Nathillien View Post
                  Second UV map for lightmap you can do in Max - too laborious and boring lol. or you can do it in the editor with few clicks:
                  Open the Content Browser, find your mesh, doubleclick on it to get into the Mesh Editor. Here click on "Mesh" drop down menu and click on "generate Unique UV's" here you can try to set up some numbers ... which will give you various results (watch out for "UV channel to save results to" number DON'T choose 0 there because you will screw up your first channel wit all te textures > Apply. Now your static mesh will have second UV chanel which you can use to control how much memory will the mesh use for the light map.

                  Inside your map open up the mesh properties go to the bottom under StaticMeshActor>StaticMeshComponent you will see:
                  -Override Lightmap Res? (CHECK)
                  -Overridden Light Map Res (put some number - the higher your number the better the shadows but the higher the memory cost)
                  It doesn't produce very high quality UV's for lightmap usage in my opinion. And in Max you can choose what parts of geometry get higher/lower lightmap density.

                  Comment


                    #10
                    Thank you all, I had success

                    Comment


                      #11
                      Just wanted to point out that you were changing the settings of a surface not the static mesh. The pic you showed is only for bsp stuff

                      Comment

                      Working...
                      X