Announcement

Collapse
No announcement yet.

New kismet warning msg in UDK 2010-01 ?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    New kismet warning msg in UDK 2010-01 ?

    Message like these are near the top of the screen both in game and pie:
    MIC::SetScalarParameterValue : Modifying 'Counter_TotPnts_Mat' during gameplay.
    MIC::SetScalarParameterValue : Modifying 'Timer_TimeLeft_Mat' during gameplay.

    Only happens when matinee controls the materialsinstanceconstant.

    Anyone know how to get rid of these messages?

    #2
    Also noticed this as I use Material Instance Constant a lot so the log covers up my whole screen, really an eyesore. I've looked at all the INI's and have not been able to find a way to disable this.

    I believe it was making noises as well but I was able to turn that off by setting bMessageBeep to false in UTGame.ini

    The method to disable these messages would be very helpful, thanks

    Comment


      #3
      I too got flooded with msgs. I dropped back to 2009-12.

      Comment


        #4
        Do a test cook to see if it happens with a packaged game. The UDK also makes backups of each log file that don't appear in a packaged game, it may just be a debugging tool.

        Comment


          #5
          I think you are right that it is a debugging tool, but I can't turn it off.

          Maps that use matinee and materialnstanceconstants have this problem. Those that do not, are fine.

          I think someone at Epic forgot to turn these messages off with this release.

          Comment


            #6
            I also kept having this messages pop in and I finally found the place they turn on or off. Look inside Engine/Config/BaseEngine.ini ... find this.. bEnableOnScreenDebugMessages and make it False.

            Comment


              #7
              When I looked into engine source file 'engine.uc', I found these lines:

              /** If TRUE, then disable OnScreenDebug messages. Can be toggled in real-time. */
              var globalconfig bool bEnableOnScreenDebugMessages;


              That means if bEnableOnScreenDebugMessages=true, OnScreenDebug messages will not display. It contradicts literally, so I guess that EPIC teams correct it in January update but they forgot to default back to false for bEnableOnScreenDebugMessages and update the comment in engine.uc.
              That is just my opinion.

              If you really need debugmessages later, press TAB or ~ key to enter console mode while playing, try this commands first:
              TOGGLEONSCREENDEBUGMESSAGEDISPLAY
              if you still can't see debugmessage,then try one more command:
              TOGGLEONSCREENDEBUGMESSAGESYSTEM
              remember, you have to let them both in ON mode, try using them several times to get it right.
              After finishing debugmessages, enter only one of the above two commands in consold line again to make it disappear.

              Combination of TOGGLEONSCREENDEBUGMESSAGEDISPLAY and TOGGLEONSCREENDEBUGMESSAGESYSTEM state:
              ON + ON (debugmessages appear)
              ON + OFF(no debugmessages)
              OFF + ON(no debugmessages)
              OFF + OFF(no debugmessages)

              and UDK will memorize their current states even you've exited UDK.

              what do these two commands do:
              •TOGGLEONSCREENDEBUGMESSAGESYSTEM - toggles the display of all on-screen debug messages
              •TOGGLEONSCREENDEBUGMESSAGEDISPLAY - toggle on-screen debug messages

              Comment


                #8
                Have this problem, but can't turn them off..

                I start the level, open the console.

                According to UDK

                disableallscreenmessages

                should work too, but it doesnt, do i need to put = true at the end of it.

                This is really frying my brain. I followed arnolder's post and still couldn't get them turned off.

                If you managed to turn off kismet warning messages please tell me how? I will love you forever.

                Comment


                  #9
                  Intrusive, annoying warnings are there for a reason: to encourage you to fix them.

                  As far as I understand it, getting this warning means you're modifying a material saved in a package during gameplay. This is BAD! It means that if you're running PIE, any modifications you make to the material at game-time will be applied to the package. If you then quit the editor and save, the change will be applied across your game!

                  To clarify this with an example: say you have a flag you're changing from red to green in your code. Chances are that you're getting the list of materials on the StaticMesh and editing one of them. But these materials are all references to content in your packages, so editing them will change your packages.

                  What you actually want to do is call CreateAndSetMaterialInstanceConstant(), which will make an instance of the material - i.e. a copy - which you can freely modify without altering the actual material saved in the package.

                  If you're getting this warning from Kismet I would guess that you're referencing the material in the package directly, rather than getting an instance from the mesh you're trying to edit. I'm not familiar with Matinee and Material workflow so I can't provide the solution, but hopefully an insight into the nature of the problem might help you find one.

                  Comment


                    #10


                    I'm essentially following the tutorial on 3D buzz, setting up the bot more or less like he says. But kismet reckons I need a "handler" for the UT bot when it exits cinematic mode. (I have it set to spawn when the Cinematic mode ends).

                    Comment


                      #11
                      Thanks for posting this solution!!!

                      Comment


                        #12
                        Originally posted by I2obiN View Post


                        I'm essentially following the tutorial on 3D buzz, setting up the bot more or less like he says. But kismet reckons I need a "handler" for the UT bot when it exits cinematic mode. (I have it set to spawn when the Cinematic mode ends).
                        You have done something wrong if cinematic mode is being toggled on a Bot, which is why you are seeing that warning message.

                        Comment

                        Working...
                        X