Announcement

Collapse
No announcement yet.

Problem with shadows in my level

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Problem with shadows in my level

    hi,
    well,
    here is my problem:



    it may look that it is floating but it isn't... it happens with every object i put in the scene, theres always a shadow in front of the surface that the light hits...
    if you want i can take other screenshot with a diferent angle, but i would like to know if anyne knows how to fix this...
    thanks

    NOTE:
    the object IS grounded, the shadow make it seem that it isn't grounded... thats the problem

    EDIT:

    heres from diferent angles



    EDIT2:

    now i created a new scene with a simple terrain, a static mesh and a dominant light... i didnt change any property of any object
    heres the result:



    so theres the problem again, but when i create a simple surface with the brush builder , the shadow is good, so the problem is with the terrain, but i dont know why and what is the problem...
    does anyone know what the problem is? :P
    maybe i should reinstall UDK...

    #2
    well, the object isnt on the ground so its gunna cast a shadow underneth it

    Comment


      #3
      Originally posted by bigsnake View Post
      well, the object isnt on the ground so its gunna cast a shadow underneth it
      it IS on the ground... i said on the post


      is this more clear?

      Comment


        #4
        It looks like its not on the ground, its that or your graphics card

        Comment


          #5
          Originally posted by bigsnake View Post
          It looks like its not on the ground, its that or your graphics card
          well my GPU is geforce 9700M GT and is updated...

          i tried now with a flat surface with the same light(dominant Directional light) and a normal cube and the shadow is good... so im thinking that the problem is with the terrain...
          does anyone know how to fix this?

          Comment


            #6
            the object inst grounded, and the shadow seems to be right.

            Comment


              #7
              how many times do i have to say that it IS grounded? lol
              do i have to make a video showing it is grounded?

              Comment


                #8
                Dude, its now grounded, I can clearly see from both images its not, you need to try dragging it down a little

                Comment


                  #9
                  Originally posted by bigsnake View Post
                  Dude, its now grounded, I can clearly see from both images its not, you need to try dragging it down a little
                  it is grounded
                  heres from diferent angles

                  Comment


                    #10
                    ok, im convinced by that lol

                    But thay last image, the shadow look sfine :/

                    Comment


                      #11
                      Originally posted by bigsnake View Post
                      ok, im convinced by that lol

                      But thay last image, the shadow look sfine :/
                      but it isnt because the light is focussed on the left of the object so it shouldn't have a shadow in front of that part

                      Comment


                        #12
                        You have few options:
                        a) make object recive shadows only from dynamic channel (but this will no allow object to get any benefits from GI and AO which look really bad)
                        b) use InterActor insted of StaticMesh (dont know real disadvantages but making every object in scene InterActor does not look like good idea)
                        c) Increase Lightmap resolution to minimum 16 (Properties of Terrain and Look at lighting on bottom should be 4 change it to 16). But EVEN increasing it to 64 (!!!!), wont fix shadows completly. There always will be some rounded corenrs, and shadows little outside object.

                        This is really annoying. What's about dynamic shadows + static GI on objects ? (actually dynamic shadows (!?) recive information about bounced lights, but those shadows mu be on BSP or terrain, self-shadows and opposite to light side of object wont, that's really odd).

                        Anyway there is no good solution. All of them are hack around which do not give really good looking results..

                        Comment


                          #13
                          now i created a new scene with a simple terrain, a static mesh and a dominant light... i didnt change any property of any object
                          heres the result:



                          so theres the problem again, but when i create a simple surface with the brush builder , the shadow is good, so the problem is with the terrain, but i dont know why and what is the problem...
                          does anyone know what the problem is? :P
                          maybe i should reinstall UDK...

                          Comment


                            #14
                            Alright I tried to duplicate your problem, while I was unable to get the same result with the shadow casting infront of the object, I did however get an awkward shadow by having to few of number of patches matched up with a large drawscale.

                            By increasing the number of patches and lowering the drawscale I got a much better shadow.

                            [shot]http://img694.imageshack.us/img694/8479/weirdg.jpg[/shot]
                            [shot]http://img15.imageshack.us/img15/2186/unweird.jpg[/shot]

                            Comment


                              #15
                              This looks like a frustrating problem! please keep us updated on how you get on with it.

                              Comment

                              Working...
                              X