Announcement

Collapse
No announcement yet.

Problem with the shadow SpeedTree

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Problem with the shadow SpeedTree



    Hello, I got this problem, I tried to build again the lighting, but still no shadow on the leaf, Why is it like that?

    Another question, is there any tutorial how to make sun light in UDK?(Like in the some demo map on unreal tournament)

    Thank you.

    #2
    Uncheck "Use Precomputed" in the properties of the tree under lighting.

    Comment


      #3
      Thank you. It's works great now,,

      I got another problem now, after I added a dome, how the ground is dark,even I already build the light,why is it like that?




      How about the tutorial on the Sunlight?
      like in here,,



      Thank you very much.

      Comment


        #4
        I may be wrong, but I think Directional Lights originate from an infinite distance away from the scene like a fake sun so to speak - so even if you place your directional light under the skybox, the rays are still originating outside... i'm guessing that the light rays are hitting your skybox and its not letting light through (like a solid mesh). Look in the Skybox properties, there is a setting to disable casting shadows and accepting lights etc.

        Hope that works for you

        Regards,
        Matt.

        Comment


          #5
          Fallingbrick is right about the skybox, you shouldnt have it casting shadows.

          As for achieving sunlight like in the second picture you posted, you can mess with high brightness values, and changing the color of the light to a slight yellow/orange but still close to pure white.

          You can also mess around with your color correction options in your WorldProperties under world info, in there you can adjust your post processing scene shadows, mid tones, and highlights to achieve more contrast or vibrance to your scene. Although you wont see these effects change while viewing in the editor unless you click the G in the perspective window.

          Lastly you can adjust the lightmap resolution of your meshes and the bsp, the lower the lightmap number for bsp, the better detail you'll get with your shadows, as for meshes its completely reversed where the higher the number, the sharper the shadow. Also in your dominant light properties under lighting/lightmass you can adjust the light source angle for sharper or blured shadows. However seeing as your using a speedtree anyway which is using dynamic shadows and not static, changing your lightmap resolutions and messing with the lightsource angle wont do anything for you.

          Anyway I know this isnt what you were looking for, as its not really a tutorial at all lol, just a heads up on features you can mess with to achieve great lighting.

          Comment


            #6
            I got another problem of shadow with speedtree.

            After I build all the light,the shadow on the both of the tree is still same, why is it like that??


            I uncheck "Use Precomputed" to get the shadow in the terrain. it is effect the shadow on the tree also??

            How to make the tree have a shadow on it, and the terrain also got full shadow of the tree??

            Thank you.

            Comment


              #7
              is there anyone can help?

              Comment


                #8
                anyone can solve this problem?

                Comment

                Working...
                X