The Infinity Blade Forums Have Moved

We've launched brand new Infinity Blade forums with improved features and revamped layout. We've also included a complete archive of the previous posts. Come check out the new Infinity Blade forums.
See more
See less

Help with interacting with fluid surfaces

  • Filter
  • Time
  • Show
Clear All
new posts

  • Help with interacting with fluid surfaces

    SO I am trying to make an acid pit, where when you walk into it it kills you, is this possible? is there something I need to do with the collision, physics or fluid actor options, or is it something else that needs to be placed on top of the fluid actor?

    Also is there a way to give depth to a fluid actor? Right now it is just a flat plane, and when you fall through and hit the bottom there is nothing "inside" of it. just a flat plane of water and then empty beneath it.

    Please help if you can, thanks

  • #2
    Add a kill volume under the plane. This will make it so that the player dies when they enter it. I believe there are special slime volumes as well. You can configure the settings to your likeing.

    Additionally, to make it look like there's something under the surface, add a postprocess volume under the water as well. You can set color, blur, etc to make it look like you're under. You can also add bubble particle effects and such to add to the effect if you want.


    • #3

      For anyone that is also looking for this, or how to add kill volume, I finally found this link

      worked perfectly for me


      • #4
        well it did work perfectly for me, now when I go in to play the game, my fluid actors dont show up, so I fall and just die... it doesnt show my fluid actor (pool of acid) anymore. anyone know what might be causing this?


        • #5
          there could be a lot of reasons for this. Make sure you don't have it set as hidden, try rebuilding geometry, etc. Click on the little binoculars at the top and see if you can find it in the list or if it's just gone.


          • #6
            lol Im a dumb ass... Let that be a lesson to everyone else, dont move areound the 3d frame with W A S D and accidentaly let your finger off the right mouse button, apparently W is the hide key for certain things lol