Announcement

Collapse
No announcement yet.

funny shadding

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    funny shadding

    I made a flat mesh (4x8 sheet of plywood) in Blender Added a UV texture, exported to an ase file. Then I imported the mesh and textures into UDK, created to material and applied it to the mesh.

    Problem is the mesh has a funny shading to it. When the meshes are set next to each other, they appear to go from light to dark on each mesh rather than according to the room lighting. Anyone know what I'm doing wrong?

    #2
    Do you have a second uv channel mapped to the problematic object? Sounds like your object is using vertex lighting but without an image I couldn't confirm nor deny.

    Comment


      #3
      Originally posted by Winter Dragon View Post
      Do you have a second uv channel mapped to the problematic object? Sounds like your object is using vertex lighting but without an image I couldn't confirm nor deny.
      I don't really know. How do you tell? All the normals are facing out.

      Another thing is...
      While importing my .ase mesh created in Blender, I get this message:
      Generated/imported vertex count ratio (24/8) exceeds expected percentage (200.00 percent vs 25 percent expected).

      Might there be any tutorials I could refer to?

      Comment


        #4
        Do you have a normal map applied to your object? Also, if you baked anything, you may have had a smoothing issue before export...

        A screenshot would help

        Comment


          #5
          is it super low poly? I know it is just a plane but it could be the issue

          Comment


            #6
            Actually it's a cube with 6 sides, all quads.

            Comment


              #7
              no baking, UV unwrapped with one material slot.

              Comment


                #8
                Select ALL faces in Blender, and turn off the smoothing. If it already is off, turn it on and then right off again. Make sure Auto Smooth isn't on either. I used to have issues with Blender when I used it. It would normally make all my meshes completely black in UE3, but I would go and re export and it would be fine then.

                Comment

                Working...
                X