Announcement

Collapse
No announcement yet.

Setting up 3D models from 3D Studio MAX?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Setting up 3D models from 3D Studio MAX?

    I created a room in 3D Studio MAX, exported the room to room01.ase file, inported the room into Content Browser, added the room into 3D world, applied material to the room, and added point light and player start. When I try to play the game, the player falls through the floor of the room. How do I set up the room so that the player doesn't fall through the floor?

    #2
    Disable the following in the mesh.

    Use Simple Box Collision
    Use Simple Line Collision
    Use Simple Rigid Body Collision

    Have fun.

    Comment


      #3
      You might want to add 6DOP Simple Collision to the model. You can do so while viewing it in the Static Mesh Editor (when you double-click the mesh in the Content Browser, this comes up) by choosing it from the Collision menu at the top. Try that and test your level to see if it helps.

      Comment


        #4
        You can also make a second model that encompasses your model in a simplified way in the same max file that you name UCX then that model will automatically be used as collision

        Comment


          #5
          Making the objects with the UCX_ prefix inside of max takes a while, and must be primitives. For a complicated concave mesh this will take a long time. Not to mention this wouldn't be viable for a curved concave mesh for example.

          Chose your poison

          Comment


            #6
            You should also build your levels as a BSP shell first and then export the bsp and build your mesh around that then you use static mesh as a deco. Keep in mind though for static meshes you need to import a separate collision mesh. I'm a little rusty in unreal so not sure if the option is still there but if the mesh is low poly then you can get away with per poly collision but if its a mesh with a high poly count than per poly collision is BAD. You will need to make a low res mesh for collision. but as I said try to make your rooms in low detail with BSP first (as i find it lights better than static mesh (ue3.5 with light mass might be a different story now)) but use your static meshes for wall deco.

            Comment


              #7
              Originally posted by jeffro11 View Post
              Making the objects with the UCX_ prefix inside of max takes a while, and must be primitives. For a complicated concave mesh this will take a long time. Not to mention this wouldn't be viable for a curved concave mesh for example.

              Chose your poison
              You don't have to make only primitives for ucx collision. When you import, unreal seem to automatically split your collison model into convex parts. Has worked very well for me this far to just make one ucx object. I keep it simplified of course, but I don't make more than one, takes 1 min.

              Comment

              Working...
              X