The Infinity Blade Forums Have Moved

We've launched brand new Infinity Blade forums with improved features and revamped layout. We've also included a complete archive of the previous posts. Come check out the new Infinity Blade forums.
See more
See less

Terrain Layer Setup

  • Filter
  • Time
  • Show
Clear All
new posts

  • Terrain Layer Setup

    It doesn't look like any terrain layer setups were included with the UDK. Has the need for these changed? Can I use the UE3 Terrain Layer Setups instead?

  • #2
    What? Are terrains different in UE3.5 when compared to UE3? :S


    • #3
      They are included. Setting up a material on the terrain is different than it was in UT3Ed.

      Now when you select a material to add to your terrain, you can right click in the terrain editor window and if you use the auto-create option, it automatically creates both the TLS and TM in your map package.

      Of course as always, I'd recommend that you save the map at least once before adding the terrain.


      • #4
        Now UDK is telling me that nothing is selected;
        create a terrain info node,
        go into terrain edit mode,
        right-click in the map layer section,
        select "new terrain set-up layer from material (auto-create)"
        addMaterial: nothing selected

        I have a material in the content browser selected.

        Also the UDK has crashed on me like 4 times while the terrain editor is open and I am interacting with the content browser....


        • #5
          Strange. Are you sure you selected a material?
          One time I had selected a texture without realizing it.


          • #6
            What do you say by "selected" ? You speak about the yellow line ? If yes, my texture is selected, but I get alway the same error message : "nothing is selected" when I try to add materials (by auto-creating").

            Hey strange, when you roght-click on the material, and choose "Edit using texture viewer...", that's open a window, close it, and add your material (same method), that's work. I don't uderstand at all why... (And that's create new layer and a new package)


            • #7
              Originally posted by desigpa View Post
              Now UDK is telling me that nothing is selected;....
              Same problem for me. I wasted a whole day trying and just about threw my computer out the window. I'm very disappointed.

              doh.... Thank you Crozz. I can't believe I was doing that!! I think the new look thru me off... I had a headache... my glasses were lost ... uh ..uh .. I selected a MATERIAL and it works now.


              • #8
                Originally posted by Froyok View Post
                Hey strange, when you roght-click on the material, and choose "Edit using texture viewer...",
                You are confusing texture with material!


                • #9
                  First select Brush in TerrainEdit window, then you can create layer setup (autocreate) in HeighMap....


                  • #10
                    I have come to the same problem.
                    I haven't found solution for it, but entire problem is little deeper.
                    When I manually try to create terrain material, Properties window popup. There is option for selecting Displacement map and Material.
                    Selecting Displacement map work fine, but when it comes to select material it simply not work.
                    I have tryed to write name manually, paste it, select from browser, bah open browswer from there, nothing work.

                    I have only once made terrain material by using Auto-Create but I'm not able to do it anymore ;/.


                    • #11
                      Seems buggy...


                      • #12
                        I have been having this same issue. I can do it the first time, but then after that I always get the "Add Material:Nothing Selected" error that someone mentioned above. It seems to me that somehow the editor thinks you have no material selected in the Content Browser.

                        I am able to add the layer manually, but this is more painful than the auto create method. Definitely seems like a bug. I hope they fix this soon.


                        • #13
                          Working fine here. Are you sure you're applying a material (created from textures) instead of a raw imported texture on the terrain material?


                          • #14
                            Hmm. OK, I went back and took another look at this. Both materials I tried were from the Cool Materials shared collection included with the UDK. The base I used was the M_Sand_Master_VertPaint material. The next one I tried (and did NOT work) was the M_UN_Rock2_BSP_BlackRock02 material. I got the "Add:Material Nothing Selected" error message.

                            This time, after the rock one would not work, I tried M_NR_Floors_BSP_Tile09. It worked!

                            So this is confusing to me. See the strange thing is that if I manually add a new setup layer, and manually add the rock material to that layer, then it works fine on the terrain.
                            So why can't I use the auto menu selection for this particular material?