Announcement

Collapse
No announcement yet.

[Solved] Dark particles on mobile devices

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    [Solved] Dark particles on mobile devices

    Hey everyone,
    Hoping someone can help out with one of my very last issues with the game I've been working on for the past year now!

    The particles I've made show up in the editor as they should, even when running in emulation mode in game. But as soon as its on the device they become darker almost black (not completely black you can still see a hint of colour).
    The thing is I have no lighting in my scene, all my materials are unlit, including my materials used for particles (triple checked) so im not sure how this could be related to lighting issues. Ive tried setting DOF bLit to true, still no go.

    I have a feeling it is something to do with the colour over life, im altering the alphas so they fade in and out. I've also made sure the materials used for particles are set to be used with Particles systems in the material settings.

    I will upload an image tomorrow to show the difference, but yeh, this has me stumped...

    Any help would be appreciated guys!

    Here's in the editor (The air conditioner looking thing up top)
    Click image for larger version

Name:	Capture.jpg
Views:	1
Size:	79.3 KB
ID:	3253876

    Here's on mobile
    Click image for larger version

Name:	photo.jpg
Views:	1
Size:	84.6 KB
ID:	3253877

    I have the same issue with a heap of other particles which have the same smoke effect.

    #2
    either multiply the emissive by a value in the material editor or increase the brightness in the texture editor

    Comment


      #3
      Hey thanks for the suggestions!
      While they weren't exactly what solved the issue they helped me narrow it down, I had the brightness set to 50 already haha upped to 5000 and still nothing, turned out I had black areas in the texture which were getting alpha'd out correctly in the editor but when on the mobile device the alpha channel isn't quite as accurate. Seems to be such a stupid thing to over look -.-
      Thanks for your help!

      Comment


        #4
        glad you fixed it
        i found the imported texture filetype has some bearing on the alpha, .png sometimes has like a border around the edges and is not quite accurate as you describe.
        .psd however works perfectly
        no idea why

        Comment


          #5
          Yeh, I've stayed clear of .png files, they don't seem to work properly when using a Translucent Material, only good when using Masked settings on my end.
          .tga 32bit seem to be pretty good for me, did not think you could import PSD files straight into UDK, that's another good thing to know for the future.

          Comment

          Working...
          X