Announcement

Collapse
No announcement yet.

iTunes Problem, Invalid Binary

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    iTunes Problem, Invalid Binary

    Hello All
    I'm trying to send to itunes Hindenburg 3DA NIGHT free version of Hindenburg 3DA.
    4x Itunes upload=OK green check, 1 min = email rejected, red point info in iTC = invalid binary
    Can anyone help?
    I do not use any special techniques, conf. scripts are default.

    UDK 11 2012 B1,11 2012 B2, 02 2013 B1, 02 2013 B2 clean installation, default scripts= same problem.

    Thank you for your feedback
    Michal

    I got this message.

    Dear developer,
    We have discovered one or more issues with your recent delivery for "Hindenburg 3DA NIGHT". To process your delivery, the following issues must be corrected:
    Non-public API usage:
    Apps are not permitted to access the UDID and must not use the uniqueIdentifier method of UIDevice. Please update your apps and servers to associate users with the Vendor or Advertising identifiers introduced in iOS 6.
    If method names in your source code match the private Apple APIs listed above, altering your method names will help prevent this app from being flagged in future submissions. In addition, note that one or more of the above APIs may be located in a static library that was included with your app. If so, they must be removed.
    If you think this message was sent in error and that you have only used Apple-published APIs in accordance with the guidelines, send the app's nine-digit Apple ID, along with detailed information about why you believe the above APIs were incorrectly flagged, to Email. For further information, visit the Technical Support Information page.
    Though you are not required to fix the following issues, we wanted to make you aware of them:
    Missing Push Notification Entitlement - Your app appears to include API used to register with the Apple Push Notification service, but the app signature's entitlements do not include the "aps-environment" entitlement. If your app uses the Apple Push Notification service, make sure your App ID is enabled for Push Notification in the Provisioning Portal, and resubmit after signing your app with a Distribution provisioning profile that includes the "aps-environment" entitlement. See "Provisioning and Development" in the Local and Push Notification Programming Guide for more information. If your app does not use the Apple Push Notification service, no action is required. You may remove the API from future submissions to stop this warning. If you use a third-party framework, you may need to contact the developer for information on removing the API.
    Non-PIE Binary - The executable 'UDKGame.app' is not a Position Independent Executable. Please ensure that your build settings are configured to create PIE executables.
    Once the required corrections have been made, go to the Version Details page and click "Ready to Upload Binary." Continue through the submission process until the app status is "Waiting for Upload." You can then deliver the corrected binary.
    Regards,
    The App Store team

    #2
    I have exactly the same problem, but my app fails when i try to upload it from the "application loader" on the mac. It has the exact same errors as yours. Why does my app use non-public API usage?

    Does anyone know how I can fix this? On the provisioning portal, I had originally selected it to use iCloud and in app purchasing, but i have yet to add those features to my game. I am releasing it without either of those features yet supported. Is that the problem???

    Comment


      #3

      Now is rejected directly from the "application loader" after my problems reported ( /Before = Uploader OK - Mail =Error-UDID,API, iTC=Invalid Binary/
      I tried two test. Same problem
      I communicate with Apple, The problem is that I do not understand it /UDID,API.......................................... ................/

      Comment


        #4
        I hope I'm wrong, but we might be out of luck for a while. I did some research...

        It seems that Apple updated their policies on May 1, 2013. They no longer allow any apps to read or use the UDID of the device anymore because of major privacy violations from some developers. The reason we developers (and UDK) have used the UDID's, is to "know" and recognize the device/player that our games are talking to. Anyways, they have two new standards now for creating an ID for the player. The new ID's aren't nearly as permanent as the older ones. You can read more about them to understand how they work.

        The new id's:
        - identifierForVendor - This is to be used by us developers. Unless the player deletes all of our apps off their phones, this number will remain the same.
        - ASIdentifierManager - This is to be used by Advertisers only. It gives them all sorts of data from your device and basically spies on you. But is only allowed for official advertisers. Kinda scary, but whatever.

        So I was hoping for an easy solution. I used UncodeX to search through all of the UDK classes and found 17 uses of "UDID" in the two files " McpUserManager.uc " and " McpUserManager.uc " . For me, these files were located in C:\UDK\UDK-2013-02_Con\Development\Src\IpDrv\Classes

        I then replaced every instance with identifierForVendor. However when I re-packaged my game and sent it through the application loader, I got the exact same error, as your original message, stating that I used the UDID which is no longer allowed. So I am assuming that the code using UDID is in the C++ code used in the Unreal Engine, and thus we are unable to update or change this.

        I'm hoping not, but my fear is that no one will be able to release any new games or update their existing games without epic updating their use of the UDID and releasing a new version of the UDK?

        Comment


          #5
          They have changed their policies on May 1st, but i uploaded a game(FEB 2013 UDK) on May 4th and that worked without any issues.
          Though, it might be that i was lucky, since i can't find rejection reports because of UDID prior to May 7th.

          Did you try to cook/package the default UDK level from a clean install and submit it ? You can simply reject the binary afterwards.

          Comment


            #6
            Please let epic guys solve it quickly!

            Comment


              #7
              I assume we are having the same problem trying to upload with application loader.
              Click image for larger version

Name:	AppLoaderError01.jpg
Views:	1
Size:	71.1 KB
ID:	3249863

              Comment


                #8
                Hey guys,

                I'm asking around internally to see if this is a UDK issue. I'll report back if I find out anything.

                Comment


                  #9
                  same problem.
                  I use a IAP,GameCenter
                  Help me. epic developer

                  Comment


                    #10
                    MereMortal: Yes that is the same error.
                    ffejnosliw: Thanks!

                    BTW, I contacted Apple about this issue and explained that I am not using the uniqueidentifier/UDID method in my apps as they don't require the users' information at all. The response was that the game engine I am using MUST be using them (which of course makes sense, because this has been the common method to use for years). Various game engines all over the web have been having this issue with Apple over the past several weeks and all of the engines have had to create fixes for their developers.

                    This was the response from apple: "While you may have removed access and usage of UDIDs from your app, the invalid binary message indicates that your app uses or accesses UDIDs in some way. Please check your source code for any occurrence of the "uniqueIdentifier" method as this is the method that returns a device's UDID.

                    Additionally, if you are linking to an external framework, such as an advertising library, these third party libraries may be accessing UDIDs. We encourage you to update your libraries to the most recent versions and use the "nm" tool to determine if the libraries are calling this method."

                    Comment


                      #11
                      onij:I got the same mail from applereview

                      Unfortunately, I still have no answer from Apple Tech support. We must wait

                      Comment


                        #12
                        Hi all and EPIC
                        We have the same problem!!!!
                        We have game ready to launch and we cannot with this bug. We tryied to sent TODAY to apple for approving.

                        PLS EPIC HELP ALL OF US TO MAKE THE GAMES ON YOUR ENGINE. THANKS

                        Comment


                          #13
                          EPIC dudes!!! my app is laying here up and ready to go and all i get is this horrible error. please for the sake of every app developer upload a little bug fix so we can carry on.
                          I hope to here from you guys soon!!!! (i know you all busy with UE4
                          THNX

                          Comment


                            #14
                            Hey guys,

                            We are working on a fix and will have a patch or update available as soon as possible. We totally understand the frustration of not being able to submit your games. As soon as I have more info, I will let you know.

                            Comment


                              #15
                              Thank you. ffejnosliw
                              waiting for the good news.

                              Comment

                              Working...
                              X