Announcement

Collapse
No announcement yet.

Lightmap Problem in Mobile

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • replied
    *.ini files do not automatically take effect. There are two types of *ini files. The ones that start with "Base" and the ones that start with "YourGameName". The "YourGameName" files are the ones the editor and the game read the values from, but they are created from the "Base" ini files if they don't exist. Delete any "YourGameName" ini files and they will be recreated with the values in the Base ini files when you launch the editor or the game next.

    Leave a comment:


  • replied
    Click image for larger version

Name:	ini.jpg
Views:	1
Size:	80.8 KB
ID:	3249137

    Good Morning, i can't seem to find this BaseSystemSettings.ini in this directory, here is an image of it, however, in the BaseEngine.ini i found this [SystemSettingsMobileTextureBias] and changed the number in the TEXTUREGROUP_lightmap and it seems it doesn't work, any ideas?
    Click image for larger version

Name:	baseengine.jpg
Views:	1
Size:	101.3 KB
ID:	3249138

    By the way thanks for taking the time to answer to my question.
    See you later!

    Leave a comment:


  • replied
    Ok ok, thank you very much, im going to try that first hour tomorrow!, right now it sounds totally like the answer to my problem

    Leave a comment:


  • replied
    you should look in the BaseSystemSettings.ini located in UDK\Engine\Config in the [SystemSettingsMobileTextureBias] section, if i'm right the lightmaps on mobile should be offsetted by 1 mipmap so if you create a 1024 lightmap the engine will use a 512 one on mobile, to avoid this just edit the ini and change:
    TEXTUREGROUP_Lightmap=(MinLODSize=1,MaxLODSize=409 6,LODBias=1,MinMagFilter=aniso,MipFilter=point)
    to:
    TEXTUREGROUP_Lightmap=(MinLODSize=1,MaxLODSize=409 6,LODBias=0,MinMagFilter=aniso,MipFilter=point)

    this should fix this issue

    Leave a comment:


  • replied
    Thank you for your response but i am already using 1024 resolution maps, giving good results for PC but still not good in mobile previewer... just like the examples i posted in my last post

    Leave a comment:


  • replied
    Select the static mesh and press F4. Search for the Override Lightmap Resolution (or something like this)
    and check it if it's unchecked. Also right under this option there's the Lightmap resolution set to 64 by default. Change this number to 512/1024 and Build Lightning. I hope it will help

    Leave a comment:


  • started a topic Lightmap Problem in Mobile

    Lightmap Problem in Mobile

    Good Morning!, i have a little problem in my work with UDK, i was until recently working in PC and Mac OSX level simulations, with a pretty good result (As an architect, importing from Archicad), but then i started working my way into iOS simulations with terrible results, such as>

    Lightmap resolution
    Click image for larger version

Name:	screen 1.jpg
Views:	1
Size:	97.4 KB
ID:	3252647
    Normal Version
    Click image for larger version

Name:	screen 2.jpg
Views:	1
Size:	97.3 KB
ID:	3252648
    Mobile Version

    As you can see the resolution of the shadow drops down quite a bit, and i really have no idea why this is happening, since in static mesh and content browser in the normal version im using 512 and even 1024 resolution lightmaps, Everything is working fine when im not in *emulate mobile features*, *Mobile previewer* and *Ipad 2*, any ideas?, thanks in advance for taking the time to help me figuring this out.
Working...
X