Announcement

Collapse
No announcement yet.

Apex Destructibles for iOS?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Apex Destructibles for iOS?

    Found this: http://physxinfo.com/news/tag/udk/

    Mobile

    PhysX is now supported on iOS.

    Rigid body physics, fracturable meshes and ragdolls are among supported features.
    Note: Cloth, fluids and soft bodies remain disabled on iOS for performance reasons.
    So I decided to give it a shot!! But didn't go so well. The object shows up in the mobile previewer and is destructible, but is INVISIBLE!! This has nothing to do with the material as I have a Static Mesh version of the model right next to it and that shows up just fine. On the device it seems to disappear completely having absolutely no existence in the level.

    Answers &/or input would be greatly appreciated! People love breaking stuff, and being able to provide that in our app would just make everything better (if at all possible using Apex destructibles)

    #2
    Hi, i was trying some tests to find if it works but i have a problem.
    I just created a fractured static mesh from a wall but it works only in utgame, not in my game.
    In my game i have melee weapon but i tried some logs and the mesh is hit and the takedamage is called. I also applied an high damage and an high momentum but nothing happen.
    If i will solve this then i'll try it on ipad.

    Comment


      #3
      Ok can answer to me. I read the damage type class and i found that in my overriden classes something was missing:
      FracturedMeshDamage=200.0
      bCausesFracture = TRUE

      now i will test it on ios.

      Comment


        #4
        I tried it inside the mobile previewer and it works to me.
        What's exactly your problem?
        It it completely invisible or just the chunks spawned from it?

        Comment


          #5
          Thanks for trying it out Ivan, glad to hear it works! Here's what's going on:

          I placed my fracturable mesh in one of the pre-made levels with the cube.
          Set it to UTGame.
          Works just in fine using PIE.
          Go to mobile previewer...and it's not there! However....I can still shoot it, and I can tell it fell appart because now I can jump on the pieces....however it's invisible yet still physically there..
          Ported it onto my iTouch 4th gen and it is not there, at all. Can't even collide with it because it doesn't exist anymore..

          It sounds like you placed the object into the level using code where I simply just dragged and dropped it into the level from the content browser directly after import...what process did you take?

          UPDATE:

          I just tried it out on my custom game in the Mobile Previewer....& it seems to have fallen apart and chunks are halfway through the ground the second the level changed to the level I had put it in...

          UPDATE2:

          Typed SHOW BOUNDS and a bounding box surrounds where the fracturable mesh should be....

          Comment


            #6
            I just dropped the fracturable mesh too. I didn't use code at all for it. Placed in the level, did the build all and nothing else.
            I don't have a lot of ideas on where the problem could be, but i'll think about it since i'm working on this stuff in this days.

            Comment


              #7
              Thanks, just tried a number of random things (Build options and a number of different settings) but I've gotten nowhere so far. If you or anyone else here on the forums manages to find out why this is happening to me please post! Much Appreciated.

              I am testing this on an iTouch 4th Gen and am using the March 2012 UDK

              Comment


                #8
                Isn't there a settings inside the .ini files?
                Now fractured meshes is supported but it requires complex calculations so probably it can works well on ipad3 and maybe on 2 but i don't think it can be a features on the iPod. Maybe it is disabled.
                Just wondering...

                edit: we should have different settings because for example in my level the spawned chunks doesn't have collision.

                Comment


                  #9
                  idk why I never thought of that! Yes you're right :P Looks like only works on iPad 2 settings. Don't see settings for it anywhere else

                  Comment

                  Working...
                  X