Announcement

Collapse
No announcement yet.

How to disable UE3ShaderCompileWorker.exe ?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    How to disable UE3ShaderCompileWorker.exe ?

    Hello everybody,


    Everytime I launch any map (C:\UDK\UDK-2012-02\Binaries\UDKLift.exe SpaceGame_A.udk -SimMobile)
    I have to wait that everything is compiled, is it possible to disable it?

    It doesn't matter I change or no the map, the script or the Package so I don't know where it comes from or what it does because there is nothing new to work on.



    Any ideas?

    #2
    If any of your materials change then it will need to recompile those shaders.

    Comment


      #3
      I don't change anything, I just launch the map. I tried to launch it from a shortcup with the path I showed in my first post, but it's the same thing if I launch the editor I also have the default map working like that, same thing with the other map I will open in the editor.

      Comment


        #4
        @spyzor, I'm not too familiar with commandlines like the one you used, but the "-SimMobile" part sounds like the "Emulate Mobile Features" button in the editor?
        When I turn that feature on, I wait a long time for shader recaching too, and with that button on, each time I turn on the editor I have to wait for a recache.
        I do notice that after recaching, a particular package gets dirtied. I think if I saved that package, I wouldn't have to redo the shader recache the next time so maybe you could try that?

        What I'm suggesting is:
        Open editor
        Turn on "Emulate Mobile Feature"
        After recache, save the dirtied package ( ie, close editor and save the package they warn you about )
        Then try running your commandline.

        What exactly does UDKLift do anyway?

        Comment


          #5
          Look in your log. You probably have an extra copy of the game running so it can't save the shader cache. Either that or you don't have write access to the cache files...

          -- Sent from my TouchPad using Communities

          Comment


            #6
            I have noticed this too, when starting the editor. It started for me with Feb UDK and seems like the mobile emulation materials always have to be compiled. This has gotten worse in May UDK in terms of time.

            In my case saving the MobileEngineMaterials package one time in the editor solves it. Not sure why this package is dirty now on load in a fresh UDK install...

            Comment

            Working...
            X