Announcement

Collapse

The Infinity Blade Forums Have Moved

We've launched brand new Infinity Blade forums with improved features and revamped layout. We've also included a complete archive of the previous posts. Come check out the new Infinity Blade forums.
See more
See less

Mobile AA

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Mobile AA

    Hi guys,

    I've been trying to find how to turn on anti-alising on mobile but to no avail...

    I set mobilemssa true on baseengine, but I still see alot of jagged lines on the ipad... on PIE it looks perfect...

    Anyone knows how to solve this?


    Thank you

  • #2
    Bump on this one, still getting this on March build...

    Comment


    • #3
      Same here, it was fine on the 07-2011 version but when I upgraded to 01-2012 I got a jaggy mess. You have to force it on some where in the ini's.

      Comment


      • #4
        Perhaps this is why I've been unable to get any texture with opacity to load on iPad normally?
        Please if you find any info on "cooking" setting , share it with us.

        I've been struggling for a couple of days already, but the best I could achieve with any kind of transparency on iPad is miles away from what I see in mobile preview.

        Comment


        • #5
          True, mobile previewer is not even close to what we see on the ipad, and forces us to be constatly uploading to the ipad to check if everything is ok... It slows down both our quality control and our efficiency...
          Not sure why as we go forward in time we start to lose vital features like AA...

          Comment


          • #6
            Hi All
            Some time ago I released the application Epic Zenta. /UDK Jan/
            I also did not succeed AA.
            I tried all methods /Postprocess,.ini files......on iPad2,iPhone4s/
            But Epic Citadel has AA turned on !?

            Comment


            • #7
              Exactly, Epic citadel and infinity blade both have AA...

              I'm developing a level with alot of sharp lines (furniture, walls, some sculptures, etc.) and without the AA it looks completly unrealistic

              I wonder if you could do it by coding a script or something...

              Comment


              • #8
                Maybe someone can help.
                Official tutorial would fit.
                I'll know if something.
                Good Luck

                When you find in the .ini files "AA , Anti" you found on some settings.But many possibilities
                C:\UDK\UDK-2011-12\UDKGame\Config

                Sorry for my english

                Comment


                • #9
                  I hate it that they do not give support to UDK users... at least for trying to solve bugs

                  But I guess that's what you get for free usage...

                  EDIT: Just found that there is a msaa force on, on definitions of the ipad. And even with that on, there is still no msaa...

                  Comment


                  • #10
                    I haven't tested this myself yet but the answer I got from dev is that mobile AA is not compatible with the graphics effects (shadows, depth-of-field, god rays, etc). God ray is the only graphic effect I have on my mobile scene so I will test with that disabled.

                    Comment


                    • #11
                      Hm, will test that tomorow. Going to turn off everything and see if it enables, but epic citadel for instance has both shadows, etc. and msaa...

                      Comment


                      • #12
                        I believe he meant shadow effects. Not just shadow.

                        Comment


                        • #13
                          Thank you taz1004! I got it working by disabling everything else.

                          This should be on the mobile documentation... How do they expect for us to find this stuff on our own???

                          Only problem now is that it's creating huge artifacts and destroying interp actors... Oh well, one problem at a time

                          Cheers mate

                          Comment


                          • #14
                            sry for bumping this old thread...
                            but can anyone explain what needs to be disabled to get aa to work and where ? "everything else" is not really clear...

                            Comment


                            • #15
                              I think they fixed the bug in the current version of udk but you can use -MSAA and -MAXQUALITYMODE
                              There are extra mobile setting in basesystemsettings.ini that are disabled on all devices
                              If not you can disable features by starting the app with -SystemSettings= e.g -SystemSettings=flash

                              Comment

                              Working...
                              X