No announcement yet.

[SOLVED] Having problem with MobileInputSystem demo between iPod Touch and iPad 2

  • Filter
  • Time
  • Show
Clear All
new posts

    Thanks for the heads up, ilguano. I'll give that a try tonight after the day job. I'll report back on my luck. I know that my fix *has* to be one of the worst case ways to do it (don't play with BaseEngine!), but I hadn't found any other way yet.


      Interesting, well I am not using a camera actor, and I am about to find out how my game works on ipad2 , will report back with results...Thanks all for bringing this issue to my attention!
      edit: yesssss my game works great on ipad2, no problems here, now I need to make a trailer cya


        Well, I tried disabling ConstrainAspectRatio and it didn't work unfortunately. It still considered the screen larger than it was (1280x720). I'm stuck reverting to my previous fix. If you have any other ideas, I'm all ears!



          Hey, I had UDK May version before, and my game was ready, then I seen a thread about code signing issues with UDK prior to august, so I ported to October just yesterday and today, and now I have the exact same problem, the picking on my pawns is displaced to the right, I can't believe this, I am now porting to August version which should work with code signing but hopefully doesn't have this picking displacement issue...

          edit: I ported to August easily, and I'm glad I did, my game runs a little better\smoother in august, I have no idea why, but I have to wait till tomorrow so my friend tests it on ipad2, to confirm its working fine!
          Confirmed , with august version everything works perfect ,
          except that weird bug with the default joysticks, so I ported to September as well,
          and september is basically same like October, Itunes don't show the icon, on ipad2 has that stretching again!
          edit2: I am now working on fixing this issue with picking code in sept and oct, I made several fixes and I'm now waiting for my friend to test it all, then I will tell how to fix it ( if it works).


            [solved] demo between iPod Touch and iPad 2

            [SOLVED] I finally got an answer from him but it looks like he didn't test all versions I had sent to him, instead he stopped as soon as he got a working version, anyway it is actually really simple and I am sorry I haven't looked into this earlier, the reason I was avoiding this problem is that I don't have an Ipad2, and its very time consuming to test it by asking someone else to do it, especially when you have several versions to test...
            So Lethil already pointed out that the picking is assuming it is running on 1280 x 960 resolution,
            so an easy fix is to simply add a If statement , so in case that is true, then put the resolution variable back to 1024x768!
            You can put this statement in event InitInputSystem() right after you get the viewport size!
            Or simply add this to your controller class :
            event OnEngineInitialTick()
               if(ViewportSize.X == 1280 && ViewportSize.Y==960)
            If you still have problems, you could try to do just if ViewportSize.X == 1280, but checking also for Y size would make sure this is running on 1.33 aspect ratio and not something else...
            Since none of the iDevices can run similar resolution this fix should not affect any other iDevices! Let me know if it works!
            If it does add [Solved] in the thread title please! Thanks!


              seems to be holding up, thanks for sharing Jurij.


                It worked

                I used the OnEngineInitialTick() and it worked great!

                Thanks, Jurij!


                  More problems!
                  This solution works fine if the Startup movie is set to be stopped at map load, but now I changed .ini file so my movie isn't stopped after the map is loaded,
                  and now the picking code gets it wrong again, the picking is displaced to the left now !
                  After thinking about it I guessed this is happening:
                  1. The Picking code now seems to think we are running at 800x600 resolution!
                  2. The GetViewportSize happens too fast due to ipad2 ultra speed, thats why we get wrong sizes in the first place!

                  So I made 2 fixes, in the first I added another If check for 800x600, if true set it to 1024x768!
                  In 2nd fix I simply deleted the If statements, and instead put the get viewport size function call to the onEngineInitialTick event!
                  And to my amusement both fixes work! Its obvious thou the 2nd solution is best:
                  event OnEngineInitialTick()
                  This way you make sure the game is already running when you GetViewportSize !