Announcement

Collapse
No announcement yet.

iPad low UI texture quality

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    iPad low UI texture quality

    Hello,

    I noticed that my UI buttons and other graphics are low quality on iPad. In udk I imported that texture as PSD. Emulating on mobile previewer it looks nice, but on iPad there are some little blurs on buttons and info screens and borders of buttons are not solid. Is there any option that for iPad textures are some way optimized or something?

    #2
    If you double click on the texture, in the content browser, it opens the texture editor. There is a drop down that has a 'UI' selection. Use that, it should help with the quality of the image. -- I also force the PVRTC (I think that's what it's called).

    Comment


      #3
      I already have seleceted LODGroup as UI and Force PVRTC option

      Comment


        #4
        Originally posted by Edska View Post
        I already have seleceted LODGroup as UI and Force PVRTC option
        What is the resolution on the image you're using, and are you trying to scale it a lot, either by having a small Authored Global Scale, or by upping the size much higher than the image itself? (such as using a 64x64 image but displaying it as 256x256)

        Comment


          #5
          I have 2048x2048 image, and only selecting some buttons with UV's. Scale of buttons is 1.0. AuthoredGlobalScale is 1.0 too. I think it's not scale problem. On mobile previewer everything is fine, but as I said on iPad images are a little bit blured and gradient patterns are not so good transitioning.

          EDIT: I think only quality is reduced somehow. I uploaded TGA instead of PSD ans quality a little bit improved, but problem the same

          Comment


            #6
            PVRTC is the file compression method used and it's generally pretty bad at vector like graphics. One method you can use is to split the image into layers to reduce the overall colors, which lead to less color bleeding. But without a screenshot of your UI it's hard to know exactly how to resolve it for your case.

            Comment


              #7
              I think I found the same problem http://forums.epicgames.com/threads/...exture-quality. I will try it latter.

              Comment


                #8
                We use to have the same problem we resolved it by :

                - Setting MobileContentScaleFactor to 1 in DefaultEngine.ini
                [SystemSettingsIPad]
                MobileContentScaleFactor=1
                - Putting images twice larger in the texture file (for a 200x100 button we put a 400x200 image).

                We don't have quality problem anymore !

                Comment


                  #9
                  We pretty much resolved all of our quality issues by ensuring we had no grayscale alpha. It somewhat limits the design of the UI a bit, but since we did that we've had no issues with quality.

                  Comment


                    #10
                    Originally posted by Wraiyth View Post
                    We pretty much resolved all of our quality issues by ensuring we had no grayscale alpha. It somewhat limits the design of the UI a bit, but since we did that we've had no issues with quality.
                    If you need grayscale alphas you shouldnt use pvrtc. It looks OK if you use uncompressed alphas.

                    Comment

                    Working...
                    X