Announcement

Collapse
No announcement yet.

Is Depth Priority Group broken in iOS?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Is Depth Priority Group broken in iOS?

    Normally the depth of a mesh is set to world. But in some cases, you want you mesh to be seen, even behind walls, objects, ect.

    The problem that i'm having, is when you run it in iOS, it goes back to the default setting.

    This is how it should look.


    But this is how it look running on iOS.



    Here is the setting in question.

    #2
    On mobile we only render the Foreground and World DPGs. All other DPGs are ignored currently for performance reasons. Look for MobileClearDepthBetweenDPG (in SystemSettingsMobile in BaseEngine.ini).

    If you have code access (Licensee), you can edit the list of DPGs the mobile rendering path iterates over in SceneRendering.cpp.

    Comment


      #3
      Alright I see, well thank you AaronJones.

      Comment


        #4
        Does this help you at all? I want to make sure you get the information you need to fix the problems you are having.

        Comment


          #5
          I'm curious, is there are way to actually do what he's asking (have a mesh always be in the foreground) or do you need a licenese to do that?

          Comment


            #6
            You could maybe hack it by using a translucent material and turning z test off, but im not sure if that would work on mobile either and it'd have to be unlit and not culled by occlusion.

            Comment


              #7
              Well, he did just say that the foreground DPG IS available.

              Comment


                #8
                Originally posted by Graylord View Post
                Well, he did just say that the foreground DPG IS available.
                The OP shows that it doesn't work, I tested it and it works in the Editor but when you use the mobile renderer it doesn't work.

                Unless there's another way of doing it?

                Comment


                  #9
                  Originally posted by Archerx View Post
                  The OP shows that it doesn't work, I tested it and it works in the Editor but when you use the mobile renderer it doesn't work.

                  Unless there's another way of doing it?
                  I was curious if editing MobileClearDepthBetweenDPG in SystemSettingsMobile in BaseEngine.ini had any affect.

                  Comment


                    #10
                    Yes setting MobileClearDepthBetweenDPG to true does seem to make the foreground group work as intended. Thanks Aaron!

                    Comment


                      #11
                      I fail to find SystemSettingsMobile and MobileClearDepthBetweenDPG in July release. !?!?!?!?

                      Comment

                      Working...
                      X