Announcement

Collapse
No announcement yet.

[Tutorial] Creating input zones through Kismet (Buttons, joysticks etc.)

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • replied
    Looks like this, right? Keep the Add Input Zone selected and move on to the properties window downstairs, give it a unique name something like SuperTurboPressingZone and press the tiny upside-down triangle on the right end of "New Zone" and select "MobileInputZone" which will give you all the properties you can tinker with.
    I have a big problem. . . the blue inverted triangle does not work. I have edited the defaultgame.ini files and it stills not working. I can put the name on the Zone but when I assign "MobileInputZone" on "New Zone" it does nothing. If theres something inside a script that its blocking or perhaps calling that new zone from another file?. Please let me know if you have an answer

    Leave a comment:


  • replied
    Really liked this tutorial. But I have a question. I want to use the button to make person move and have some problem to handle with it. So I want to learn a bit more about mobile button acces, analog input, key/button pressed, mobile input access, mobile simple swipe. Shortly say I will be pleased if you make some explanation of the input zone.

    Leave a comment:


  • replied
    Hi all,

    I've already posted this elsewhere thought i would post it here maybe get some more help...

    I'm having problem with trying to replace the joystick images, my own imported images don't display at all even in the mobile previewer, it must be a setting somewhere as when I use a pre installed image that comes with UDK it works fine :S Just not with my own, the images are tga's and are set LOD UI on import and I'm using an add input zone to override the images... I'm using march build.

    I've not changed or added any code, it seems that from the tutorial I used you shouldn't have to?

    Also does the game type selected in world properties have an effect on these things as at the moment its set to none :S

    Help is much appreciated

    Thanks

    Mike

    Leave a comment:


  • replied
    It sounds like the package isn't being referenced by the iDevice. Check out the link fro Dragon666.

    Also, dragon666, when I used my textures for iOS, I had the same issue at first. I ended up using textures that are around 128x128 and then when they are imported into UDK, double click them in the content browser and change their settings to force PVRTC4 and change the LOD dropdown to 'UI'. That helped a lot with the distortion.

    Leave a comment:


  • replied
    I have .. similar issues with a couple of custom classes that don't get loaded on iPad.
    I found this link http://udn.epicgames.com/Three/ContentCooking.html and I hope I'll find the answer there.

    I also have big issues with the images compression. For some reason all the images are with way lower quality than in PIE or in console mobile preview.
    I guess it has something to do with the packaging again, because I've seen UI elements on other mobile UDK games (Dungeon Defenders for example, and a few others) that show perfectly fine.
    Even the original textures from Chicken Coup are getting horribly distorted and compressed when porting to iOS with my setup.

    Leave a comment:


  • replied
    Someone please help me .. please

    Leave a comment:


  • replied
    Originally posted by Vawx View Post
    How are you packaging your game damian?

    Also, what is it you're experiencing when you put your game on an iDevice. Is it only the button that doesn't show? or is there more stuff missing; such as lighting? Is the button there but the texture you used not? (where you can still touch the button but it has a 'default' texture).
    It's only the button which doesn't show up. I can so clearly see the button on the PC run as well as the UDK iOS simulator run for the game, but it's not visible on the iOS device. One of the comments on the 2nd page recommend changing the DefaultGame.ini to the following

    [Engine.GameInfo]
    DefaultGame=MobileGame.MobileGame
    DefaultServerGame=MobileGame.MobileGame
    DefaultGameType="MobileGame.MobileGame"

    when I did this, the button ofcourse didn't show up, on top of that the rotation of my car using accelerometer even stopped working.

    Leave a comment:


  • replied
    Not working...

    Originally posted by Vawx View Post
    How are you packaging your game damian?

    Also, what is it you're experiencing when you put your game on an iDevice. Is it only the button that doesn't show? or is there more stuff missing; such as lighting? Is the button there but the texture you used not? (where you can still touch the button but it has a 'default' texture).
    Thank you for your reply. Actually my game displays perfectly fine, sir. The texture, lightning and everything else like I never added the button to the game. However when I press the button in the simulator it does exactly what it is supposed to do (increase the speed of my car), but this button does not get displayed on the iDevice. Please help.

    Leave a comment:


  • replied
    How are you packaging your game damian?

    Also, what is it you're experiencing when you put your game on an iDevice. Is it only the button that doesn't show? or is there more stuff missing; such as lighting? Is the button there but the texture you used not? (where you can still touch the button but it has a 'default' texture).

    Leave a comment:


  • replied
    Mr. Curious, could you please help me. I am unable to get this button displayed on the iPhone 4. Are we supposed to change some properties, or mobile settings under buttons to get it displayed? It works fine on the UDK iOS simulator as well as the PC run on the UDK but not when installed on the device. Please help.

    Leave a comment:


  • replied
    [HELP] Unable to run the button on the iPhone 4

    Awesome tutorial. It works absolutely fine for the PC run as well as the mobile simulation, but when I install the game on the device (in my case iPhone 4) I am not able to see the button I designed using this tutorial. Please help.

    Leave a comment:


  • replied
    It's been around on another site for a month or so but I couldn't find it again either - THNX!

    Leave a comment:


  • replied
    Originally posted by salochin59 View Post
    I am having an issue of the buttons not changing resolution for the 3Gs and iPad. 4Gs fits fine but 3Gs the buttons are too big and dont fit in the screen and Ipad the buttons are too small. How do I fix this?
    I haven't tried it but I think you can define the button zone as a percentage of the screen size instead of by pixels by using Relative.

    Originally posted by James Douglas View Post

    My problem is probably a simple one: I would like to move an object along a horizontal plane either left, right, forward or backward buy touching it on the ipad screen. Is this possible?
    Did you try Mobile Object Picker? It might be better/easier to use Simple Swipes, but it would work anywhere on the screen, not just the object.

    Leave a comment:


  • replied
    a stupid question . . .

    I'm a complete newbie to this so please bear with me. I am a graphic designer not a programmer hence the move to UDK.

    My problem is probably a simple one: I would like to move an object along a horizontal plane either left, right, forward or backward buy touching it on the ipad screen. Is this possible? I have searched for video tutorial but to now avail and I have a client breathing down my neck for a prototype of his program (this is the only hitch we have). Any help is greatly appreciated.
    TIA James Douglas, Creative Conspiracy. :

    Leave a comment:


  • replied
    I am having an issue of the buttons not changing resolution for the 3Gs and iPad. 4Gs fits fine but 3Gs the buttons are too big and dont fit in the screen and Ipad the buttons are too small. How do I fix this?

    Leave a comment:

Working...
X