No announcement yet.

problem when running the deployed udk-ios sample game.

  • Filter
  • Time
  • Show
Clear All
new posts

    problem when running the deployed udk-ios sample game.

    Hey guys. I need your helps.
    I deployed udk mobile sample game(EpicCitadel, SimpleCourtyard) to my iPhone. But when running the app, it crashes and pops up message shown below.

    "Assertion failed: appErrorf
    Failed to find file for package Startup_LOC for async preloading."

    Does anybody know why?

    Alright did u get any errors wen u packaged the game into a standalone? ANd porbably the game isnt that all finished you need to add a menu an other things. tell me wen u can


      Are you sure that all of the packages are deployed on your iPhone?


        hmm... Another packages?

        It seems that the game "SimpleCourtyard" has packages shown below.
        There's another package that is needed to run game properly?
        Then how can I include that missing packages in the game binary file?
        (sorry for my being so newbie at UDK...)

        Here's log generated during UnrealFrontEnd packaging process.
        Compressing files into IPA. Only large files will be listed next, but other files are also being packaged.
        ... Packaging 'Payload/'
        ... Packaging 'Payload/'
        ... Packaging 'Payload/'
        ... Packaging 'Payload/'
        ... Packaging 'Payload/'
        ... Packaging 'Payload/'

        Finished repackaging into IPA, written to 'E:\UDK\UDK-2010-12\Binaries\IPhone\Release-iphoneos\MobileGame\MobileGame.ipa' (took 18.47 s)


          Im facing the same problem. Can anyone help?


            Could you open up UnrealFrontEnd and do the following steps?

            1) Make sure the UDK iPhone profile is selected, and make sure it says "MobileGame on IPhone (Release_32) | Cook/Make/Sync with Release_32 ?
            2) Make sure SimpleCourtyard is listed in the Maps To Cook list and that Override Default is checked.
            3) Click on the Cook button and select "Clean and Full Recook"
            4) If there are any errors during this, please post them in this thread
            5) Try hitting Start now (should package and then try to deploy again)

            Michael Noland


              Hi,I find that I don't have a Release_32 option under the "Cook/Make" block in my UnrealFrountEnd. Is that a problem course the crash? I have not paid Epic 99$, must I pay the money to get the program running on my device? How can I get the Release_32 option appear?


                Originally posted by kcmonkey View Post
                I have not paid Epic 99$, must I pay the money to get the program running on my device?

                You aren't by chance trying to deploy to a iPod Touch 3rd gen 8gb are you?



                  I get a iPod Touch 4th gen and a iPad. It's just weird that I do not have a release_32 option under the "Cook/Make" block in my UnrealFrountEnd as the official documentation shows. By the way, I'm a beginner with UDK. So i just simply open the project and compile and install it on my device with out doing any implement to it (of course I've got my iOS previsioning and certification setup follow the documentation correctly). Is that the problem?


                    Hi, I'm having the same symptom, the game crashing/quitting upon finishing the UDK loading screen. I've pinpointed exactly when it occurs, and I have a lot of little tidbits of info, so I'll restate my findings:

                    -I own a Ipod Touch 4th gen 8gb.
                    -Crash occurs only on the map EpicCitadel, this doesn't occur at all on SimpleCourtyard.
                    -Steps to repro the crash, which is 100%:
                    1) Load EpicCitadel to the Ipod Touch. Run 'UDK Game', then observe the game load successfully.
                    2) Quit out of the game so that the UDK splash screen must reload (as opposed to returning back to the 'save-state'), or just click on the button that leaves the game and loads Safari to Epic's website.
                    3) Attempt to reload 'UDK Game' and observe the UDK loading splash animation.
                    4) Observe game quit/crash out back to the iOS desktop.

                    -This crash is remedied by rebooting the Ipod. I'm not exactly certain how to specifically do this, but it seems to work by turning it off for about 20 seconds. When the Ipod gets fully rebooted, 'UDK Game' will load again, but will keep crashing each subsequent launch.. until fully rebooted again.
                    -This crash seems like its no big deal since it will load upon a fully restart, but it is still unacceptable for a commercial release of a game. You will literally get all 1 star reviews saying how the game doesn't even start, even though it DOES load back properly after a full reboot.


                      -I own a Ipod Touch 4th gen 8gb.


                      32gig devices required.


                        Originally posted by TOP-Proto View Post

                        32gig devices required.
                        Thanks for the info, I was just about to make another post saying that I was wrong about it working after a full reboot. It still doesn't work after full reboots, it has a mind of it's own.

                        Can you provide a link for the full details on what devices are compatible with UDK mobile? And if the 8 gig device compatibility is being worked on for future UDK releases? Also, if the UDK game gets published on the Appstore, will it work on 8 gig devices?


                          I have an iTouch 8gb and havn't run into any problems yet.



                            Developing iOS Games
                            The hardware requirements for developing games for iOS devices are the same as the normal system requirements for building games with Unreal Engine 3. You need a PC capable of running the Unreal Editor.

                            Unreal Engine 3 currently supports the following iOS devices:

                            •iPhone 4
                            •iPhone 3GS
                            •iPod touch 4th generation
                            •iPod touch 3rd generation (except for 8 GB 3rd generation devices.)
                            iOS devices must have at least iOS 3.2 or later installed in order for Unreal Engine 3 to run. If you have an older device, or a device with an unsupported version of iOS installed, then you will not be able to run your application. Also note that certain features are only available with some combinations of device and iOS versions. For example, iOS 4 or later is required for multisample antialiasing.

                            The minimum hardware requirements for developers are:

                            •Windows XP SP2 with DirectX 9.0c
                            •2.0+ GHz CPU
                            •2+ GB RAM
                            •A graphics card with Shader Model 3.0 support, such as nVidia GeForce 7800

                            In order to develop iOS games with Unreal Engine 3, you need the following programs installed on a PC:

                            seems i was mistaken, its 3rd gen 8gb devices it doesnt work on, not 4th gen.