Announcement

Collapse
No announcement yet.

'InvalidArchitecture' problem

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    'InvalidArchitecture' problem

    Hello Everyone,

    I'm new to UDK so I apologize in advance...

    I've succesfully run the packager with the JazzTutorial with a valid provisioning profile, certificate, etc. I can't seem to install the .ipa on my ipod touch MC086LL (3rd gen 8GB, right?) with OS4.2.

    iTunes says the app is not compatible with my device. I've searched the docs and can't seem to find the minimum ipod hw requirements. Does anyone know if UDK requires a newer ipod device?

    Thanks,

    tom

    #2
    From the Unreal Development Kit FAQ:
    Q: What operating systems are compatible with UDK?

    A: The development environment for UDK runs on Windows PC. It's currently possible to create executables for Windows PC and iOS (iPhone 3GS, iPhone 4, iPad, third and fourth-generation iPod touch).

    Comment


      #3
      More complete requirements:
      Unreal Engine 3 currently supports the following iOS devices:
      • iPhone 4
      • iPhone 3GS
      • iPad
      • iPod touch 4th generation
      • iPod touch 3rd generation (except for 8 GB 3rd generation devices.)


      iOS devices must have at least iOS 3.2 or later installed in order for Unreal Engine 3 to run. If you have an older device, or a device with an unsupported version of iOS installed, then you will not be able to run your application. Also note that certain features are only available with some combinations of device and iOS versions. For example, iOS 4 or later is required for multisample antialiasing.

      Comment


        #4
        Hi Tom,

        Unfortunately, UDK for iOS will not run on the iPod Touch 3 8GB, as they do not support OpenGL ES 2.0. The UDN getting started page has just been updated with a list of supported devices: Getting Started for iOS Development

        The 8 GB iPod Touch 3 models are really second generation hardware.

        Cheers,
        Michael Noland

        Comment


          #5
          Ok, my bad - I saw this in the docs and I see now that my 8 GB touch doesn't meet the requirements, darn.

          I appreciate your response(s).

          thanks,

          tom

          Comment

          Working...
          X