Announcement

Collapse
No announcement yet.

Blender FBX Scale Export Bug

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • replied
    Oh thats ****, that even better than what I was shooting for, I found what I was origanoly going for which was a blend by speed node in the animetree. But thats even better.

    Danke Sha

    Leave a comment:


  • replied
    Originally posted by OSIAS View Post
    I read somewhere about how the UDK plants a skeletal mesh's foot during movement so the model is not sliding across the map. Can anyone point me in the right direction?
    Skeletal controllers, IK foot placement. There's a page on UDN that goes into detail if you search for it, but the basics are on this page: http://udn.epicgames.com/Three/Using...lFootPlacement

    Edit, actually that is the definitive page I think.

    Leave a comment:


  • replied
    it's hard and time consuming to keep tutorials up to date when the blender and udk get up dated so often, if and when blender get the fbx export fixed i'll certainly up date my stuff.

    in the end it's up to you which workflow you follow, i don't use blender as often as i should but that's life.

    Foot planting i've never heard of, yes in the anims you can set an anim-notifier which is used to play the sound of the foot hitting the ground, afaik all movement is done on the root bone so you need to match that speed with the anim speed. i could be wrong though

    Leave a comment:


  • replied
    Thanks - I get what your laying down now, the other tutorials explained it differently. But I seem to be finding a lot of mistakes in outdated tutorials, or even further more everyone does things a little differently.

    So if anyone is still tracking this post, I know I read somewhere about how the UDK plants a skeletal mesh's foot during movement so the model is not sliding across the map. Can anyone point me in the right direction?

    Leave a comment:


  • replied
    Originally posted by OSIAS View Post
    ITS WORKING, yay.
    congratulations

    That work around doesnt work, I was doing that commenting out the extra armature and using toa ref pose /bugged, plus dont get me started on the animations importing not working properly with fbx and having to use yet another work around.
    there is one other thing to do other then commenting the 3 lines and using "TOA ref pose" but im still testing to make sure it works.

    PSK/PSA really does seem to be the lesser of two demons.
    yep

    Anyhow 96 units tall is 6ft in UDK if I setup lines 16 - scale 1 - subdivisions 8. This means there are 8x8 units in 1 block, 1 block equals 1 foot. My human model is 6 blocks.
    the scale in UDK is set by you, for the UT game they used the scale of 1UU = 2 CM (96UU=192CM=6ft4inches) but you could use 1UU = 1CM or 1UU = 1inch its you choice.

    blenders default default display is set to lines 16 - scale 1 - subdivisions 10, on the grid each square is 1 blender unit so your model is 6 units tall explaining why its so small in UDK.
    16x6=96.

    However to add when I export in PSA/PSK I have to use scale 16 not 1 to get it to line up in UDK. But for ASE of our static meshes I do the same scale it by 16.
    explained above.

    anyway glad you got your stuff in UDK

    Leave a comment:


  • replied
    Originally posted by OSIAS View Post
    @

    N -> Display
    Lines 16
    Scale 1
    Subdivisions 8
    Well I wrote a lengthy reply and the server swallowed it, so here's the short version.

    Thats just the grid scale, it has no effect on mesh scale. I usually set my scale to 10 as a starting reference. 1 Blender unit = 1 Unreal unit, so with your grid setup you are modelling tiny meshes. The other exporters appear to work because they probably scale up the mesh by default, I think by x16 for one of them last time I looked. I prefer to work at 1:1 ratio though.

    Clear the scale, rotation and location on your mesh and armature with ALT+S, +R and +G.

    Leave a comment:


  • replied
    Well I just moved over to the PSA/PSK format, Took a little tweaking IE groups to vertexs etc and the scale function in there works I tested it.

    Anyhow I got my human model imported into UDK with animations and wrapper scale etc, wait for it.

    ITS WORKING, yay.

    I am sure I going to run into a few more bumps in the road, fingers crossed that I dont. Now to move onto animation trees.

    @ Smokey
    That work around doesnt work, I was doing that commenting out the extra armature and using toa ref pose /bugged, plus dont get me started on the animations importing not working properly with fbx and having to use yet another work around. PSK/PSA really does seem to be the lesser of two demons.

    As far as units go I am pretty new to blender, so my naming convention could be wrong. Anyhow 96 units tall is 6ft in UDK if I setup lines 16 - scale 1 - subdivisions 8
    This means there are 8x8 units in 1 block, 1 block equals 1 foot. My human model is 6 blocks. If I export as .ASE with that setup my udk ruler says its 96 units tall.

    However to add when I export in PSA/PSK I have to use scale 16 not 1 to get it to line up in UDK. But for ASE of our static meshes I do the same scale it by 16. Now I did make the model physically a giant since the scale was not working but it didnt change for me using .fbx. I just think FBX has more issues then its worth dealing with. Now I could make all my models 16 times bigger for everything but that seems wierd to me, too big in blender. Plus this is just the scale setup we have for our group so I want to stick with it for consistancy.

    Cheers.

    Leave a comment:


  • replied
    Originally posted by OSIAS View Post
    If I compare my fbx export to the ironguardmale its probably 1/16th the size
    just out of curiosity how many units tall/wide is your model in blender?

    So are you saying PSK is really the only way to go? If so what are the limitations I am going to be facing, 1 animation export at a time is that all?
    using the PSK/PSA exporter you can have multiple animations, the only limitations are that you can only have one armature and one object, although with 2.66 the unreal exporter has a "mesh check" option witch highlights any bad geometry (witch is good).

    when I tested the fbx export earlier I tried changing the exporters scale setting and your right it makes no difference what so ever, so it seems it can only export at "scale = 1.0" (I didn't try it on a static mesh so I don't know if using the fbx exporter to scale would work on them).

    Originally posted by geodav View Post
    i only had a quick look at blender 2.66 but afaik fbx for skeletal meshes still hasn't been fixed
    I think I have found a work around for the fbx witch works in tandem with the commented out part (for the extra armature) and using the "TOA ref pose" option in UDK. I tested it using my buggy and it worked, so im going to try it with my golf cart and its animations, if the animations work ill try to find someone with a weapon and character file (both with animations) that I could use for testing my work around to make sure it works, and then if it works write it somewhere so others could use it (fingers crossed on it working).

    Leave a comment:


  • replied
    ok to get your character in at the right size/scale

    1. set blender correctly and make it the default setting
    2. before doing anything complex do something simple.
    3. doing the above puts you into the correct settings and workflow
    4. with blender atm use the UDK export tools (psk/psa)
    5. the fbx is still borked for skeletal meshes.

    this is my personal opinion and some thing that works for me, i only had a quick look at blender 2.66 but afaik fbx for skeletal meshes still hasn't been fixed

    Leave a comment:


  • replied
    @ Geodav, yes thats what I have been doing.

    N -> Display
    Lines 16
    Scale 1
    Subdivisions 8

    Ctrl + A = Then check scale

    Object Menu Choosing both the armature & The mesh scale for xyz all 1.0

    Scene Menu imperial/metric = none and the grayed out scale is 1.0

    This means every full block in blender is 1ft and my exporting with .ase for static meshes has been correct and tested and proven. All static mesh models are fine.

    So moved onto animated human meshes, I dont think I can leave defualt becuase I need to export animations as well. Either way this is when the scale issue arose and this is also when I would start to mess with the fbx export scale just becuase nothing else was working. I have played with all the above settings one at a time and even physically made the model giant and same issue. If I compare my fbx export to the ironguardmale its probably 1/16th the size tiny. Nothing I have done changes that. Animations are working fine minus that all the frames on the animation say there the same length. But to fix that I thought I could use the FBX Viewer from autodesk or whatever to take each animation one at a time that way.

    Now I have seen a lot of your posts and tutorials for several of ya hence I respect your opionon, but I saw plenty of posts as well stating fbx for char animation works fine or did at one point. Ultimatly it doesnt matter which process I use I just need to get it done. So are you saying PSK is really the only way to go? If so what are the limitations I am going to be facing, 1 animation export at a time is that all?

    Again thanks in advance. Oh edit to add just made sure fbx settings are defualt and same results.

    Leave a comment:


  • replied
    I change the scale in the fbx export options from 1 to 20 to 50 and no change on the size that udk is importing.
    i think that's your problem, don't use the fbx exporter to scale your content, do any scaling in blender then reset the scale then export

    Leave a comment:


  • replied
    I usually use the PSK exporter for skeletal meshes and the FBX for static meshes but I just did a test export of a skeletal mesh using the FBX, I imported the model twice, one as a skeletal mesh and one as a static mesh and the scale was the same for both the files in UDK and were the same size as in blender, so its not a problem with blenders exporter, there must be some other problem but I am not sure what it could be.

    oh, when I exported I left the export settings at there default.

    Leave a comment:


  • replied
    Both the armature and object are both scale 1 for xyz.
    I change the scale in the fbx export options from 1 to 20 to 50 and no change on the size that udk is importing.

    Any other ideas?

    Leave a comment:


  • replied
    Your armature's scale need to be 1,1,1 too. Otherwise I never heard of such fbx export scaling issues.

    Leave a comment:


  • replied
    Originally posted by OSIAS View Post
    Yes ctrl +a checked scale - object and scene scale is all 1 for xyz
    is that for your mesh or bones or both?

    Never heard of it? Its just a couple posts down from mine right now, first and second post in that thread are talking about scale.
    http://forums.epicgames.com/threads/...-from-blender)
    oh yeah so there is, I even commented on that thread, although I commented on the other guys problem witch is probably why I didn't remember

    Leave a comment:

Working...
X