Announcement

Collapse

The Infinity Blade Forums Have Moved

We've launched brand new Infinity Blade forums with improved features and revamped layout. We've also included a complete archive of the previous posts. Come check out the new Infinity Blade forums.
See more
See less

Skeletal mesh problem (imported fbx from blender)

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Skeletal mesh problem (imported fbx from blender)

    Hi, recently ive been having problems importing a skeletal mesh, the size is a little off also, even when i try changing it in the exporter. My main issue is that when import a FBX skeletal mesh it shows up normal but when i apply the armature it looks like the origin has changed causing the mesh to skew, i have my .blend file and a picture of what it looks like in the UDK animation viewer, thanks (its just suppose to look like a regular arm, not large claws)

    http://i.imgur.com/Ao5lFS3.png
    http://www.mediafire.com/?2ah9acdbiryv5zz

  • #2
    this is a know problem when exporting a skeletal mesh from blender to udk, my advice is ftm use the built -in udk exporter tools.

    as for the strange problem that will be caused by the skinning not being correct so double check the vertex weights

    i do have a small blender tutorial playlist on my youtube channel which shows how to set up and export content from blender to udk

    Comment


    • #3
      i would use the built-in exporters but i get the "error armature bone 28 vertex group 42 don't match"

      Comment


      • #4
        you need to have the same amount of bones as you have vertex groups, even if the groups are empty

        Comment


        • #5
          I use weight paint for assigning bones to vertexes, does this mean i must make vertex groups and assign them to the bones to export?

          Comment


          • #6
            also, i started on another skeletal mesh and it works more but it does look like the bones vertex groups are not correct its, it inflates and barley resembles the original animation

            Comment


            • #7
              ok on the odd time i use blender when i parent the mesh to the armature i choose automatic vertex groups which has worked for me every time. yes i know i'm only a very basic blender user so i can't say whats going wrong, i just know that the workflow i use works.

              it might be an idea to start with something simple like a low res mesh with a few bones to get the workflow right then move on to something more complicated

              Comment


              • #8
                Ok so, I too have a problem with my skeleton mesh. It's meant to be a walking, running.... and idle animated guy. But when exported into udk as an FBX it looks more like a mutated alien. The movement's there but it looks nothing like it should. Having read this thread I did some more research into blender rigging and vertex groups and found this awesome tutorial on rigging.

                (this might be helpful to other, so I'll include it) Regarding the application of vertex groups to bones, skip to 15:55 on the tutorial for an excellent explanation on how to check is vertexes are applied to the right bone, and if they are not linked, how to fix it. Basically in weight paint mode, select the bone. Go to Edit mode. Click the object data bottom on the properties panel. This is where you can click to select, remove and apply vertex groups to that selected bone. If you click select at this stage, it will highlight the areas that are linked to that bone. In some cases I've found that some areas of the mesh are linked that are no supposed to be there at all. I won't go into to much detail, the tutorial will explain it all.

                http://www.blenderguru.com/videos/in...on-to-rigging/

                Now, I cleaned up my mesh using this tutorial and the mesh is much smoother to watch when it animates. Problem is that it didn't help with the distortion in udk, "Distorted Alien!" I even tried exporting as the udk exported tool. But as More Ragtime says, I got the error saying "error armature bone 30 vertex group 22 don't match" This brings up another issue. Firstly, my skeleton has (that I can see) 21 bones for the mesh, all linked to vertex... I also have a root bone, 4 IK targets (1 on each ankle and 1 on each wrist) Also have 4 IK directional targets, each for the elbows and knees. This (if my math is correct) brings the count to 30...

                So, two issues here. Firstly I can only see 21 bones for the actual skeleton, but the error says 22 vertex groups. ( Clearly I seem to have a stray group somewhere, that I need to check) The second is my main concern. It reads 30 bones and 22 vertex groups. My question is, are the IK targets causing my mesh to spazz out when I put it into UDK? hence the reason it won't export as a udk file? If that is the problem, what the hell do I do about that. I can't link vertex groups to the IK targets. Unless, I need to remove the targets once I've done the animation.... Any thoughts on that? Maybe I should try and remove them, but very unsure at this time...

                Comment


                • #9
                  I made a mesh and had to use bone constraints with targets and it worked fine so I doubt they are what's causing your mesh to spazz out. to use the PSK exporter every bone needs to have a vertex group, also constraints wont stop you being able to export to PSK either.

                  Comment


                  • #10
                    Well thats confused me even more. So any idea on how I match the bones to vertex? It's obviously (i think) including the bone constraints. But since they don't have vertex groups how then does that work? Because I can't add vertex groups to them....

                    Comment


                    • #11
                      The IK targets and constraints should be considered bone 'controllers' that influence other bones, but not the vertices. For these bones untick DEFORM in the bone properties. Both exporters should then ignore them at export (FBX has an option), leaving you with just the deformation bones on import.

                      Each deformer bone requires a vertex group, even if the group is empty.

                      Comment


                      • #12
                        Well i turned off deform and also scaled and rotated and relocated my model. Had a couple issues with that but with a bit of tweaking i mended it. The great thing was it came into udk nicely and had no crazy deforming going on. Excited was I. So tried it with another model I had made and animated. But, it played up again. Even when applying the above suggestions. I spent a good part of the day trying to figure it out. I did notice that the walk animation was odd because the arms and legs seemed to do the action but going the wrong direction. So I looked again at the export options. My model was facing in the -Y direction and I exported it out with "-Y forward" understandably. So after seeing this I considered exporting on the "Y forward" Did I swear or what!? Thats all it was, the flipping axis output. Tried it with the other model, worked fine. Happy, yet annoyed that it finally worked.
                        But this brought up another issue. When previewing the animation in the UDK content browser, the animation works (Yay) but there seems to be no movement on the Z axis. Basically, when it runs, it's arms and legs move but no up and down movement. So I tried a quick animated jump action and in UDK, again no up or down movement. Very comical to watch with the arms and legs flapping about but its not the required action. Any ideas there?

                        Oh and by the way, apologies to More Ragtime for taking over your thread...

                        Comment


                        • #13
                          have you un-checked the "allow rotation only" box in you animset?

                          Comment


                          • #14
                            Oh... I have absolutely no idea... I'll check that later, Thanks. I'll report back

                            Comment


                            • #15
                              Job done. Un-checked "allow rotation only" and it's sorted the up and down movement. Gave me another problem with animation compression, but fixed that with the auto compress. Thank you for your help, feel bait bad for taking over someones post but I hope it helps other with the sam issue. No doubt I'll be using this forum a lot

                              Comment

                              Working...
                              X