Announcement

Collapse

The Infinity Blade Forums Have Moved

We've launched brand new Infinity Blade forums with improved features and revamped layout. We've also included a complete archive of the previous posts. Come check out the new Infinity Blade forums.
See more
See less

Tweaking UTAnimBlendByTurnInPlace?

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Tweaking UTAnimBlendByTurnInPlace?

    Hi, I noticed that it's now possible to blend between two idle-animations: one for character being still, one for turning in place by using UTAnimBlendByTurnInPlace -node in the animation tree.

    I copied the node from AT_CH_Human like this: (Sorry for the big size of the image; smaller one was very hard to read)


    But there are two problems:

    1. The rotation animation starts "late", meaning I have to rotate the character about 30-45 degrees before the TurnInPlace -animation (run_forward) starts playing. I'd like it to start after about 5 degrees of rotation, or almost immediately.

    2. After stopping to turn the character in place, the animation does not return to to the Idle -animation (idle_ready).

    Also I would like to know what the slider at the bottom of the UTAnimBlendByTurnInPlace -node does (set to 0.11 Idle in the pic). Thanks in advance!

  • #2
    yeah im getting the same problem. after i stop turning, the character just goes into T-Pose

    Comment


    • #3
      The slider lets you test the animation.
      As far as setting the values, its handled natively.

      To adjust the angles, you will need to muck around with MaxYawAim.
      UDKPawn.uc
      Code:
      /** How far RootYaw differs from Rotation.Yaw before it is rotated to catch up. */
      var() int    MaxYawAim;
      This defaults to 7000... with is what, 38 degrees?
      Change that too 1000'ish for 5-6 degrees.

      Full full control over the twisting and turning of the torso, you need to disable this and write your own code.

      Comment


      • #4
        @slowJusko

        You're a life saver! This fixed the problem for me where I wanted the "turn in place" node to fire sooner.

        Comment

        Working...
        X