Announcement

Collapse

The Infinity Blade Forums Have Moved

We've launched brand new Infinity Blade forums with improved features and revamped layout. We've also included a complete archive of the previous posts. Come check out the new Infinity Blade forums.
See more
See less

Weapon custom fire animation HELPP

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Weapon custom fire animation HELPP

    hi i have a litle problem with a custom fire animation i have add to my weapon i have added the sockets add the animsets in the weapon code and add the fire animation name but when i shot it doesnt play my Custom fire animation it just work when i use the shock Rifle code so please help if any interesed here is my weapon code

    Code:
    class UTWeap_uzi extends UTWeap_uzi_base;
    
    
    
    
    defaultproperties
    {
    
    
       Begin Object Name=FirstPersonMesh // First person settings
    	SkeletalMesh=SkeletalMesh'lascosasdeljuego.uzi'
           AnimSets(0)=AnimSet'lascosasdeljuego.uzianimaciones'
       End Object
    
       Name="Default__UTWeap_assaultrifle"
       ObjectArchetype=UTWeapon'UTGame.Default__UTWeapon'
    
    
    
    
    	Begin Object Name=PickupMesh
    		SkeletalMesh=SkeletalMesh'lascosasdeljuego.uzi'
    	End Object
    
    AttachmentClass=class'UTAttachment_uzi'
    
    
    
    
    
    	
    
    	WeaponRange=50
    
    
    
    	PickupSound=SoundCue'A_Pickups.Weapons.Cue.A_Pickup_Weapons_Link_Cue'
    
    	AmmoCount=120
    	LockerAmmoCount=20
    	MaxAmmoCount=120
    MaxDesireability=0.7
    	AIRating=+0.3
    	CurrentRating=+0.3
    
    
    
    FireInterval(0)=+0.10 // Done in Seconds  (0.10 is 600 RPM)
    FireInterval(1)=+0.10
    
    	
    
    
    
    
    	
    	GroupWeight=0.5
    
    	WeaponFireAnim(1)=WeaponAltFire
    
    	MuzzleFlashSocket=MF
    
    	
    
    
    
    
    	
    	
    
    	
    PlayerViewOffset=(X=16.0,Y=-18,Z=-18.0)
    
    
    
    {

    here is UTAttachment_uzi

    Code:
    class UTAttachment_uzi extends UTWeaponAttachment;
    
    
    
    
    
    defaultproperties
    {
    	// Weapon SkeletalMesh
    	Begin Object Name=SkeletalMeshComponent0
    		SkeletalMesh=SkeletalMesh'lascosasdeljuego.uzi'
    	
    	End Object


    and here is UTWeap_uzi_base

    Code:
    class UTWeap_uzi_base extends UTWeapon
    	abstract;

  • #2
    help pleaseeeeeeeee

    Comment


    • #3
      please use the code tags when posting code, you'll find it when you click the "Go Advanced" button.
      if you used bone translation in your anims then you have to remove the tick from the Anim Rotaition Only box

      Comment


      • #4
        i have try that but it continue with out working

        Comment


        • #5
          Code:
          class UTWeap_uzi extends UTWeap_uzi_base;
          
          
          defaultproperties
          {
          
          Begin Object Name=FirstPersonMesh // First person settings
          SkeletalMesh=SkeletalMesh'lascosasdeljuego.uzi'
          AnimSets(0)=AnimSet'lascosasdeljuego.uzianimacione s'
          End Object
          
          Name="Default__UTWeap_assaultrifle"
          ObjectArchetype=UTWeapon'UTGame.Default__UTWeapon'
          
          Begin Object Name=PickupMesh
          SkeletalMesh=SkeletalMesh'lascosasdeljuego.uzi'
          End Object
          
          AttachmentClass=class'UTAttachment_uzi'
          
          WeaponRange=50
          
          PickupSound=SoundCue'A_Pickups.Weapons.Cue.A_Picku p_Weapons_Link_Cue'
          
          AmmoCount=120
          LockerAmmoCount=20
          MaxAmmoCount=120
          MaxDesireability=0.7
          AIRating=+0.3
          CurrentRating=+0.3
          
          FireInterval(0)=+0.10 // Done in Seconds (0.10 is 600 RPM)
          FireInterval(1)=+0.10
          
          GroupWeight=0.5
          
          WeaponFireAnim(1)=WeaponAltFire
          
          MuzzleFlashSocket=MF
          
          PlayerViewOffset=(X=16.0,Y=-18,Z=-18.0)
          
          
          
          }
          take note of the very last bracket you have a { when it should be }

          what anim names are you using, they must be the same as the original anims

          Comment


          • #6
            i have fix the code errores but it continue with out working and the anim names are the exact names

            Comment


            • #7
              what does your UTWeap_uzi_base.uc look like

              Comment


              • #8
                here is the UTWeap_uzi_base code

                class UTWeap_uzi_base extends UTWeapon
                abstract;



                Comment


                • #9
                  try removing this line
                  WeaponFireAnim(1)=WeaponAltFire

                  Comment


                  • #10
                    well it continue with out working but i dont know why my custom animations work when i just change the shock rifle models and animsets but how im going to sell my game i cant copy any UDK weapon code

                    Comment


                    • #11
                      Um, it works just fine if you do it right. Seriously, repost your code, both base and the other, with proper code tags, otherwise we really can't give meaningful feedback. Geodav should not be doing it for you (dude stop being so nice) I for instance see a space in your Animset name that shouldn't be there, but I have no way of knowing whether that's REALLY what your code looks like.

                      Custom weapon animations work just fine, see my signature for an example (albeit a bad example). Repost if you want help, otherwise we're shooting in the dark and having to try to interpret badly copied wall-of-code-text.

                      Comment


                      • #12
                        ok i have alredy repost the code in the main topic with proper code tags and the same with utattachment_uzi and utweap_uzi_base so if you want go to the main topic and chek the code

                        Comment


                        • #13
                          You can use all the code in UDK, just not models, textures or sounds.

                          Comment


                          • #14
                            Hitpawz is correct.

                            Comment


                            • #15
                              O_O thanksssssss

                              Comment

                              Working...
                              X