Announcement

Collapse
No announcement yet.

Trouble with Vertex/Mesh paint on transparent water surface

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Trouble with Vertex/Mesh paint on transparent water surface

    Hi all.

    I'm having some difficulties making vertex/mesh paint work on my translucent ocean shader and I was hoping someone could help me out.

    This is the scene so far; I'm trying to make it so I can paint in the foam around the rocks at the edge of the water
    Click image for larger version

Name:	OceanShader.jpg
Views:	1
Size:	66.0 KB
ID:	3253743

    And this is the current shader network for the ocean;

    Click image for larger version

Name:	OceanShaderNetwork.jpg
Views:	1
Size:	63.0 KB
ID:	3253744
    http://www.racebox.net/OceanShaderNetwork.jpg <--Link to higher res image.
    (sorry if it's messy/difficult to understand, it has become quite large)

    I circled in red where I define the vertex colour for the foam.
    When I select mesh paint and paint "Red" on the ocean plane no foam appears, I've also tried painting black and all the other colours and still the foam won't appear.
    Selecting "RGB" as the view mode in meshpaint shows the colours of the verts changing as I paint them but no foam.

    What am I doing wrong?
    I'm assuming you can use meshpaint on translucent materials? and materials that make use of "WorldPositionOffset"?
    Any advice is much appreciated.

    Thanks,
    Dan.

    #2
    Try making the mesh have bCollideComplex on. That might help you vertex paint it. I know its hard to paint on materials with no collision. I'm not sure about translucenly, maybe turn on translucent selection as well.

    Comment


      #3
      I re-installed UDK to "2013-09-VR2". and now it works fine, however I have a new issue; my framerate has literally halved.
      Opening exactly the same level in the newly installed engine gives an FPs of 34 where as before it was 58.

      I have tried the following values for anti-aliasing; (it was boosted before, for the Oculus Rift)

      //Antialiasing//

      \UDKGame\Config\UDKSystemSettings.ini

      MaxAnisotropy=4
      MaxMultiSamples=8
      bAllowD3D9MSAA=False

      ResX=1280
      ResY=800
      ScreenPercentage=100

      and I get a 2fps increase.

      Do you think it's simply because I have an expensive transparent shader covering a large area? Or is there something else I haven't thought of that could boost the frame-rate?
      The specs for this PC are;

      Intel Xeon 3.4GHz Quad.
      16GB RAM
      nVidia GeForce GT 640 2GB DDR3 with 3 Monitors.


      Any suggestions?

      Comment


        #4
        Turns out I'd made a mistake in my script causing the anti-aliasing lines to not be read.
        I modified "UDKSystemSettings" in the config folder, changing the following settings;

        MaxAnisotropy=8
        MaxMultiSamples=2
        bAllowD3D9MSAA=False

        ResX=1280
        ResY=720
        ScreenPercentage=200

        This gives an acceptable frame-rate with lows of 60FPS and it works nicely with the Rift.

        "bAllowD3D9MSAA" Seemed to be the problem, halving the frame-rate when set to true.

        I hope this helps anyone with a similar problem.

        Comment

        Working...
        X