Announcement

Collapse
No announcement yet.

RPG Inventory Starter Kit (WIP)

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    #31
    The thought actually occurred to me that the disappearing pawn could have been an unimplemented gibs system. Good to know that's what it was.

    The main thing that was freaking me out was the ragdoll physics. Depending on the instance, it looked like the pawn was trying to breakdance in a really twisted way, trying to imitate the Harlem Shake and failing hard at it, or trying to recreate Get Down but just couldn't get up off the ground to do it.

    I'll give the new tweaked version a try.


    Edit: I tried the new version and it works a lot better. The dead pawn falls weird and often-times slides over the edge of the floor, but it doesn't do any weird ragdoll stuff anymore. If I hit it just right, I can get the pawn to stay put. Before, it never would. As far as I can tell, "playing dead" works perfectly.

    I'll post here again if I find anything else, but that seems to be all the issues I had with it. I haven't tried modifying the kit yet. Still need to work on learning my Unrealscript and AS.

    Comment


      #32
      Grabbing this now, I've wanted to make an RPG ever since I played Morrowind years ago. Thanks for giving this to the community, it's really appreciated!

      Comment


        #33
        Hi Chosker,

        This would fit my survival game perfectly but I had a few issues with it. Are you using a ue3 license to make the download.
        The reason I ask is that when I go to open the files in the content browser I get no assets, this in turn stops me from being
        able to open the map you provided as an example.

        SURVIVAL GAME LINK
        http://www.youtube.com/user/Scotland3d?feature=watch

        Any ideas as to what may be causing this. I'm using udk 2012 at the moment.

        To try and fix the problem I created 2 folders in the browser and manually imported the textures and meshes but still no joy opening the map.

        All the best with development of it as it looks ideal for a lot of peoples projects.

        Comment


          #34
          Angel_Mapper: you're welcome


          Scotland3d: no I'm not using a UE3 license, it's pure UDK.
          the problem is most likely due to you using an older version of UDK. as stated in the Readme, for this Kit I used the 2013-02 version.

          Comment


            #35
            This is excellent work, thanks so much for putting this out there.

            I'm in the process of integrating this into my current project, but am having some difficulty. Mostly since because I'm on a previous version of UDK, I can't open the packages to test it's assets. That's fine, I can create new assets, but I'll need to dig into your Flash stuff to make changes, and I seem to be missing an external file to make myIconInventory.fla run as intended.

            can I assume the AS class 'gfx.controls.Window' is also only included in the 2013-02 version of scaleform? I don't seem to have the file in 2012-07.

            EDIT: I've installed the 2013-02 version of UDK to look for the 'gfx.controls.Window' file, but had no luck. Instead, I found what I believe is the Window.as file in a different directory, "\\Development\Flash\As2\CLIK\demos\com\scaleform\ Window.as"

            I've copied this file and edited it's path to match 'gfx.controls.Window' and it displays your FLA file correctly, with no compiler errors.

            I've also managed to get your source code compiled successfully for the 2012-07 version of UDK and integrated with my pre-existing classes, and am working on integrating the Scaleform stuff now.

            Comment


              #36
              Hello!

              You made a great Job there and this Kit is really helping me out, but I have a Problem.
              I'm pretty new to UDK but I have already a map and some other stuff done, how can I Import the Inventory System to this map?
              I can place Clothin and stuff, and if I walk into them they dissappear and it says the message, but if I walk into a Container wich has some Items in int the inv doesnt Show up.
              How can I fix this and how can I open and Close the Inventory anyways?

              Thanks for your help!

              -gerixxx

              Comment


                #37
                You have to set the gamemode in worldproperties to the inventory one.

                Comment


                  #38
                  Ah ok thanks, and how do I open the Inventory without Walking into a Container?

                  Comment


                    #39
                    There was a shortcut for that. Ah, you have to type into console "toggle inventory" or something like that. You'' find the exec function in code. Then you can bind it, using default input config file, to a key.

                    Comment


                      #40
                      Greetings and a huge thank you for sharing this with the community Chosker, I'm currently attempting to stitch this together with a randomized loot code I've been working on and ran into a problem locating how your code handles catching the string values of Object-name/Durability/Value and passes them to the scaleform HUD. Your code is set out very neatly which has allowed me to change the values being displayed simply enough. However I would like to add whole new variable fields that will be displayed to the HUD when an item is hovered over. Could you point me in the direction or even the class that is handling this so I may investigate more closely?

                      This seems to be where the breadcrumbs lead me, Is my answer hiding in the flash file?
                      Code:
                      simulated function SendItem(string ContainerType, string idemID, string itemSlot, string itemType, string itemName, string itemQuantity, string itemDurability, string itemMaxDurability, string itemValue)
                      {
                      	//`log("SendItem "$bEnabled$" "$itemID$" "$itemSlot$" "$itemType$" "$itemName$" "$itemQuantity$" "$itemWeight$" "$itemQuality$" "$itemDurability$" "$itemMaxDurability);
                      	ActionScriptVoid("SetItemByString");
                      }
                      Thanks in advance.

                      Comment


                        #41
                        the answer lies in the flash file yes. you have the SendItem function with all the parameters that I coded in, and these parameters get send to flash via ActionScriptVoid("SetItemByString");.
                        I know it doesn't seem like it, but ActionScriptVoid("SetItemByString"); actually passes all the parameters that were passed into the SendItem function. so if you open the flash file and goto the actionscript code, you'll be able to find a matching SetItemByString function with all the matching parameters (ContainerType, itemID, etc).
                        want to pass even more parameters? no problem, just add them to the end of both the SendItem function in UnrealScript, and the SetItemByString function in actionscript

                        Comment


                          #42
                          Hi Chosker. Great work on the inventory. I've been working to adapt it for a contemporary setting with clothes instead of armor.

                          I have a question for anyone following this thread:
                          One persistent problem that is: Unrecognized type 'archtype' in both the Pawn and InventoryContainer files. I've double checked that all the resources are in the correct place and searched the code for an object def. of 'archtype' but I've not had any luck finding it so far. Is it possibly a case-mismatch error, as "Archtype..." does appear elsewhere in the code?
                          Has anyone else seen similar issues?

                          I'd appreciate any help with this.

                          Edit:

                          I found this link that explains what the archtype is and how to create them.
                          http://udn.epicgames.com/Three/UsingArchetypes.html
                          This leads me to believe that I misplaced one of the resource files but they all seem to be accounted for. I'll continue to look into it.

                          Comment


                            #43
                            Que the laugh track. Two days of beating my head against this problem have finally come to an end. All the resources were in the correct place all along. The problem: A spelling error.'Archtype' should have been spelled 'Archetype'. Spelling it without the 'e' seemed so intuitively correct that I never questioned it. Why would there be an 'e'? I'm not scripting in French!

                            Lessons learned:
                            * Install the spell-check module into your script environment. It might save you days of work.

                            Comment


                              #44
                              Thanks Chosker for your hard work. For me this helps with more different perspectives on code, and how to it!

                              Comment


                                #45
                                Link is dead and im really lurking this stuff, please reupload.
                                Also for anyone who is gonna tell me omg dude ue4 is out what are you doing with udk, i know. I am just fan of udk and i really want this kit.
                                Thanks

                                Comment

                                Working...
                                X