Announcement

Collapse
No announcement yet.

WIP Coral Reef

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    WIP Coral Reef

    Allright I'm creating a coral reef and i wanted to post my images and yalls input....also I have just encountered a error that will not allow me to PIE any more....nor will it allow me to play the level in the UDK game....oddly enough it worked yesterday...so not sure whats going on anway im including the log as well as some screens. Let me know what yall think

    Code:
    Log: Log file open, 10/19/11 09:21:20
    Init: WinSock: version 1.1 (2.2), MaxSocks=32767, MaxUdp=65467
    DevConfig: GConfig::LoadFile associated file:  ..\..\UDKGame\Config\UDKCompat.ini
    DevConfig: GConfig::Find has loaded file:  ..\..\Engine\Config\ConsoleVariables.ini
    Init: Version: 8710
    Init: Epic Internal: 0
    Init: Compiled (64-bit): Jul 18 2011 18:42:12
    Init: Changelist: 955963
    Init: Command line: editor -D3D11 
    Init: Base directory: C:\UDK\UDK-2011-07\Binaries\Win64\
    [0000.52] Init: Computer: TYLER-LAPTOP
    [0000.52] Init: User: Tyler
    [0000.52] Init: CPU Page size=4096, Processors=8
    [0000.52] Init: High frequency timer resolution =1.948759 MHz
    [0000.52] Init: Memory total: Physical=12.0GB Pagefile=24.0GB Virtual=8192.0GB
    [0000.55] Init: WinSock: I am Tyler-Laptop (172.16.0.111:0)
    [0000.55] Init: Presizing for 0 objects not considered by GC, pre-allocating 0 bytes.
    [0000.55] Init: Object subsystem initialized
    [0000.59] Log: Found D3D11 adapter 0: NVIDIA GeForce GTX 560M 
    [0000.59] Log: Adapter has 3034MB of dedicated video memory, 0MB of dedicated system memory, and 1023MB of shared system memory
    [0000.64] Log: Shader platform (RHI): PC-D3D-SM5
    [0000.99] Log: PhysX GPU Support: DISABLED
    [0001.00] Init: Initializing FaceFX...
    [0001.00] Init: FaceFX 1.7.4 initialized.
    [0005.34] Init: Finished loading startup packages in 4.20 seconds
    [0005.34] Log: 75481 objects as part of root set at end of initial load.
    [0005.34] Log: 0 out of 0 bytes used by permanent object pool.
    [0005.55] Log: Supported Consoles:
    [0005.55] Log:   IPhone
    [0005.55] Log:   PC
    [0005.55] Log: Initializing Engine...
    [0005.60] Log: Encountered missing default brush - spawning new one
    [0005.60] Init: UEngine initialized
    [0005.60] Log: Primary PhysX scene will be in software.
    [0005.60] Log: Creating Primary PhysX Scene.
    [0005.61] Init: Transaction tracking system initialized
    [0005.61] Log: Can't find edit package 'OnlineSubsystemGameSpy'
    [0005.61] Log: Can't find edit package 'OnlineSubsystemLive'
    [0006.03] Init: XAudio2 using 'Speakers (Realtek High Definition Audio)' : 2 channels at 48 kHz using 32 bits per sample (channel mask 0x3)
    [0006.09] Log: Working around XDK XAudio2 regression: TRUE
    [0006.10] Init: XAudio2Device initialized.
    [0006.21] Log: WinTab initalized successfully.
    [0006.21] Init: Client initialized
    [0006.21] Init: Editor engine initialized
    [0006.29] Log: Initializing Engine Completed
    [0006.29] Log: >>>>>>>>>>>>>> Initial startup: 6.29s <<<<<<<<<<<<<<<
    [0006.36] Cmd: MODE MAPEXT=udk
    [0006.44] SourceControl: Source Control disabled in UDKEditorUserSettings.ini.  [SourceControl] has Disabled=True
    [0006.45] SourceControl: Source Control disabled in UDKEditorUserSettings.ini.  [SourceControl] has Disabled=True
    [0007.96] Log: The hooked GetPenEventMultiple() method was called; events are being ignored.
    [0007.96] Log: Found D3D11 adapter 0: NVIDIA GeForce GTX 560M 
    [0007.96] Log: Adapter has 3034MB of dedicated video memory, 0MB of dedicated system memory, and 1023MB of shared system memory
    [0009.29] Log: Detected 1 GPUs for rendering
    [0009.41] Cmd: MAP LOAD FILE="..\..\Engine\Content\Maps\Templates\Template_MidDay.umap" TEMPLATE=0
    [0009.62] Log: Encountered missing default brush - spawning new one
    [0009.90] Log: New File, Existing Package (Package Untitled_2, Package Template_MidDay)
    [0009.96] Log: -- Checking Building LODs
    [0009.96] Log: Primary PhysX scene will be in software.
    [0009.96] Log: Creating Primary PhysX Scene.
    [0009.97] Log: Finished looking for orphan Actors (0.004 secs)
    [0009.97] Cmd: MAP CHECKDEP DONTCLEARMESSAGES
    [0010.05] Log: TIMER ALL OF INIT : [9.046165]
    [0015.24] Cmd: MAP LOAD FILE="C:\UDK\UDK-2011-07\UDKGame\Content\Maps\Examples\UDKFrontEndMap.udk" TEMPLATE=0
    [0015.28] Log: Encountered missing default brush - spawning new one
    [0015.86] Log: !!!!!!!!!!!!!!!!!!!!!!!!!!   CPU skinned UDKFrontEndMap.TheWorld:PersistentLevel.SkeletalMeshActor_0.SkeletalMeshComponent_13 spar2.Mesh.fishface_rug 1 0 1 0
    [0015.86] Log: !!!!!!!!!!!!!!!!!!!!!!!!!!   CPU skinned UDKFrontEndMap.TheWorld:PersistentLevel.SkeletalMeshActor_0.SkeletalMeshComponent_13 spar2.Mesh.fishface_rug 1 0 1 0
    [0016.02] Log: -- Checking Building LODs
    [0016.03] Log: Primary PhysX scene will be in software.
    [0016.03] Log: Creating Primary PhysX Scene.
    [0016.03] Log: Finished looking for orphan Actors (0.005 secs)
    [0016.17] Cmd: MAP CHECKDEP DONTCLEARMESSAGES
    [0663.35] Log: 
    ==== Worlds needing PIE Save:
    [0663.35] Log: UDKFrontEndMap
    [0663.35] Log: ==== 1 total
    [0663.42] Log: Built Phys StaticMesh Cache: 8.962 ms
    [0663.42] Log: COOKEDPHYSICS: 0 TriMeshes (0.000000 KB), 2 Convex Hulls (2.164063 KB) - Total 2.164063 KB
    [0663.46] Log: !!!!!!!!!!!!!!!!!!!!!!!!!!   CPU skinned UDKFrontEndMap.TheWorld:PersistentLevel.SkeletalMeshActor_0.SkeletalMeshComponent_13 spar2.Mesh.fishface_rug 1 0 1 0
    [0664.46] Log: Save=1042.659457
    [0664.46] Log: Moving 'C:\UDK\UDK-2011-07\Binaries\Win64\..\..\UDKGame\Autosaves\UEDPIEUDKFrontEndMap_save.tmp' to 'C:\UDK\UDK-2011-07\Binaries\Win64\..\..\UDKGame\Autosaves\UEDPIEUDKFrontEndMap.udk'
    [0664.49] Cmd: MAP LOAD PLAYWORLD=1 FILE="C:\UDK\UDK-2011-07\Binaries\Win64\..\..\UDKGame\Autosaves\UEDPIEUDKFrontEndMap.udk"
    [0664.83] Log: Finished looking for orphan Actors (0.003 secs)
    [0664.83] Log: Game class is 'GameInfo'
    [0664.90] Log: !!!!!!!!!!!!!!!!!!!!!!!!!!   CPU skinned UEDPIEUDKFrontEndMap.TheWorld:PersistentLevel.SkeletalMeshActor_0.SkeletalMeshComponent_13 spar2.Mesh.fishface_rug 1 0 1 0
    [0664.95] Log: Primary PhysX scene will be in software.
    [0664.95] Log: Creating Primary PhysX Scene.
    [0665.07] PerfWarning: bEnableValidBounds not set while bEnableClothTearing is set. Possible performance issue.  SkeletalMeshComponent: SkeletalMeshComponent_13, SkeletalMesh: fishface_rug
    [0665.07] Log: *** WARNING - PATHS MAY NOT BE VALID ***
    [0665.07] Log: Bringing World UEDPIEUDKFrontEndMap.TheWorld up for play (0) at 2011.10.19-09.32.24
    [0665.08] Log: Bringing up level for play took: 0.214812
    [0665.12] Log: PIE: play in editor start time for UEDPIEUDKFrontEndMap 1.971
    [0665.17] Critical: appError called: Assertion failed: i>=0 && (i<ArrayNum||(i==0 && ArrayNum==0)) [File:d:\depot\unrealengine3\development\src\core\inc\Array.h] [Line: 575]
    
    Stack: Address = 0x4021d9d9 (filename not found) [in C:\UDK\UDK-2011-07\Binaries\Win64\UDK.exe]
    Address = 0x404e93a6 (filename not found) [in C:\UDK\UDK-2011-07\Binaries\Win64\UDK.exe]
    Address = 0x4052d5ae (filename not found) [in C:\UDK\UDK-2011-07\Binaries\Win64\UDK.exe]
    Address = 0x4090c606 (filename not found) [in C:\UDK\UDK-2011-07\Binaries\Win64\UDK.exe]
    Address = 0x40923222 (filename not found) [in C:\UDK\UDK-2011-07\Binaries\Win64\UDK.exe]
    Address = 0x404df972 (filename not found) [in C:\UDK\UDK-2011-07\Binaries\Win64\UDK.exe]
    Address = 0x406f2901 (filename not found) [in C:\UDK\UDK-2011-07\Binaries\Win64\UDK.exe]
    Address = 0x406f371d (filename not found) [in C:\UDK\UDK-2011-07\Binaries\Win64\UDK.exe]
    Address = 0x406f6315 (filename not found) [in C:\UDK\UDK-2011-07\Binaries\Win64\UDK.exe]
    Address = 0x412722d5 (filename not found) [in C:\UDK\UDK-2011-07\Binaries\Win64\UDK.exe]
    Address = 0x413cbfea (filename not found) [in C:\UDK\UDK-2011-07\Binaries\Win64\UDK.exe]
    Address = 0x417598a1 (filename not found) [in C:\UDK\UDK-2011-07\Binaries\Win64\UDK.exe]
    Address = 0x4175a1a9 (filename not found) [in C:\UDK\UDK-2011-07\Binaries\Win64\UDK.exe]
    Address = 0x800c965e (filename not found) [in C:\UDK\UDK-2011-07\Binaries\Win64\wxmsw28u_core_vc_custom_64.dll]
    Address = 0x800041ce (filename not found) [in C:\UDK\UDK-2011-07\Binaries\Win64\wxmsw28u_core_vc_custom_64.dll]
    Address = 0x950783   (filename not found) [in C:\UDK\UDK-2011-07\Binaries\Win64\wxmsw28u_vc_custom_64.dll]
    Address = 0x800db784 (filename not found) [in C:\UDK\UDK-2011-07\Binaries\Win64\wxmsw28u_core_vc_custom_64.dll]
    Address = 0x4175e6b3 (filename not found) [in C:\UDK\UDK-2011-07\Binaries\Win64\UDK.exe]
    Address = 0x4175e78a (filename not found) [in C:\UDK\UDK-2011-07\Binaries\Win64\UDK.exe]
    Address = 0xf32cff82 (filename not found) [in C:\Windows\Microsoft.NET\Framework64










    #2
    Great !! But.. some little mistakes which I would like to bold:
    1. you made it too simple - some little hills near the wavy sand which are covered by the corals are not really cool, the usual corals are growing for much bigger colonies
    2. the ground: there is no sand between the corals which are placed nearly because these intervals are full of moss stone and other corals, you may want to add some rocky landscape
    3. you made the reef to look too rich of different coral species, these colorful corals are should to be grouped into colonies - this is the way they are growing up and living under the water in a real life. Also it would look even better in-game if you used this way. Your screenshots look like if there was a giant opened chest with all the gold and jewerly which were brought out to the sandy hills, looks really funny but not naturally.

    Sorry for english
    Otherwise is great, keep it up mate !

    Comment


      #3
      Coral looks reeeeeally cool

      Critical: appError called: Assertion failed: i>=0 && (i<ArrayNum||(i==0 && ArrayNum==0)) [File:d:\depot\unrealengine3\development\src\core\i nc\Array.h] [Line: 575]

      Are you writing over native classes? If you mess with Epic's code, you're bound to get these errors.
      This file: File:d:\depot\unrealengine3\development\src\core\i nc\Array.h
      This line: [Line: 575]

      What are you doing there? The log tells you what to do, you just have to undo what you did there.

      Comment


        #4
        Hrm....I really don't know what is going on in that line...I'm not doing anything technical, I barely know coding I have a foot into python and thats it, but oddly enough it is working now...after i went to the location where it said there was missing files i double click the udk.exe it crashed , then i ran the editor again and its working fine now....so, i dont know if out of the woods yet. Thank you for pointing that out carsten, do you happen to know what its trying to do with that file or did i acidently gunk something up on my end?

        Jarro,
        Some good pointers. I must admit it has been a very interesting challenge trying to find the right balance between oceanic reef coral and the coral of a fish tank.
        also i wanted to show you some of the reference that im using for the coral and the sand. But yes i do agree that the colors are to intense it what i have now and does not match anything ive seen other than reef images out of a tank. I am going for a slightly stylized look but i want it to still feel real. I'll be adding a water plane and such hopefully get that in, in a few minutes. and when i do ill throw some images up

        Thank you for the crits keep em coming guys!


        Comment


          #5
          Um I wont lie - your screenshots do not match the real underwater shots. At the first, it is really monochromic (it is caused by a sun light though). And at the second - you can see that there are some colonies made of only one type. It alternates itself, so ... And at the third - in my honest opinion you should to... plant some corals at the edges and surfaces of the bedrock which are naked..
          I'm sure you already knew all these things, so good luck with that ! It is really cool

          Comment


            #6
            Jarro,

            I feel like im still struggling with what you have stated, but i have added coral on the edges so that's a bit fixed but i do feel that its to color full compared to oceanic reefs...I'll have to tackle that when i get my anemones back in.

            So i wanted to put up new images from yesterday but that just wasnt possible due to UDK acting up...and trying to bring disco back.
            But i have most things under control, i still need to restore my anemone during all the chaos of yesterday they lost their animation tree links and materials so i need to go restore that but im postponing that till i have placed all of them
            but I have reworked my lighting and placed alot of assets.
            So let me know what yall think.


            UDK Disco Party








            Comment


              #7
              Here are some more



              Comment


                #8
                I have been messing around with the mat editor trying to get a rim shader to work on some of my coral and i wanted to post what i had gotten so far and let me know what you think.

                The coral that have the rim shader on them are the orange tubes and the grungy looking tubes.



                Comment


                  #9
                  Looking great, the lighting is awesome. Time to hop on a plane to some tropical paradise and do some real world studies I think!

                  Comment


                    #10
                    Thank you Ironbelly its ironic you say that because right now I am having major issues with my lighting.
                    It seems to just ranomly blow out areas with seemingly no logical explanation. I'll be blown out in one area lower a light value then be blown out in a area that is not even in the lights sphere of influence. Ive changed lightmap sizes to no real effect.
                    I'm at a loss. Does anyone know what im doing wrong?

                    Comment


                      #11
                      Make sure your materials don't have any crazy values. Sometimes this type of thing will happen if a value is way over 1, for example.

                      Comment


                        #12
                        micahpharoh,

                        thank you yeah i do have some mats where i am boosting the emisive channel.

                        but what was really odd was that I took out one light and it seemed to fix everything can lights go corrupt?
                        so now everything seems to be working.

                        I wanted to show yall the environment in action so take a look and let me know what you think

                        http://vimeo.com/31100450

                        Comment


                          #13
                          Looks nice. I sense a halo fan

                          Comment


                            #14
                            ahha yes, well sadly none of the gears music would fit hahah.
                            and im hoping to post screens of the first part of the chest sculp today

                            Comment


                              #15
                              I feel like the lighting is too dark, unless it's at night then it's just kinda off I guess.

                              Comment

                              Working...
                              X