Announcement

Collapse
No announcement yet.

Yet Untitled Platforming Game

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    #31
    Yeah, I just reinstalled the system so I'm 100% sure - I downloaded them straight from nVidia's website, made sure they're for x64 etc. etc.

    Comment


      #32
      try changing compatibility properties on udk.exe.
      just guessing...

      Comment


        #33
        So is this not going to work in versions after Decembers version? I tried it with the new (February) update and I keep getting an error for line 1783, error with "If". tried a few differant things and I still get the same error? Is it something I am doing wrong or are people getting this same error ever

        Comment


          #34
          Originally posted by Dandi8 View Post
          Since quite a few people asked me how I did this and that, I decided to post the most recent source code of my platformer, which has now been put on hold:
          http://uploading.com/files/2dfcccm9/PlatformGame.rar

          Hopefully it'll help someone
          Hi Dandi8, great job on the platformer so far and it's very generous of you to share the code!

          I tried to run it on my machine, recompiled the scripts and ran it with
          SimpleMap.udk?game=PlatformGame.MyGameInfo

          Everything works great except my mouse doesn't seem to be responding. So I can't control the aiming or turning the character. Is there an extra step I missed?

          Comment


            #35
            @JeJones:
            AFAIK the compatibility options are for compatibility with older systems, not older platforms (or whatever they're called).

            @DanBanna:
            Which file has the error? The build should work with the newest build - it's just code after all.

            @Jaggedge:
            The mouse isn't supposed to be working - controls are supposed to work the same way as in the Metroid games - go right to shoot right, go left to shoot left, press up to shoot at an angle, jump while pressing up to shoot straight up etc. etc.

            I reccomend that you play the game windowed because there's some sort of a bug that occasionaly prevents you from aiming while the camera is close to the character which seems to be partially solved by playing windowed.

            If you, however, want to make Abuse-style controls, it should be just a matter of recoding a few things. The aim would have to be set to the mouse (using something like the Deproject function) and then you'd have to draw a crosshair at the mouse's position and you're done I think

            Comment


              #36
              Hi Dandi8! Thanks for such a prompt reply!

              I see, then there's definitely something wrong with the way I set it up, because it's my Up arrow key ( and "W" ) that moves the character forward/right..! And my Down arrow key ( and "S" ) does not turn the character around to face the left.

              Comment


                #37
                Originally posted by Dandi8 View Post
                Yeah, I just reinstalled the system so I'm 100% sure - I downloaded them straight from nVidia's website, made sure they're for x64 etc. etc.
                There are at least 4 threads stating that the latest nVidia WHQL and the latest nVidia beta drivers are broken.... could it be you use one of those drivers?

                Comment


                  #38
                  Jaggedge, you need to configure the input file. I'll upload mine in a sec.

                  @eAlex79:
                  It could be... damnit!
                  Thanks, dude Didn't notice those threads.

                  EDIT:
                  Here's the UTInput file:
                  http://uploading.com/files/7dc9edbc/UTInput.ini/
                  I forgot I added a command or two on my own that get executed there.

                  Comment


                    #39
                    I took your UTInput.ini and overwrote the one existing in my C:\UDK\UDK-2010-02\UTGame\Config\ folder, but nothing changed?

                    I see the changes that you made:
                    Bindings=(Name="W",Command="aimUp | OnRelease aimNormal")
                    ;Bindings=(Name="S",Command="GBA_Backward")
                    Bindings=(Name="S",Command="aimDown | OnRelease aimNormal")
                    Bindings=(Name="A",Command="GBA_StrafeLeft")
                    Bindings=(Name="D",Command="GBA_StrafeRight")

                    So I'm not sure why it still isn't registering your controls?

                    *Edit: Hmm, it seems that each time I launch the map, your UTInput.ini gets overwritten again by the default one..

                    **Edit2: I checked the ReadOnly property and everything runs great now, thanks Dandi8! I really like the controls, the camera zoom is a nice touch!

                    Comment


                      #40
                      nice dude keep up the good work

                      Comment


                        #41
                        To make it permanent, you should probably also overwrite DefaultUTInput

                        Comment


                          #42
                          Your game looks exactly what i wann do for my project but i have little to no experience with unrealscript. So i was wondering if you could write the steps to get this working for me.

                          Like which config files i have to change and stuff like that because atm when i play the level i am flying around with no character visible

                          Comment


                            #43
                            Has anyone made some more updates to this package, and want to share them for learning purposes ?

                            Comment


                              #44
                              Originally posted by jameso123 View Post
                              Your game looks exactly what i wann do for my project but i have little to no experience with unrealscript. So i was wondering if you could write the steps to get this working for me.

                              Like which config files i have to change and stuff like that because atm when i play the level i am flying around with no character visible

                              I'm in exactly the same boat. Completely brand new to UDK as well so although it's useful reading extensively on these forums, some of the absolute basics get missed (like where new code goes, ini files, how to actually test the new code in UDK?)

                              Any help would be greatly appreciated!

                              Comment


                                #45
                                Originally posted by zdegrees View Post
                                I'm in exactly the same boat. Completely brand new to UDK as well so although it's useful reading extensively on these forums, some of the absolute basics get missed (like where new code goes, ini files, how to actually test the new code in UDK?)

                                Any help would be greatly appreciated!

                                check this out
                                http://utforums.epicgames.com/showthread.php?t=707020

                                Comment

                                Working...
                                X