Announcement

Collapse

The Infinity Blade Forums Have Moved

We've launched brand new Infinity Blade forums with improved features and revamped layout. We've also included a complete archive of the previous posts. Come check out the new Infinity Blade forums.
See more
See less

[DT3D] UDK Skin Shader

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

    #16
    Very nice. I am still educating myself with the material editor. So, nice to have references to study. Thank you.

    Comment


      #17
      Hi migusan76,

      Really, really, REALLY great work. I have the original book by nVidia (GPUGems 3), and for me it's really difficult stuff. I've been trying to get sss going inside the UDK, but with little success.

      So thank you so much for 'converting'/adapting this technique to the UDK. The scattering is beautiful!

      Charles

      Comment


        #18
        thanks Charles and Denny! Really glad to hear this Is helping out.

        Comment


          #19
          Finally found some time to play your shader and it is really fantastic work. Still images do not do it justice.
          I still very new to creating Unreal shaders so excuse my ignorance but I can not find where get access to the Common Material Attribute Information as shown in your instructions.

          Comment


            #20
            Hi JohnLA, No problem. I guess I should have stated it in the instructions, but normally if you right click the material and make an instance of it you can get the shader parameters and tweak that way.

            Comment


              #21
              Bravo, all works great now

              Comment


                #22
                Whoa! That's Awesome! How do people even begin to figure out their own custom lighting materials is beyond me.

                Comment


                  #23
                  Hi migusan76,

                  I'm running into an issue with your shader.

                  Everything works fine in the material editor.. But as soon as I add a model to a scene the scattering disappears, and after I hit 'Build All', the normal maps don't work anymore, and I only see a smooth surface with the diffuse map, no scattering or other effects.

                  Any idea what would cause this?

                  Thanks!
                  Charles

                  Comment


                    #24
                    Static lit static meshes don't look that good.. put it on a Skeletal Mesh or something that moves around and is dynamically lit

                    Comment


                      #25
                      Ooops, yes of course Thanks eAlex79. And wow... the shader even looks a lot better now with the scene lighting!

                      Comment


                        #26
                        I also noticed that he sets his textures to be saved as TEXTUREGROUP_Skybox textures instead of TEXTUREGROUP_Character and that allows for 2048 textures and does not downsize them to 1024

                        Comment


                          #27
                          If you setup your ini's right you don't have to put your texture to the wrong group

                          Comment


                            #28
                            Superb, this exactly what characters should be pushed to.

                            Comment


                              #29
                              Hi migusan76,

                              Another question on your shader. In the nVidia Human Head demo there is a parameter called "waxy".

                              I would like to use such a parameter to increase or even exaggerate the scattering effect, also to create non-human skin effects.

                              I tried to find such control in your shader by tweaking it, but since I don't really understand what's happening under the hood I failed in achieving this.

                              Could you tell me what I should change to create a similar parameter?

                              Thanks,
                              Charles

                              Comment


                                #30
                                Hi Charles,
                                There should be a way to control the density of the material, by simply multiplying the top diffuse layer and the normalizing table, but this would only decrease the scattering effect. The nvidia is a little more complex since its running the diffusion blurs in real-time in texture space. So that waxy attribute is probally some sort of factor to increase the gaussian blurs which in essense increase the blur radius and the scattering effect. Not sure that can be done in UDK and it be running efficient.

                                Comment

                                Working...
                                X