Results 1 to 20 of 20
  1. #1
    The Sacrifice
    Join Date
    Feb 2012
    Location
    Germany
    Posts
    113

    Default UDK stoped workin on startup.

    Hi,

    i build a custom setup for my first indie game. But i have a problem running it on other system. Installing and playing in on the dev pc is working without any problems. Now i installed it on 2 other PCs and i get this error in Logfiles:

    [0006.21] Critical: appError called: Assertion failed: i>=0 && (i<ArrayNum||(i==0 && ArrayNum==0)) [File:d:\depot\unrealengine3-udk\development\src\core\inc\Array.h] [Line: 581]

    Stack: Address = 0xf41f39 (filename not found) [in D:\Program Files (x86)\Revenge of the Fallen - Alpha Demo\Binaries\Win32\RotF.exe]

    [0006.21] Critical: Windows GetLastError: Der Vorgang wurde erfolgreich beendet. (0)
    [0008.93] Log: === Critical error: ===
    Assertion failed: i>=0 && (i<ArrayNum||(i==0 && ArrayNum==0)) [File:d:\depot\unrealengine3-udk\development\src\core\inc\Array.h] [Line: 581]

    Stack: Address = 0xf41f39 (filename not found) [in D:\Program Files (x86)\Revenge of the Fallen - Alpha Demo\Binaries\Win32\RotF.exe]


    System.Runtime.InteropServices.SEHException error in UDK:

    Eine externe Komponente hat eine Ausnahme ausgelöst.

    bei GuardedMainWrapper(Char* , HINSTANCE__* , HINSTANCE__* , Int32 )
    bei ManagedGuardedMain(Char* CmdLine, HINSTANCE__* hInInstance, HINSTANCE__* hPrevInstance, Int32 nCmdShow)Address = 0x7574c41f (filename not found) [in C:\Windows\syswow64\KERNELBASE.dll]
    Address = 0xfa8c31 (filename not found) [in D:\Program Files (x86)\Revenge of the Fallen - Alpha Demo\Binaries\Win32\RotF.exe]
    Address = 0xfe3ab3 (filename not found) [in D:\Program Files (x86)\Revenge of the Fallen - Alpha Demo\Binaries\Win32\RotF.exe]
    How can i fix this? The RotF.exe is there and i don't know why the log say's 'not found' and whats about the KERNELBASE.dll?
    Thanks for your help.

  2. #2
    Palace Guard
    Join Date
    Oct 2002
    Location
    Western Canada
    Posts
    3,437

    Default

    Is KernelBase.dll actually in the C:\Windows\SysWOW64\ folder on the PCs?
    This is a standard Windows file on Windows 64-bit OS'es so it should be there.

    I have a feeling that those "filename not found" errors are not actually relevant.

    The failed assert is on the array line which looks like an array parameter error or index out-of-bounds error.
    An assertion failure is an error thrown by one of the standard C++ library functions when it is called with invalid parameters.
    I'm guessing that there is an array created somewhere in the scripts or engine with issues or whose bounds are not being properly checked.

    You are running the 32-bit RotF.exe in the Win32 folder, correct?
    DG - LCS - TerreSculptor blog - TerreSculptor wiki - Game Tools Developer - Indie UDK Game Developer - UDN Documentation

  3. #3
    The Sacrifice
    Join Date
    Feb 2012
    Location
    Germany
    Posts
    113

    Default

    Quote Originally Posted by DGUnreal View Post
    Is KernelBase.dll actually in the C:\Windows\SysWOW64\ folder on the PCs?
    You are running the 32-bit RotF.exe in the Win32 folder, correct?
    Yes, to both of them.
    The problem is, there is no other code in the game/engine. It's default at the moment.
    If i build the game with Frontend installing it, i can play it without any problem.

    I made my own setup like this way:

    1. Installing the Frontend Build
    2. Change .exe Icon and name
    3. Added user Code for SaveSystem
    4. Created a Setup with Inno Setup that install's the UE3Redist after setup.

    So nothing special but it won't work. I'm working on this projekt now for 5 month and everything is working great. Only the setup is f***ked up -.-

  4. #4
    The Sacrifice
    Join Date
    Feb 2012
    Location
    Germany
    Posts
    113

    Default

    Still need help =/

  5. #5

    Default

    I can only put my finger on your custom installer/settings.

    Do a *standard* packaging using unreal frontend (without changing the .exe file names and all), and test it, if it solved the problem it means you packaging is at fault.

  6. #6
    The Sacrifice
    Join Date
    Feb 2012
    Location
    Germany
    Posts
    113

    Default

    And thats the problem..

    default installer: working fine on any pc (but usercode is missing)
    custom installer: working on my developer pc but crashes on startup on any other pc
    Zip folder from default installer:: working on my developer pc but crashes on startup on any other pc

    I think the default installer copys some files to a windows folder or a regestry entry. But i don't not what.
    I can give someone the default installer and he tries to make a custom setup and tell me how and give me the installer script?

    That would be great!

  7. #7
    Redeemer
    Join Date
    Nov 2009
    Location
    Caracas
    Posts
    1,819
    Gamer IDs

    Gamertag: daimakupikoro PSN ID: lone_vampire

    Default

    i'm guessing, but your first line of code is an error in the array.h class, check your code, if you are using arrays maybe you have some wrong condition and is resulting in a infinite loop.
    http://vincenzoravo.vrs.com.ve http://www.slaughtermaze.com

    please don't fill my inbox with questions, ask in the forum, the answers will help you and others !!!

  8. #8
    The Sacrifice
    Join Date
    Feb 2012
    Location
    Germany
    Posts
    113

    Default

    Quote Originally Posted by daimaku View Post
    i'm guessing, but your first line of code is an error in the array.h class, check your code, if you are using arrays maybe you have some wrong condition and is resulting in a infinite loop.
    I'm only using the UltimateSaveSystem in the UserCode Folder.


    File:d:\depot\unrealengine3-udk\development\src\core\inc\Array.h
    The path d:\depot does not exist. So it's not possible to check any files in an non-existing folder.

    And why should there be any error in a file. The game is working with the default installer! Copy the files from the default frontend installer to another pc and this fake bulls**t log is there and i don't know why and how to fix it.

    This is a senseless and unprovoked error. Just copy a working game and it's not working anymore ...
    Is there any support email from Epic? Just found one for korea and china =/

  9. #9
    Redeemer
    Join Date
    Nov 2009
    Location
    Caracas
    Posts
    1,819
    Gamer IDs

    Gamertag: daimakupikoro PSN ID: lone_vampire

    Default

    i'm not talking about your UserCode folder, i'm talking about the code of your scripts.
    http://vincenzoravo.vrs.com.ve http://www.slaughtermaze.com

    please don't fill my inbox with questions, ask in the forum, the answers will help you and others !!!

  10. #10
    The Sacrifice
    Join Date
    Feb 2012
    Location
    Germany
    Posts
    113

    Default

    Yes but why should there something wrong?
    Installed with default setup the file is working without any error. How should there be an error on a working file.

  11. #11
    Redeemer
    Join Date
    Nov 2009
    Location
    Caracas
    Posts
    1,819
    Gamer IDs

    Gamertag: daimakupikoro PSN ID: lone_vampire

    Default

    you have custom classes ? check them
    http://vincenzoravo.vrs.com.ve http://www.slaughtermaze.com

    please don't fill my inbox with questions, ask in the forum, the answers will help you and others !!!

  12. #12

    Default

    Quote Originally Posted by vesta View Post
    default installer: working fine on any pc (but usercode is missing)
    custom installer: working on my developer pc but crashes on startup on any other pc
    Zip folder from default installer:: working on my developer pc but crashes on startup on any other pc
    I'm guessing your custom installer doesn't install the pre-requisites for UE3. The reason it would work for your PC is that they would already be installed.
    I'm making a game!

    http://www.desura.com/games/modulated
    Click the link above to read more!

  13. #13
    The Sacrifice
    Join Date
    Feb 2012
    Location
    Germany
    Posts
    113

    Default

    Quote Originally Posted by daimaku View Post
    you have custom classes ? check them
    No. Only the working UlimateSaveSystem.

    Quote Originally Posted by Graylord View Post
    I'm guessing your custom installer doesn't install the pre-requisites for UE3. The reason it would work for your PC is that they would already be installed.
    What is all the pre-requisites for UE3? The UE3Redist.exe? This is installed several times on the other PC and it won't help.
    What else could it be?

  14. #14
    Redeemer
    Join Date
    Nov 2009
    Location
    Caracas
    Posts
    1,819
    Gamer IDs

    Gamertag: daimakupikoro PSN ID: lone_vampire

    Default

    Quote Originally Posted by vesta View Post
    What is all the pre-requisites for UE3? The UE3Redist.exe? This is installed several times on the other PC and it won't help.
    What else could it be?
    directx and the net framework
    http://vincenzoravo.vrs.com.ve http://www.slaughtermaze.com

    please don't fill my inbox with questions, ask in the forum, the answers will help you and others !!!

  15. #15
    The Sacrifice
    Join Date
    Feb 2012
    Location
    Germany
    Posts
    113

    Default

    UE3Redist.exe installs DX9 and net framework ?!

  16. #16
    Palace Guard
    Join Date
    Oct 2002
    Location
    Western Canada
    Posts
    3,437

    Default

    Quote Originally Posted by vesta View Post
    The path d:\depot does not exist. So it's not possible to check any files in an non-existing folder.
    That is not referring to a local path on your system.

    Quote Originally Posted by vesta View Post
    And why should there be any error in a file. The game is working with the default installer! Copy the files from the default frontend installer to another pc and this fake bulls**t log is there and i don't know why and how to fix it.
    If any of the library files (prerequisites) are missing or have versioning issues, then the calls to those missing or invalid files can throw those assertion errors.
    Installing prerequisites may also make changes to the target system's registry, which is why simply copying files won't always work.
    Simply copying subsystem files to another PC can result in serious versioning issues that will trash the system.
    And if the target computer systems have something messed up in their current VCRedist, DirectX, or dotNET, then that computer may be suffering versioning issues.
    That is why I stated in my first post that the errors you are getting may not actually be relevant.

    Check to see if the error is being logged by Windows.
    It may be getting logged if the issue is in one of the subsystems such as DirectX or dotNET etc.
    Run the game to the crash, note the time, launch Event Viewer (Control Panel, Administrative Tools, Windows Logs, usually Application but could be in System), look for any crash report at that same time (error entry), and see if it lists in the crash information what dll the error occurred in. If it is getting logged with the offending file then that will tell you what subsystem is missing or invalid.
    Last edited by DGUnreal; 08-04-2013 at 03:28 PM. Reason: formatting
    DG - LCS - TerreSculptor blog - TerreSculptor wiki - Game Tools Developer - Indie UDK Game Developer - UDN Documentation

  17. #17
    The Sacrifice
    Join Date
    Feb 2012
    Location
    Germany
    Posts
    113

    Default

    Thank you! Test it tomorrow! I hope it works.

  18. #18
    The Sacrifice
    Join Date
    Feb 2012
    Location
    Germany
    Posts
    113

    Default

    I installed DirectX, DotNet and vcredist but is still crashes on startup.

    This is in the Event viewer:

    Application Error:
    Code:
    Name der fehlerhaften Anwendung: UnSetup.exe, Version: 1.0.4797.32539, Zeitstempel: 0x51226d3f
    Name des fehlerhaften Moduls: unknown, Version: 0.0.0.0, Zeitstempel: 0x00000000
    Ausnahmecode: 0xc0000005
    Fehleroffset: 0x000007fe8c5395ec
    ID des fehlerhaften Prozesses: 0x10d8
    Startzeit der fehlerhaften Anwendung: 0x01ce91b738a51bda
    Pfad der fehlerhaften Anwendung: D:\Program Files (x86)\Company\NewProduct\Binaries\UnSetup.exe
    Pfad des fehlerhaften Moduls: unknown
    Berichtskennung: 79bf4bad-fdaa-11e2-a903-e02a82948601
    Code:
    - <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
    - <System>
      <Provider Name="Application Error" /> 
      <EventID Qualifiers="0">1000</EventID> 
      <Level>2</Level> 
      <Task>100</Task> 
      <Keywords>0x80000000000000</Keywords> 
      <TimeCreated SystemTime="2013-08-05T08:39:01.000000000Z" /> 
      <EventRecordID>3225</EventRecordID> 
      <Channel>Application</Channel> 
      <Computer>MOBIL-2013-WEN</Computer> 
      <Security /> 
      </System>
    - <EventData>
      <Data>UnSetup.exe</Data> 
      <Data>1.0.4797.32539</Data> 
      <Data>51226d3f</Data> 
      <Data>unknown</Data> 
      <Data>0.0.0.0</Data> 
      <Data>00000000</Data> 
      <Data>c0000005</Data> 
      <Data>000007fe8c5395ec</Data> 
      <Data>10d8</Data> 
      <Data>01ce91b738a51bda</Data> 
      <Data>D:\Program Files (x86)\Company\NewProduct\Binaries\UnSetup.exe</Data> 
      <Data>unknown</Data> 
      <Data>79bf4bad-fdaa-11e2-a903-e02a82948601</Data> 
      </EventData>
      </Event>
    Windows Error Report:
    Code:
    Fehlerbucket 3489620354, Typ 5
    Ereignisname: CLR20r3
    Antwort: Nicht verfügbar
    CAB-Datei-ID: 0
    
    Problemsignatur:
    P1: unsetup.exe
    P2: 1.0.4797.32539
    P3: 51226d3f
    P4: UnSetup
    P5: 1.0.4797.32539
    P6: 51226d3f
    P7: 7d
    P8: 2
    P9: System.NullReferenceException
    P10: 
    
    Angefügte Dateien:
    C:\Users\Daniel\AppData\Local\Temp\WER75EA.tmp.WERInternalMetadata.xml
    
    Diese Dateien befinden sich möglicherweise hier:
    C:\Users\Daniel\AppData\Local\Microsoft\Windows\WER\ReportArchive\AppCrash_unsetup.exe_3f3571967f33ae94a9fd6edf34362a3f8bb94b1_11f2b125
    
    Analysesymbol: 
    Es wird erneut nach einer Lösung gesucht: 0
    Berichts-ID: 79bf4bad-fdaa-11e2-a903-e02a82948601
    Berichtstatus: 0
    Code:
    - <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
    - <System>
      <Provider Name="Windows Error Reporting" /> 
      <EventID Qualifiers="0">1001</EventID> 
      <Level>4</Level> 
      <Task>0</Task> 
      <Keywords>0x80000000000000</Keywords> 
      <TimeCreated SystemTime="2013-08-05T08:39:17.000000000Z" /> 
      <EventRecordID>3226</EventRecordID> 
      <Channel>Application</Channel> 
      <Computer>MOBIL-2013-WEN</Computer> 
      <Security /> 
      </System>
    - <EventData>
      <Data>3489620354</Data> 
      <Data>5</Data> 
      <Data>CLR20r3</Data> 
      <Data>Nicht verfügbar</Data> 
      <Data>0</Data> 
      <Data>unsetup.exe</Data> 
      <Data>1.0.4797.32539</Data> 
      <Data>51226d3f</Data> 
      <Data>UnSetup</Data> 
      <Data>1.0.4797.32539</Data> 
      <Data>51226d3f</Data> 
      <Data>7d</Data> 
      <Data>2</Data> 
      <Data>System.NullReferenceException</Data> 
      <Data /> 
      <Data>C:\Users\Daniel\AppData\Local\Temp\WER75EA.tmp.WERInternalMetadata.xml</Data> 
      <Data>C:\Users\Daniel\AppData\Local\Microsoft\Windows\WER\ReportArchive\AppCrash_unsetup.exe_3f3571967f33ae94a9fd6edf34362a3f8bb94b1_11f2b125</Data> 
      <Data /> 
      <Data>0</Data> 
      <Data>79bf4bad-fdaa-11e2-a903-e02a82948601</Data> 
      <Data>0</Data> 
      </EventData>
      </Event>

    Application Error:
    Code:
    Name der fehlerhaften Anwendung: RotF.exe, Version: 1.0.10900.0, Zeitstempel: 0x5122c65d
    Name des fehlerhaften Moduls: KERNELBASE.dll, Version: 6.1.7601.18015, Zeitstempel: 0x50b83c8a
    Ausnahmecode: 0x00000001
    Fehleroffset: 0x0000c41f
    ID des fehlerhaften Prozesses: 0x13c4
    Startzeit der fehlerhaften Anwendung: 0x01ce91b737adb19c
    Pfad der fehlerhaften Anwendung: D:\Program Files (x86)\Company\NewProduct\Binaries\Win32\RotF.exe
    Pfad des fehlerhaften Moduls: C:\Windows\syswow64\KERNELBASE.dll
    Berichtskennung: 83eb0d3d-fdaa-11e2-a903-e02a82948601
    Code:
    - <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
    - <System>
      <Provider Name="Application Error" /> 
      <EventID Qualifiers="0">1000</EventID> 
      <Level>2</Level> 
      <Task>100</Task> 
      <Keywords>0x80000000000000</Keywords> 
      <TimeCreated SystemTime="2013-08-05T08:39:18.000000000Z" /> 
      <EventRecordID>3227</EventRecordID> 
      <Channel>Application</Channel> 
      <Computer>MOBIL-2013-WEN</Computer> 
      <Security /> 
      </System>
    - <EventData>
      <Data>RotF.exe</Data> 
      <Data>1.0.10900.0</Data> 
      <Data>5122c65d</Data> 
      <Data>KERNELBASE.dll</Data> 
      <Data>6.1.7601.18015</Data> 
      <Data>50b83c8a</Data> 
      <Data>00000001</Data> 
      <Data>0000c41f</Data> 
      <Data>13c4</Data> 
      <Data>01ce91b737adb19c</Data> 
      <Data>D:\Program Files (x86)\Company\NewProduct\Binaries\Win32\RotF.exe</Data> 
      <Data>C:\Windows\syswow64\KERNELBASE.dll</Data> 
      <Data>83eb0d3d-fdaa-11e2-a903-e02a82948601</Data> 
      </EventData>
      </Event>

    Windows Error Report:
    Code:
    Fehlerbucket 3744137796, Typ 1
    Ereignisname: APPCRASH
    Antwort: Nicht verfügbar
    CAB-Datei-ID: 0
    
    Problemsignatur:
    P1: RotF.exe
    P2: 1.0.10900.0
    P3: 5122c65d
    P4: KERNELBASE.dll
    P5: 6.1.7601.18015
    P6: 50b83c8a
    P7: 00000001
    P8: 0000c41f
    P9: 
    P10: 
    
    Angefügte Dateien:
    C:\Users\Daniel\AppData\Local\Temp\WERB4BE.tmp.WERInternalMetadata.xml
    
    Diese Dateien befinden sich möglicherweise hier:
    C:\Users\Daniel\AppData\Local\Microsoft\Windows\WER\ReportArchive\AppCrash_RotF.exe_b9121988d5abff6787aeb7b6d479988e73fa7_10d2c38d
    
    Analysesymbol: 
    Es wird erneut nach einer Lösung gesucht: 0
    Berichts-ID: 83eb0d3d-fdaa-11e2-a903-e02a82948601
    Berichtstatus: 0
    Code:
    - <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
    - <System>
      <Provider Name="Windows Error Reporting" /> 
      <EventID Qualifiers="0">1001</EventID> 
      <Level>4</Level> 
      <Task>0</Task> 
      <Keywords>0x80000000000000</Keywords> 
      <TimeCreated SystemTime="2013-08-05T08:39:22.000000000Z" /> 
      <EventRecordID>3228</EventRecordID> 
      <Channel>Application</Channel> 
      <Computer>MOBIL-2013-WEN</Computer> 
      <Security /> 
      </System>
    - <EventData>
      <Data>3744137796</Data> 
      <Data>1</Data> 
      <Data>APPCRASH</Data> 
      <Data>Nicht verfügbar</Data> 
      <Data>0</Data> 
      <Data>RotF.exe</Data> 
      <Data>1.0.10900.0</Data> 
      <Data>5122c65d</Data> 
      <Data>KERNELBASE.dll</Data> 
      <Data>6.1.7601.18015</Data> 
      <Data>50b83c8a</Data> 
      <Data>00000001</Data> 
      <Data>0000c41f</Data> 
      <Data /> 
      <Data /> 
      <Data>C:\Users\Daniel\AppData\Local\Temp\WERB4BE.tmp.WERInternalMetadata.xml</Data> 
      <Data>C:\Users\Daniel\AppData\Local\Microsoft\Windows\WER\ReportArchive\AppCrash_RotF.exe_b9121988d5abff6787aeb7b6d479988e73fa7_10d2c38d</Data> 
      <Data /> 
      <Data>0</Data> 
      <Data>83eb0d3d-fdaa-11e2-a903-e02a82948601</Data> 
      <Data>0</Data> 
      </EventData>
      </Event>
    What does it mean?

  19. #19
    The Sacrifice
    Join Date
    Apr 2011
    Location
    Hamburg, Germany
    Posts
    152

    Default

    did anyone ever find an issue to this issue? we have been getting this too at critical point: incursion (UDK July 2012)
    Project Manager
    Critical Point: Incursion Project Site & Studio Site
    CP:I are recruiting: link here
    Check our our Showcase thread here: link here
    Check our our Facebook page here: link here

  20. #20
    MSgt. Shooter Person
    Join Date
    Apr 2012
    Location
    Germany
    Posts
    71

    Default

    same here


 

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Copyright ©2009-2011 Epic Games, Inc. All Rights Reserved.
Digital Point modules: Sphinx-based search vBulletin skin by CompletevB.com.