Results 1 to 5 of 5
  1. #1
    MSgt. Shooter Person
    Join Date
    Apr 2011
    Posts
    40

    Default Critical Bink Bug when encoding Videos in Full HD

    I encountered a critical Bink Bug:
    When encoding Bink videos from full HD material (1920 x 1080, see image A) without any scaling, Bink doesn't mix the color channels correctly (i.e. shifts their on-screen position). As seen on attached image B, the encoding seems to work fine, when full HD material gets encoded/downscaled to 720p HD (1280x720). You get some of the expected blurring due to the down-scaling, but that's perfectly okay.

    However, when there is no scaling involved, i.e. Original Image A: 1920x1080 encoded to Bink 1920x1080 (Image C) you get a SIGNIFICANT off-shift in the color channels. Image C demonstrates how the RED-channel is moved up on the screen, while the grey colored area remains at the proper position.


    (Images are scaled to 200% for demonstration purposes)

    As we need to rely on Bink with UDK, this bugs seems to be unacceptable and I'm surprised that I appear to be the first one reporting it. Will that be fixed soon? Or is there a work-around in the settings that I didn't see?
    Thanks for your help in advance...

    PS: I just noticed that I cannot add attachments to posts in this forum. How are users of UDK supposed to properly report bugs for a VISUAL engine, when we're not allowed to attach images? I don't get it... Anyway, I linked the image in from our webspace.

  2. #2
    MSgt. Shooter Person
    Join Date
    Apr 2011
    Posts
    40

    Default

    UPDATE: The bug appears only if the video is displayed through a UDK project, e.g. when using it as a loading screen. So, it seems to be related to how UDK plays videos. Maybe there's a specific part in the UDK that needs to be upgraded to a newer version of the BINK player? Just guessing here...
    Last edited by Sharkster; 07-24-2012 at 11:24 AM.

  3. #3

  4. #4
    MSgt. Shooter Person
    Join Date
    Apr 2011
    Posts
    40

    Default

    Quote Originally Posted by ryanjon2040 View Post
    I also have this problem.
    Looks like UDK wasn't made for HD-quality games!

  5. #5
    MSgt. Shooter Person
    Join Date
    Apr 2011
    Posts
    40

    Default

    I also sent this "bug" to the BINK support guys and this is the answer I received:

    If you are drawing the videos with the GPU, as UDK most likely does,
    then the videos need to be a multiple of 16 in the width and height.
    So, make the movie 1088 or 1072 and it should work fine.
    It works!


 

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Copyright ©2009-2011 Epic Games, Inc. All Rights Reserved.
Digital Point modules: Sphinx-based search vBulletin skin by CompletevB.com.