Results 1 to 13 of 13
  1. #1
    MSgt. Shooter Person
    Join Date
    Jun 2011
    Posts
    60

    Default "New" Material not showing up

    Hey guys,

    All right so I'm trying to teach myself how to work with Materials, so I downloaded a texture pack from Nobiax's Deviant Art Page. (His free textures / materials are awesome, so if you haven't already, check it out.) To make things easy, I opened up the first texture from his first texture pack.

    Then I followed the following tutorial.



    And got the following results:



    I know that the specular power thing is set to 1 in that screenshot, but even what it was set to 5 and 10, it didn't appear to be working.



    When I imported the files into UDK, I didn't have any kind of special naming convention - in case that has anything to do with it.

    I'm pretty sure that I'm using the most recent version of UDK... so i'm guessing that there were some changes between the May 2010 UDK version that the Beere used to make his tutorial and the current version that i'm using.

    My problem is that even after I hit the green checkmark, nothing really happens. The circle remains a blue / white checkerboard and the material is still unusable.


    Anyone have any ideas as to what I'm doing wrong? (or where I can go to figure it out?)

    - Justin

  2. #2
    Prisoner 849
    Join Date
    Jun 2008
    Posts
    892
    Gamer IDs

    Gamertag: Black Fang666

    Default

    I guess your installation of UDK is broken.
    Want to collaborate? Want to chat UDK? Message me on Skype, Craig Delancy. Check out my UDK Youtube channel: http://www.youtube.com/user/xblBlack...ew=0&flow=grid

  3. #3

    Default

    I don't know why the checker is there, but I can see you didn't import your normal map correctly, when you import the normal maps you need to set them to use TC_Normalmap compression. If you've done it correctly it will show up more blue in the material editor (like in the tutorial image you posted)

  4. #4
    Prisoner 849
    Join Date
    Jun 2008
    Posts
    892
    Gamer IDs

    Gamertag: Black Fang666

    Default

    That would just make some normal seams, the textures aren't loaded into the material at all. What format were the textures in?
    Want to collaborate? Want to chat UDK? Message me on Skype, Craig Delancy. Check out my UDK Youtube channel: http://www.youtube.com/user/xblBlack...ew=0&flow=grid

  5. #5
    Boomshot
    Join Date
    May 2011
    Location
    Chicago
    Posts
    2,215

    Default

    I don't think the format is the problem because he would have gotten a warning that the format was wrong and it wouldn't even import the textures.

    Do you see the material preview if you open up other materials included with UDK?

  6. #6
    MSgt. Shooter Person
    Join Date
    Jun 2011
    Posts
    60

    Default

    skwisdemon - the textures are TGA files.

    Jessie G - I do see a material preview when I open up a material included in UDK



    Darthviper: I reloaded the normal map with the TC_Normalmap compression, and got a blue-er texture in the material editor.



    I noticed that my specular map appears in color, while the tutorial files has a black and white picture. Maybe there's a similar issue? What compression settings are usually used for Specular Maps when you import them? That might be it.


    Thanks for the help guys.

    - Justin

  7. #7
    MSgt. Shooter Person
    Join Date
    Jun 2011
    Location
    Germany
    Posts
    475

    Default

    UDK is fine with colored specular maps. You don't need to change the compression for specular or diffuse maps.
    Do you get a preview if you only plug one of the textures into the diffuse slot?
    Also what about other textures from nobiax pack?

    Import the textures once more, otherwise it's probably really your UDK installation that's having issues.

    Working good here, http://h9.abload.de/img/yfgfggfz1p.png
    Last edited by mAlkAv!An; 07-06-2012 at 05:25 AM.
    3.1415926535
    Blog

  8. #8
    MSgt. Shooter Person
    Join Date
    Jun 2011
    Posts
    60

    Default

    All right... well i tried it with only the diffuse texture in the diffuse slot, but nothing seems to change.




    And I also went through and tried the same thing with the textures from his second pack (without messing with the "glow") and got the same thing.




    So i'm sure that I'm just missing a step somewhere. But it's 6 am so i'm going to crash and try this again tomorrow!

  9. #9
    MSgt. Shooter Person
    Join Date
    Jun 2011
    Posts
    60

    Default

    mAlkAv!An thanks again for your suggestions. I just read your post again - and now that it's not insanely late - i actually caught that part about the UDK installation.

    But the UDK download page only lets you go back so far. The oldest build i can get is Feb 2012, so i'll try it on that. Either way thanks again for your help.

  10. #10
    MSgt. Shooter Person
    Join Date
    Jun 2011
    Location
    Germany
    Posts
    475

    Default

    Just change the date in the URL, f.e. download.udk.com/UDKInstall-2012-01-BETA.exe. All older versions are actually available.
    3.1415926535
    Blog

  11. #11
    MSgt. Shooter Person
    Join Date
    Jun 2011
    Posts
    60

    Default

    oh sweet! Thanks!

    Is there a certain build that you'd recommend for this? The tutorial used a 2010 version, but I'm not sure if that'd be going too far back... but I guess it wouldn't hurt to start experimenting. Thanks again for your help!

  12. #12
    MSgt. Shooter Person
    Join Date
    Jun 2011
    Posts
    60

    Default

    Got it - it seems to work with the Feb 2012 build. Thanks again


  13. #13
    MSgt. Shooter Person
    Join Date
    Jun 2011
    Location
    Germany
    Posts
    475

    Default

    No, it does not matter. Actually it has to work with each engine build, no matter if it's UT3, the first UDK build or the latest one. There might be something wrong with your UDK installation or your system itself. There have been several reported for the may 2012 beta so I suggest you use the Feb/March 2012 build.

    edit: too late
    Last edited by mAlkAv!An; 07-06-2012 at 05:48 PM.
    3.1415926535
    Blog


 

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Copyright ©2009-2011 Epic Games, Inc. All Rights Reserved.
Digital Point modules: Sphinx-based search vBulletin skin by CompletevB.com.