Results 1 to 17 of 17

Hybrid View

  1. #1
    MSgt. Shooter Person
    Join Date
    Feb 2012
    Posts
    66

    Default (pics inside) Animation flips skeletal mesh on wrong axis

    Hello please give me some advise on this issue ive been stuck on it for a week now. I import my skeletal mesh, animations. Create a custom animation set combining all 7 animations to one set. Create my animation tree and it all works proper.

    The issue i am having which i think its coming from not export/import from 3ds max 2012 with the right settings, is when a animation is applied or played in the previewer it flips my character from standing up right, to laying on his back. I have tried to check the root bone location to make sure its being exported at 0,0,0 but i see no location setting inside 3ds max. Please any help is much appreciated, this is the only thing holding me back...Thank You

    THE NUMBERS IN THE X,Y,Z, BOX ARE THE LOCATION OF MY MOUSE NOT THE ROOT J BONE.

    http://img713.imageshack.us/img713/2347/flipsmesh.png

    http://img100.imageshack.us/img100/3743/rootbone.png
    Last edited by stephan360; 05-08-2012 at 04:55 PM. Reason: ADD INFO OF PICTURE

  2. #2
    Marrow Fiend
    Join Date
    Jul 2006
    Location
    UT40k
    Posts
    4,634

    Default

    when you export via fbx make sure you tick the box Z axis is up
    UT40K:The Chosen - Warhammer 40,000 for UDK
    ut40kgeodav - UE4 Tutorials
    UT3 Tutorials - Characters - Weapons - Vehicles - FaceFX
    UDK Tutorials - Basics - Vehicles - Characters - Weapons

  3. #3
    MSgt. Shooter Person
    Join Date
    Feb 2012
    Posts
    66

    Default

    Thank you for the reply. I have tried both the z and y option on exporting from 3ds max none have helped. The animation was done in maya which i believe y axis is the height and when bringing into max it is z which has conflicting issues. Are there any options to set the height axis in udk to y? because exporting as z axis hasnt helped. please look at these new images in the file property is shows the file direction and system direction of the axis as different. exported as z and y still flips the mesh. thanks so much!

    http://img402.imageshack.us/img402/5018/zyconflict.png

    http://img717.imageshack.us/img717/4676/option.png

  4. #4
    Boomshot
    Join Date
    May 2011
    Location
    Chicago
    Posts
    2,215

    Default

    Did you set Z up for all of the animation files as well as the character mesh file? The axis orientation is definitely your problem. And no, the axis for UDK is fixed as far as I know.

    I use Maya and for every FBX file I export, skeletal mesh or animation files, I always have Z-up set in the FBX export settings. Double check all of your files to make sure.

  5. #5
    Prisoner 849
    Join Date
    Feb 2010
    Posts
    957

    Default

    Ohhhh... Maya. I know exactly what you're talking about. Before, ActorX had Assume Maya Coordinates option which is not available on FBX anymore so its screwy for us Maya users. Checking Z up on FBX export option does nothing as you said. Only workaround I found is to actually switch Maya's axis to Z up just before exporting. If going through preference all the time is annoying, there's MEL command you can use.

    upAxis -ax z

    I create shelf button for that and another one for changing it back to Y up.

  6. #6
    MSgt. Shooter Person
    Join Date
    Feb 2012
    Posts
    66

    Default

    well i changed it through preferences and settings to the z axis and export it. Now in 3ds max file properties say it has z-up in direction of file and system so that is good. I still am guessing the skeletal mesh itself is stuck on the y axis because in maya when i show the axis it is on y even though the viewport is on z.

    http://img42.imageshack.us/img42/8684/wtfftq.png

  7. #7
    MSgt. Shooter Person
    Join Date
    Feb 2012
    Posts
    66

    Default

    Thanks Taz, the Mel script gives me a warning that the z axis is already up. I also reset it to y axis then used the mel script to convert it to z. Still no luck.

  8. #8
    Prisoner 849
    Join Date
    Feb 2010
    Posts
    957

    Default

    If you do it from preference, it flips your model. It has different effect than doing it with command. Problem may be that you changed it in preference and then with mel? Go back to original scene that is Y up. Use the mel to change to Z up. Export. Import into Max or UDK.

  9. #9
    MSgt. Shooter Person
    Join Date
    Feb 2012
    Posts
    66

    Default

    I truly think it has to be re-rigged and animated. I have exhausted all options here. FML

  10. #10
    MSgt. Shooter Person
    Join Date
    Jun 2011
    Posts
    171

    Default

    Err, I was under the impression you left your axis as native to the program -> Z up for Max, Y up for Maya, then on import FBX UDK will figure it out. Actually that's also recommended going from Max>Maya>Max - let FBX handle it, as far as 2013 is concerned, perhaps it is slightly different in 2012, but I doubt it, I had no such problems going 2012 MAX>Maya>UDK (but unit scale will bite you if you are unwary).
    You should be able to figure out the location of the root bone in Max by selecting it, activate transform tool but don't move it - should show position in XYZ channels. Might want to do that at frame 0 with no animation on it.
    The animaton came from Maya, you say, so what are you doing in Max? I do not understand your pipeline.

  11. #11
    MSgt. Shooter Person
    Join Date
    Feb 2012
    Posts
    66

    Default

    Exporting from maya with the z up option was not workin and since Max is also z up I was trying to use it to flip the axis.but I am not familiar with either program never used maya and have dabbled in max for about 6 months in my free time which isnt much sine i fulltime work and college. I hired a animator who used maya and gave me a fbx file. I did not know the axis differences of the programs or that I would have eliminated all of these issues from the beginning.

    Fbx does absolutely nothing when choosing z up on export options so it won't figure it out. I've tried a million different ways, maybe I'm just a noob but my animater has also flipped the axis for me. I have re-installed udk. Nothing so far I'm actually done stressing it and continuing to work on other things for a bit. Thanks for info

  12. #12
    Banned
    Join Date
    Feb 2011
    Location
    BXL/Paris
    Posts
    2,169

    Default

    Quote Originally Posted by stephan360 View Post
    I'm just a noob but my animater has also flipped the axis for me.
    Problem is, that animation was made with flipped axis - you have two choice:
    1. In your 3d editor flip model to right axis and remade all animations...
    2. ...or import original mesh (flipped) in to UDK and set Rot Origin in mesh properties to right axis.

  13. #13
    MSgt. Shooter Person
    Join Date
    Feb 2012
    Posts
    66

    Default

    Exporting from maya with the z up option was not workin and since Max is also z up I was trying to use it to flip the axis.but I am not familiar with either program never used maya and have dabbled in max for about 6 months in my free time which isnt much sine i fulltime work and college. I hired a animator who used maya and gave me a fbx file. I did not know the axis differences of the programs or that I would have eliminated all of these issues from the beginning.

    Fbx does absolutely nothing when choosing z up on export options so it won't figure it out. I've tried a million different ways, maybe I'm just a noob but my animater has also flipped the axis for me. I have re-installed udk. Nothing so far I'm actually done stressing it and continuing to work on other things for a bit. Thanks for info

  14. #14
    MSgt. Shooter Person
    Join Date
    Feb 2012
    Posts
    66

    Default

    What's with this thread buggin out....I made a reply yesterday looks like vendor x did as well neither of them showing. 12 replies only 10 visible. There was a option inside udk on the rot>roll add 90 positive to counter balance the -90. This is a temporary fix.

    When a animation is played he's upright when no animation is played he's laying down so it's reversed for now but at least I can move around inside my level to start programming functions. I will post pic when I get home.

  15. #15
    MSgt. Shooter Person
    Join Date
    Feb 2012
    Posts
    66

    Default

    Hmmm guess its my iPhone not showing all threads now I can see them. Thank you vendor x this is what nestor_chavez showed me last night and it has worked. One question is what about when animation isn't applied to him.

    Because its originally at -90 so I put +90>roll To make him upright. But when animation isn't played he goes back to his original state of -90. "laying down"

    *update* " I think I see what your saying vendor. I Can't give it a go for a while since I'm at work, then going to dinner for mothers day but will try it ASAP. Thank you"
    Last edited by stephan360; 05-13-2012 at 12:37 PM.

  16. #16
    MSgt. Shooter Person
    Join Date
    Feb 2012
    Posts
    66

    Default

    There are many options here i am trying a few of them and the kid goes shooting out of the grid.
    Last edited by stephan360; 05-13-2012 at 09:11 PM.

  17. #17

    Default

    I know I'm super-late to this, but I was having the same problem, and was unable to fix it with any of the aforementioned solutions. However, I finally figured out that if you go to mesh properties -> move -> pitch and set it to -90, it will fix it in-game. It'll look ridiculous in the editor, but at least it's an easy fix


 

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Copyright ©2009-2011 Epic Games, Inc. All Rights Reserved.
Digital Point modules: Sphinx-based search vBulletin skin by CompletevB.com.