Results 1 to 9 of 9
  1. #1
    MSgt. Shooter Person
    Join Date
    Feb 2012
    Posts
    77

    Default Make Feet Disappear

    Hello,

    I'm running a UTgame and having trouble making my player's feet disappear (or maybe they aren't feet but they are under my character when I look down). I'm running a UTgame instead of UDKgame in world properties because I want the footstep sound effects. I've removed the hud and weapons by setting the world properties window check "no default inventory for player and setting togglecinematic mode in kismet.




    Thoughts?

  2. #2
    Boomshot
    Join Date
    May 2011
    Location
    Chicago
    Posts
    2,215

    Default

    Those are actually the arms of your first person view. With the inventory being cleared, they have nothing to do so they just float there. On page two of the following thread I put up a tutorial for custom game types with custom footsteps as well. The pawn for that doesn't show the arms and you can add new footstep sounds without editing UT code.

    http://forums.epicgames.com/threads/...4#post28677934


    If you simply just want to get rid of the arms and NOT add your own custom footsteps later on down the line, this is the easiest solution to your problem:

    First, make sure UDK is closed and go to your UDK folder and navigate to Development --> Src---> UTGame --> Classes. Now make a copy of the first file and change the name of that file to "BlankWeapon.uc". Open it up in notepad, delete everything from it, and paste this in:

    Code:
    class BlankWeapon extends Weapon;
    
    defaultproperties
    {
    
    }
    and save it.

    Now open up UDK and pick yes to rebuild your scripts. Open your map and in Kismet make a player Spawned event node, right click again and go to New Action-->Pawn--> Give Inventory and connect the out of the player spawned to this. Place a player variable node as the target. Click on the Give Inventory node, and turn on "Clear Existing" in its properties and lastly, click the green plus sign on the right of "Inventory List" and pick "BlankWeapon". Now when you spawn the arms should be gone because you have a "weapon" that's really just nothing.

    You can use "none" in the inventory list as well, but you'll get annoying kismet warnings. This method is cleaner and gives you a universal blank weapon that you can use in any project.
    Last edited by JessieG; 04-30-2012 at 04:35 AM.

  3. #3
    MSgt. Shooter Person
    Join Date
    Feb 2012
    Posts
    77

    Default

    WTF? THOSE ARE ARMS?!? :\

    I'll try your suggestion out. Thanks a lot.

  4. #4
    Boomshot
    Join Date
    May 2011
    Location
    Chicago
    Posts
    2,215

    Default

    Haha yeah. You can see what they look like if you search through the skeletal meshes in the content browser for them. They're pretty much down and floating because there's no code for them to remain hidden from the player if their inventory is removed (since UT game modes have default weapons loaded). I think they may just be there if someone wants to use them without having to make new arms.

  5. #5
    MSgt. Shooter Person
    Join Date
    Feb 2012
    Posts
    77

    Default

    Hmm,

    The BlankWeapon.uc method did not work for me. I set it up exactly as you said but I still see my arms. :[

    Is there some world properties that could be messing things up?

  6. #6
    Prisoner 849
    Join Date
    Feb 2010
    Posts
    957

    Default

    Here is kismet way to do it. You need to re-enable "no default inventory" in World Properties first for this to work.



    Question mark is object variable and under Give Inventory node, check Clear Existing. Also set max trigger count on Player spawned to 0.

  7. #7
    Boomshot
    Join Date
    May 2011
    Location
    Chicago
    Posts
    2,215

    Default

    That method throws kismet warnings though, which is why I suggested making a blank weapon to assign to the player.

    Are you sure you named the .uc file correctly? The name of the file has to be the same as whatever you put after the word "class" in the code, and it's case sensitive. So if the code says "class BlankWeapon extends Weapon" the file should be named "BlankWeapon" with the B and W capitalized.

  8. #8
    Prisoner 849
    Join Date
    Feb 2010
    Posts
    957

    Default

    Quote Originally Posted by JessieG View Post
    That method throws kismet warnings though, which is why I suggested making a blank weapon to assign to the player.
    I don't get any kismet errors. There was a version last year that did but not anymore.

  9. #9
    Boomshot
    Join Date
    May 2011
    Location
    Chicago
    Posts
    2,215

    Default

    Did you modify any ini files to not show them? The warning is brief, but definitely there in my version. I've been using the January 2012 build though so it might not be present in current builds. I'm waiting for whenever the next release is to upgrade.


 

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Copyright ©2009-2011 Epic Games, Inc. All Rights Reserved.
Digital Point modules: Sphinx-based search vBulletin skin by CompletevB.com.