Results 1 to 9 of 9
  1. #1
    Skaarj
    Join Date
    Jun 2010
    Location
    Dorset, UK
    Posts
    14
    Gamer IDs

    Gamertag: Paradux

    Default FBX Smoothing Groups error when importing. Cannot combine mesh.

    Hi all.

    I get this error a lot when trying to import models.


    I have FBX set to export smoothing groups. I am using Maya 2011 with latest FBX plugin, and all my normals are set at 30 degrees. Maya doesn't have smoothing groups so they must be generated on the FBX export. If I uncheck 'combine mesh' the error pops up but still imports the separate meshes and materials. If I check it, it completely fails and sometimes crashes UDK for a bit.

    Any ideas anyone?

    Thanks.
    Attached Images Attached Images

  2. #2

    Default

    Quote Originally Posted by Paradux View Post
    Hi all.

    I get this error a lot when trying to import models.


    I have FBX set to export smoothing groups. I am using Maya 2011 with latest FBX plugin, and all my normals are set at 30 degrees. Maya doesn't have smoothing groups so they must be generated on the FBX export. If I uncheck 'combine mesh' the error pops up but still imports the separate meshes and materials. If I check it, it completely fails and sometimes crashes UDK for a bit.

    Any ideas anyone?

    Thanks.

    hey did you fix this ? I am having the exact same problem using maya 2012 when I import my car into udk it says the same, fbx doesnt seem to export the smoothing groups and all they edges become hard :/

  3. #3
    MSgt. Shooter Person
    Join Date
    Mar 2012
    Location
    Chicago Il
    Posts
    275

    Default

    "Please make sure to enable 'export smoothing groups' option in the FBX exporter"

  4. #4
    Skaarj
    Join Date
    Jun 2010
    Location
    Dorset, UK
    Posts
    14
    Gamer IDs

    Gamertag: Paradux

    Default

    @DGlow As I mentioned in my post I have enabled smoothing groups in FBX exporter, I did read the error message!

    @Blue3agle I got around this by setting all normal angles in Maya to 30 degrees. On one of my models I had some flipped normals and some hidden geometry. I fixed these and it worked. Hope this helps!

  5. #5
    MSgt. Shooter Person
    Join Date
    Jan 2012
    Location
    Eynsford, Kent
    Posts
    134

    Default

    If you have access to max, just Send to max and set groups and export.
    Make Something Unreal Live 2012 Winner
    Environmental Artist @CommandoKiwi

  6. #6
    Prisoner 849
    Join Date
    Feb 2010
    Posts
    957

    Default

    Maya does have smoothing groups it's just called differently. Unlock normals and use soften/harden edge. Don't use average normals. You could but results will be unpredictable.

  7. #7

    Default

    sorry for the late reply !!

    what Paradux and DGlow said was perfectly correct and fixed all problems for future reference to others !!

    thanks again

  8. #8
    MSgt. Shooter Person
    Join Date
    Nov 2009
    Location
    Austin, TX
    Posts
    209
    Gamer IDs

    Gamertag: ST Omega

    Default

    Maya FBX > Unreal works perfectly fine, trust me. This is a case of user error.
    Environment Artist
    Certain Affinity

  9. #9
    Veteran

    Join Date
    Dec 2002
    Location
    A world of possibilities
    Posts
    6,142

    Default

    You get that error because you don't have "import tangents" checked in UDK's import.
    I run VoxHouse (VHSGames) and the UnrealDB.
    Film & Game producer, using and teaching UDK & Unreal Engine 4. Please stop by and say a good word on my project thread.
    Also feel free to join us on #udkc irc.gamesurge.net or via web: http://myclodel.com to chat live with others in the UDK community.


 

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Copyright ©2009-2011 Epic Games, Inc. All Rights Reserved.
Digital Point modules: Sphinx-based search vBulletin skin by CompletevB.com.