Results 1 to 3 of 3
  1. #1

    Default Can't deploy to device

    So, I have had a problem deploying an executable to all of my devices since the first UDK version I've used (December 2011).

    I use this same set of Provisioning Profile and Certificates to deploy applications from XCode without any problems, so I don't understand what's wrong.

    Here is the output of the frontend:

    Saving IPA ...
     ... Writing updated Info.plist
    Opening source executable...
    ... Initial signature step
    IPP ERROR: Application exception: System.Security.Cryptography.CryptographicException: Keyset does not exist
       at System.Security.Cryptography.Pkcs.PkcsUtils.CreateSignerEncodeInfo(CmsSigner signer, Boolean silent)
       at System.Security.Cryptography.Pkcs.SignedCms.Sign(CmsSigner signer, Boolean silent)
       at System.Security.Cryptography.Pkcs.SignedCms.ComputeSignature(CmsSigner signer, Boolean silent)
       at MachObjectHandling.CodeDirectorySignatureBlob.SignCodeDirectory(X509Certificate2 SigningCert, DateTime SigningTime, CodeDirectoryBlob CodeDirectory)
       at iPhonePackager.CodeSignatureBuilder.PerformSigning()
       at iPhonePackager.CookTime.RepackageIPAFromStub()
       at iPhonePackager.Program.Main(String[] args)
    [Apr 8, 4:45 AM] COMMANDLET 'iPhonePackager.exe RepackageIPA UDKGame Release -interactive -compress=none -sign -r INT' FAILED
    Any help would be greatly appreciated. I have already tried regenerating new versions of both certificates and Provisioning Profile, re-installing UDK (I'm on March 2012).

  2. #2


    My answer was to create a new certificate with the Signing Request (csr) generated by IPhonePackager utility, and my old keys.

    This worked and now I can deploy to my devices.
    Last edited by skumancer; 04-11-2012 at 04:29 AM.

  3. #3
    Join Date
    Apr 2012
    Boston, MA


    My solution to this also involved resigning a certificate, but I just went to the iOS Dev portal. I also had to export a set of keys from my Keychain assistant in OSX. Be very careful to do it from the certificates page.

    After this, I thought I was done, which led me to your post. I also had to go to the iPhonePackager utility and bring in my encrypted key created in OSX. Crazy, since it would work from Frontend, but I'm not complaining.




Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
Copyright ©2009-2015 Epic Games, Inc. All Rights Reserved.
Digital Point modules: Sphinx-based search vBulletin skin by