Results 1 to 12 of 12
  1. #1

    Default Segmentation fault

    Hello

    This is my first time I want to run a UT3 server on Linux. I use Debian Squeeze (6) 64-bit as operating system. I try to follow the steps on http://forums.epicgames.com/threads/...dicated-Server but I keep getting a 'Segmentation fault' error while trying to run the .bin-file (./UT3-linux-server-12172007.bin) to let it install the server files.

    As I saw on the forum there are some problems caused by SELINUX. I've tried to disable it, but I'm not really sure if it's disabled as I keep getting the error. When I typ this as root: 'cat /selinux/enforce' it shows me 0 (as far as I understand this means SELINUX is turned of?). I have rebooted the system and also downloaded the .bin-file from other minors.

    I hope someone of you professionals are able to help me further so I can play this awsome game with my friends!

    (Sorry for my bad English)

  2. #2

    Default

    I want to play with my friends so I hope someone can help me soon? The activity on this forum seems a bit 'down'?

  3. #3

    Default

    Nobody can help me further? I would really approciate the help so I can play UT3 (THE BEST SHOOTER OUT THERE) with my friends!

  4. #4

    Default

    It may be a corrupt file.
    Don forget the lastest patch: UT3-linux-server-04292009.bin

    Check the md5.

    UT3-linux-server-12172007.bin
    70149f802efc087455a87f92c1485982

  5. #5

    Default

    Thanks for the response! First of all, how do I check the md5 in Debian? Also, like I've told, I've downloaded the file from different minors. Also I didn't update anything because the tutorial tells me I have to install (extract) the bin-file first. Or am I wrong?

    EDIT: I've checked the MD5 of the file (UT3-linux-server-12172007.bin) and it is the same as yours: 70149f802efc087455a87f92c1485982. So the file is not corrupt. Is there any other reason why I get the segmentation fault? Do I need to run the patches first?
    Last edited by lolleflikker; 04-09-2012 at 06:08 AM.

  6. #6

    Default

    Nobody else can help me? (BUMP)

    Thanks!

  7. #7

    Default

    if rattlesn4k3 cant help you then i doubt anyone else can.

    - i can only suggest an expansion of your search; maybe to encompass all games-
    // or at least all unreal games; that have encountered a similar issue with "segmentations faults"
    - maybe something from ut2004 might help [dunno i just speculating]
    http://www.unrealadmin.org/forums/sh...ad.php?t=30593
    ^^

  8. #8

    Default

    I've already tried some fixes from UT2004. But they do not fix anything. So here is my question again: do I need to apply the patches first before I try to run the bin-file? By doing ./UT3-linux-server-12172007.bin it should begin extracting (installing) itself, or am I wrong?

    Thanks!

  9. #9

    Default

    Is there please someone else that can help me? I would be really happy

  10. #10

    Default

    The linux support for UT3 (UnrealEngine 3) is very limited. I would suggest to use a different linux distribution (if it's an OS problem). Or try to get more information on searching the web.
    The bin file is a installer. Yes.

  11. #11

    Default

    So, I finally had time to install a new OS. I'm now using Ubuntu and the UT3 server is working fine! It starts perfectly without any errors. I see the NAT is moderate, but I have no idea if this is correct? I have no firewall or router that is blocking my ports. The only problem I'm facing now is that the server is not on de serverlist. I can only join it by typing 'open IP:PORT' in the console. Also adding it to favorites gives me ping 999, no player count and no map and gametype information.

    I have already searched the web and found some topics where they have discussed the same problem. And it seems to be some Administration problems? I have already tried to run the server as root but that did not help. Any other suggestions?

    Code:
    ./ut3 Server VCTF-Suspense?game=UTGameContent.UTVehicleCTFGame_Content?bIsDedicated=True?bShouldAdvertise=True?MaxPlayers=32?MinNetPlayers=1?TimeLimit=20 -login=loginname -password=loginpassword -unattended
    Thank you very much!

  12. #12

    Default

    It's been a while now and I still don't have any answers. Maybe someone who's reading this can help me? Many thanks!


 

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Copyright ©2009-2011 Epic Games, Inc. All Rights Reserved.
Digital Point modules: Sphinx-based search vBulletin skin by CompletevB.com.