Results 1 to 6 of 6
  1. #1
    MSgt. Shooter Person
    Join Date
    Feb 2012
    Posts
    41

    Default Hidden object takes damage

    I have hidden a KActor object but if its shot it still takes damage.

    Is there a way I can easily prevent this whilst it remains hidden, when its not hidden I'd like it to take damage.

    The only way I can think is to use matinee and move it out of the way as I hide it and move it back as I toggle it from hidden.

    I have 50 of these objects hence why Iam reluctant to use the matinee solution e.g. only 1 will ever be not hidden and its random as to which one is unhidden at any given time.

  2. #2
    Veteran
    Join Date
    Sep 2006
    Location
    Unreal Nomad
    Posts
    7,682
    Gamer IDs

    Gamertag: ambershee

    Default

    If you hide something, it is still there. Teleporting the actor is probably the way to do it.
    - Please do not send me questions regarding programming or implementing things in UDK via Private Message. I do not have time to respond and they are much better answered in the forums. -

  3. #3

  4. #4
    MSgt. Shooter Person
    Join Date
    Feb 2012
    Posts
    41

    Default

    Thanks for the suggestions.

    Regarding the setting to no collision, I tried in Kismet using a Modify Property of the object by using these settings. the Property Name as ECollisionType, Ticking the Modify Property and the Property Value as COLLIDE_NoCollision.

    I guess I haven't done this correctly as that doesn't seem to work.

  5. #5
    Banned
    Join Date
    Feb 2011
    Location
    BXL/Paris
    Posts
    2,169

    Default

    TakeDamage in KActor is an event, you can disable it by calling Disable('TakeDamage');

  6. #6
    MSgt. Shooter Person
    Join Date
    Nov 2006
    Posts
    97

    Default

    Quote Originally Posted by yummy-vegetables View Post
    Thanks for the suggestions.

    Regarding the setting to no collision, I tried in Kismet using a Modify Property of the object by using these settings. the Property Name as ECollisionType, Ticking the Modify Property and the Property Value as COLLIDE_NoCollision.

    I guess I haven't done this correctly as that doesn't seem to work.
    Use the "Actor>Change collision" node instead.


 

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Copyright ©2009-2011 Epic Games, Inc. All Rights Reserved.
Digital Point modules: Sphinx-based search vBulletin skin by CompletevB.com.