Results 1 to 17 of 17
  1. #1
    MSgt. Shooter Person
    Join Date
    Nov 2008
    Location
    California
    Posts
    58

    Unhappy "No suitable matches can be found"

    Alright so first things first. I am in a college dorm room. They have security settings so to plug my Xbox into the wall I needed to clone the Mac (or physical) adress of my laptop. I get on the internet fine, I can play any other 360 game online (cod 4, black ops, gears of war 1&2, bfbc2) but when I try to connect to a match in Gears 3 It searches through games, finds them but never attempts to join any. It just says "No suitable matches can be found" and keeps searching. I left it for about 20 minutes one time and never got into a game.

    Any help would be GREATLY appriciated. I am dying to sink some good multiplayer hours into the game.

    Thanks everyone.

  2. #2

    Default

    I'm having the same problem, but only when it comes to Beast mode. It'll never load a game for me. Horde and Versus work fine, however. Strange...

  3. #3
    MSgt. Shooter Person
    Join Date
    Nov 2008
    Location
    California
    Posts
    58

    Default

    Its weird that horde works but Beast doesn't. I know that Versus has dedicated servers but beast and horde don't. I'm sure that has something to do with it. I wish i could get versus to work. I can connect to the wireless network But i have an insane amount of packet loss (every few seconds my guy teleports around the map) and I end up dead

  4. #4
    MSgt. Shooter Person
    Join Date
    Nov 2008
    Location
    California
    Posts
    58

    Default

    UPDATE: When I try to join a friends game I get an error message saying "connection to host cannot be established" please help!

  5. #5
    Skaarj
    Join Date
    Sep 2011
    Location
    Philippines
    Posts
    14

    Default

    This happened to me once. I was trying to join him while I was in matchmaking. I succeeded joining him when I joined from the main menu.

  6. #6
    Redeemer
    Join Date
    Dec 2008
    Location
    INDIA
    Posts
    1,285

    Default

    can you post your speedtest and pingtest maybe that can help
    THANK YOU EPIC FOR DEDICATED SERVERS IN INDIA FOR GEARS3

  7. #7
    MSgt. Shooter Person
    Join Date
    Nov 2008
    Location
    California
    Posts
    58

    Default

    Yeah its not a fast connection by any means. But it gets around 1-2 megs at a good time of day download. It gets 0 packet loss and barely any jitter 1-3ms. So its a good quality connection but for some reason i'm getting obnoxiously slow download speeds over Xbox live. I'm not sure why that is but i think the matchmaking detects that and doesn't put me in a game. Which is unfortunate because the connection works fine in every other game.

  8. #8
    Redeemer
    Join Date
    Dec 2008
    Location
    INDIA
    Posts
    1,285

    Default

    to play gears u need a beast connection, not necessarily high speed but low pings is very important
    THANK YOU EPIC FOR DEDICATED SERVERS IN INDIA FOR GEARS3

  9. #9
    MSgt. Shooter Person
    Join Date
    Nov 2008
    Location
    California
    Posts
    58

    Default

    Yeah but the weird thing is that I can play the game on a ****ty wireless connection. It has as much as 30% packet loss, a ton of jitter, (gets a D or F on pingtest.net) and It connects to a match almost instantly. But when I plug my xbox into the better wired connection It'll sit in the matchmaking window for a half hour straight never finding a game.

  10. #10

    Default

    It's not just you man, and I highly doubt its your connection. I am having the exact same problems, even with a decent wired connection, and "NAT TYPE - OPEN". I even usually have STRICT, and I never had a problem getting into GOW2 matches, or GOW3 Beta. It's obviously a problem with Epic's servers, or something to do with the game. I can't connect to 2 of my friends at all, even for co-op campaign yet.

  11. #11
    MSgt. Shooter Person
    Join Date
    Nov 2008
    Location
    California
    Posts
    58

    Default

    I really hope this gets fixed because I can't take playing on wireless anymore its too frustrating. Hopefully epic helps out their fans even the minorities that are having problems.

  12. #12
    Skaarj
    Join Date
    Sep 2011
    Location
    Philippines
    Posts
    14

    Default

    Yes I hope so too. I'll be playing this for years if they fix it.

  13. #13

    Angry

    CANT FIND MATCHES IN BEAST MODE ...The server having a problem that need to be fix I hope they will do it...

  14. #14

    Default

    I got the same msg when attempting to join a horde game ... let it sit for 5 minutes and was able to finally join one game and then one by one people got disconnected.

  15. #15

    Default

    Having the same issue, takes forever to connect to a game, but when I join with friends it loads and runs flawlessly... What's going on?

  16. #16
    Banned
    Join Date
    Dec 2007
    Location
    New York City & Toronto
    Posts
    324

    Default

    I am experiencing the exact same issues in both Horde and Beast/Locust mode.

  17. #17

    Default

    This has been happening to me the last month..... i got to play for a day after the update and then it happened again ..... no one seems to know how to fix it... im on wireless.... I just want to play :s


 

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •